aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-turbocheetah/Makefile45
-rw-r--r--devel/py-turbocheetah/distinfo3
-rw-r--r--devel/py-turbocheetah/files/pkg-deinstall.in17
-rw-r--r--devel/py-turbocheetah/files/pkg-install.in16
-rw-r--r--devel/py-turbocheetah/pkg-descr4
-rw-r--r--devel/py-turbocheetah/pkg-plist19
7 files changed, 105 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0aee828bcbb4..51823fd9d8e4 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1802,6 +1802,7 @@
SUBDIR += py-testgears
SUBDIR += py-tconfpy
SUBDIR += py-testoob
+ SUBDIR += py-turbocheetah
SUBDIR += py-turbojson
SUBDIR += py-turbokid
SUBDIR += py-twisted
diff --git a/devel/py-turbocheetah/Makefile b/devel/py-turbocheetah/Makefile
new file mode 100644
index 000000000000..b31d6ff620e4
--- /dev/null
+++ b/devel/py-turbocheetah/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: py-turbocheetah
+# Date created: 2006-12-01
+# Whom: Nicola Vitale <nivit@email.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= TurboCheetah
+PORTVERSION= 0.9.5
+CATEGORIES= devel python
+MASTER_SITES= http://files.turbogears.org/eggs/ \
+ http://nivi.interfree.it/distfiles/${PORTNAME}/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${TURBOCHEETAH_EGG}
+EXTRACT_SUFX=
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= TurboGears plugin to support use of Cheetah templates
+
+BUILD_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS+= cheetah:${PORTSDIR}/devel/py-cheetah
+
+USE_PYTHON= 2.4
+
+NO_BUILD= yes
+
+SUB_FILES+= pkg-deinstall pkg-install
+SUB_LIST+= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR} \
+ EGG="${PORTNAME}==${PORTVERSION}"
+
+EASY_INSTALL= ${LOCALBASE}/bin/easy_install
+EASY_INSTALL_ARGS= -b ${WRKSRC} -N -d ${PYTHON_SITELIBDIR} -s ${PREFIX}/bin
+
+DATADIR= ${PYTHON_SITELIBDIR}/${TURBOCHEETAH_EGG}
+
+TURBOCHEETAH_EGG= ${PORTNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+
+do-install:
+ ${EASY_INSTALL} ${EASY_INSTALL_ARGS} ${DISTDIR}/${DISTFILES}
+
+.include <bsd.port.mk>
diff --git a/devel/py-turbocheetah/distinfo b/devel/py-turbocheetah/distinfo
new file mode 100644
index 000000000000..63dd2a7864d2
--- /dev/null
+++ b/devel/py-turbocheetah/distinfo
@@ -0,0 +1,3 @@
+MD5 (TurboCheetah-0.9.5-py2.4.egg) = 68616454b994f1f87b1bd5b0689a0f4d
+SHA256 (TurboCheetah-0.9.5-py2.4.egg) = 289f8b3b2d5f11ce2cf63d3ccbce7646e5176830dfed396a3ad0872e839d412e
+SIZE (TurboCheetah-0.9.5-py2.4.egg) = 7492
diff --git a/devel/py-turbocheetah/files/pkg-deinstall.in b/devel/py-turbocheetah/files/pkg-deinstall.in
new file mode 100644
index 000000000000..c2a4012d7b2e
--- /dev/null
+++ b/devel/py-turbocheetah/files/pkg-deinstall.in
@@ -0,0 +1,17 @@
+#!/bin/sh
+# $FreeBSD$
+PKGNAME=$1
+#
+case $2 in
+ DEINSTALL)
+ easy_install -q -N -m -x -S %%PYTHON_SITELIBDIR%% %%EGG%%
+ ;;
+ POST-DEINSTALL)
+ exit 0
+ ;;
+ *)
+ echo "Unexpected Argument $2!!!"
+ exit 1
+ ;;
+esac
+exit 0
diff --git a/devel/py-turbocheetah/files/pkg-install.in b/devel/py-turbocheetah/files/pkg-install.in
new file mode 100644
index 000000000000..9cddbe28f167
--- /dev/null
+++ b/devel/py-turbocheetah/files/pkg-install.in
@@ -0,0 +1,16 @@
+#!/bin/sh
+# $FreeBSD$
+PKGNAME=$1
+#
+case $2 in
+ POST-INSTALL)
+ easy_install -q -N -S %%PYTHON_SITELIBDIR%% %%EGG%%
+ ;;
+ PRE-INSTALL)
+ ;;
+ *)
+ echo "Unexpected Argument $2!!!"
+ exit 1
+ ;;
+esac
+exit 0
diff --git a/devel/py-turbocheetah/pkg-descr b/devel/py-turbocheetah/pkg-descr
new file mode 100644
index 000000000000..be26397c7354
--- /dev/null
+++ b/devel/py-turbocheetah/pkg-descr
@@ -0,0 +1,4 @@
+TurboGears plugin to support use of Cheetah templates.
+
+Author: Kevin Dangoor
+WWW: http://www.turbogears.org/docs/plugins/template.html
diff --git a/devel/py-turbocheetah/pkg-plist b/devel/py-turbocheetah/pkg-plist
new file mode 100644
index 000000000000..e95b920c7c66
--- /dev/null
+++ b/devel/py-turbocheetah/pkg-plist
@@ -0,0 +1,19 @@
+@comment $FreeBSD$
+%%DATADIR%%/EGG-INFO/PKG-INFO
+%%DATADIR%%/EGG-INFO/SOURCES.txt
+%%DATADIR%%/EGG-INFO/entry_points.txt
+%%DATADIR%%/EGG-INFO/not-zip-safe
+%%DATADIR%%/EGG-INFO/requires.txt
+%%DATADIR%%/EGG-INFO/top_level.txt
+%%DATADIR%%/turbocheetah/__init__.py
+%%DATADIR%%/turbocheetah/__init__.pyc
+%%DATADIR%%/turbocheetah/cheetahsupport.py
+%%DATADIR%%/turbocheetah/cheetahsupport.pyc
+%%DATADIR%%/turbocheetah/tests/__init__.py
+%%DATADIR%%/turbocheetah/tests/__init__.pyc
+%%DATADIR%%/turbocheetah/tests/test_template.py
+%%DATADIR%%/turbocheetah/tests/test_template.pyc
+@dirrm %%DATADIR%%/turbocheetah/tests
+@dirrm %%DATADIR%%/turbocheetah
+@dirrm %%DATADIR%%/EGG-INFO
+@dirrm %%DATADIR%%