aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Hook-LexWrap/Makefile28
-rw-r--r--devel/p5-Hook-LexWrap/distinfo2
-rw-r--r--devel/p5-Hook-LexWrap/pkg-descr4
-rw-r--r--devel/p5-Hook-LexWrap/pkg-plist6
5 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ffe4e0b7f3a5..1e1d72ff219c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -789,6 +789,7 @@
SUBDIR += p5-Getopt-Mixed
SUBDIR += p5-Glib2
SUBDIR += p5-Heap
+ SUBDIR += p5-Hook-LexWrap
SUBDIR += p5-IO
SUBDIR += p5-IO-Multiplex
SUBDIR += p5-IO-String
diff --git a/devel/p5-Hook-LexWrap/Makefile b/devel/p5-Hook-LexWrap/Makefile
new file mode 100644
index 000000000000..6632ff74cf67
--- /dev/null
+++ b/devel/p5-Hook-LexWrap/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Hook-LexWrap
+# Date created: Wed Jul 7 2004
+# Whom: Anton Berezin <tobez@tobez.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Hook-LexWrap
+PORTVERSION= 0.20
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Hook
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Lexically scoped subroutine wrappers for Perl
+
+PERL_CONFIGURE= yes
+
+MAN3= Hook::LexWrap.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port only support perl 5.6.1 or above
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Hook-LexWrap/distinfo b/devel/p5-Hook-LexWrap/distinfo
new file mode 100644
index 000000000000..29ed1e1d2bde
--- /dev/null
+++ b/devel/p5-Hook-LexWrap/distinfo
@@ -0,0 +1,2 @@
+MD5 (Hook-LexWrap-0.20.tar.gz) = e3aaeb59a3adddc80ed3867e4d16654e
+SIZE (Hook-LexWrap-0.20.tar.gz) = 6369
diff --git a/devel/p5-Hook-LexWrap/pkg-descr b/devel/p5-Hook-LexWrap/pkg-descr
new file mode 100644
index 000000000000..bbb470c9814a
--- /dev/null
+++ b/devel/p5-Hook-LexWrap/pkg-descr
@@ -0,0 +1,4 @@
+Hook::LexWrap allows you to install a pre- or post-wrapper (or both)
+around an existing subroutine.
+
+WWW: http://search.cpan.org/dist/Hook-LexWrap/
diff --git a/devel/p5-Hook-LexWrap/pkg-plist b/devel/p5-Hook-LexWrap/pkg-plist
new file mode 100644
index 000000000000..b29379103b5b
--- /dev/null
+++ b/devel/p5-Hook-LexWrap/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Hook/LexWrap/.packlist
+%%SITE_PERL%%/Hook/LexWrap.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Hook/LexWrap
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Hook 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Hook 2>/dev/null || true