aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/libdsp/Makefile2
-rw-r--r--devel/libdsp/pkg-plist1
-rw-r--r--devel/libfs++/Makefile2
-rw-r--r--devel/libshbuf/Makefile2
-rw-r--r--devel/libstroke/Makefile6
-rw-r--r--devel/libzt/Makefile2
-rw-r--r--devel/libzt/pkg-plist1
-rw-r--r--devel/log4c/Makefile2
-rw-r--r--devel/mingw-binutils/Makefile2
-rw-r--r--devel/openzz/Makefile2
-rw-r--r--devel/shapelib/Makefile2
-rw-r--r--devel/styx/Makefile2
-rw-r--r--devel/t1lib/Makefile12
13 files changed, 25 insertions, 13 deletions
diff --git a/devel/libdsp/Makefile b/devel/libdsp/Makefile
index 387e848d59eb..d52cb0ea826d 100644
--- a/devel/libdsp/Makefile
+++ b/devel/libdsp/Makefile
@@ -19,7 +19,7 @@ COMMENT= C++ class library of common digital signal processing functions
WRKSRC= ${WRKDIR}/libdsp-src/${PORTNAME:S/dsp/DSP/}-${PORTVERSION}
-WANT_LIBTOOL_VER=13
+WANT_LIBTOOL_VER=15
USE_GMAKE= yes
MAKE_ENV= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" MKDIR="${MKDIR}" \
INLINE_VER="${INLINE_VER}"
diff --git a/devel/libdsp/pkg-plist b/devel/libdsp/pkg-plist
index b4f140bfd66b..0da1dead2902 100644
--- a/devel/libdsp/pkg-plist
+++ b/devel/libdsp/pkg-plist
@@ -27,7 +27,6 @@ include/dsp/X86.h
include/dsp/dspop.h
include/dsp/dsptypes.h
lib/libdsp.a
-lib/libdsp.la
lib/libdsp.so
lib/libdsp.so.5
@dirrm include/dsp
diff --git a/devel/libfs++/Makefile b/devel/libfs++/Makefile
index 620a7e512590..919e56cc96a3 100644
--- a/devel/libfs++/Makefile
+++ b/devel/libfs++/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= C++ library which provides a file_iterator class
USE_REINPLACE= yes
-USE_INC_LIBTOOL_VER= 13
+USE_LIBTOOL_VER=15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
diff --git a/devel/libshbuf/Makefile b/devel/libshbuf/Makefile
index 5cfe3bd79357..64e9ce1c5076 100644
--- a/devel/libshbuf/Makefile
+++ b/devel/libshbuf/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Library for Shared Buffer IPC
USE_REINPLACE= yes
-USE_INC_LIBTOOL_VER= 13
+USE_LIBTOOL_VER=15
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
diff --git a/devel/libstroke/Makefile b/devel/libstroke/Makefile
index bb21ca1b82dc..bf637d775261 100644
--- a/devel/libstroke/Makefile
+++ b/devel/libstroke/Makefile
@@ -16,7 +16,11 @@ COMMENT= A stroke translation library
USE_XLIB= yes
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER= 13
+USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
+post-patch:
+ @${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
+ ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/devel/libzt/Makefile b/devel/libzt/Makefile
index 7b63fd3517b4..73da7eea4360 100644
--- a/devel/libzt/Makefile
+++ b/devel/libzt/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Collection of utility code for C application/server development
GNU_CONFIGURE= yes
-USE_LIBTOOL_VER= 13
+USE_LIBTOOL_VER=15
USE_REINPLACE= yes
USE_GETOPT_LONG= yes
INSTALLS_SHLIB= yes
diff --git a/devel/libzt/pkg-plist b/devel/libzt/pkg-plist
index cd536333a8f3..c505caf8fb89 100644
--- a/devel/libzt/pkg-plist
+++ b/devel/libzt/pkg-plist
@@ -17,7 +17,6 @@ include/libzt/progname.h
include/libzt/str.h
include/libzt/zt.h
lib/libzt.a
-lib/libzt.la
lib/libzt.so
lib/libzt.so.0
@dirrm include/libzt/cfg
diff --git a/devel/log4c/Makefile b/devel/log4c/Makefile
index 0d9d81d28a06..4bf8c9758bd0 100644
--- a/devel/log4c/Makefile
+++ b/devel/log4c/Makefile
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Logging for C Library
-USE_INC_LIBTOOL_VER= 13
+USE_LIBTOOL_VER=15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
diff --git a/devel/mingw-binutils/Makefile b/devel/mingw-binutils/Makefile
index 8e1a8518785c..fe7160a14095 100644
--- a/devel/mingw-binutils/Makefile
+++ b/devel/mingw-binutils/Makefile
@@ -24,7 +24,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-20011113
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER= 13
+USE_LIBTOOL_VER=15
CONFIGURE_ARGS= --target=i386-mingw32msvc
MAN1= i386-mingw32msvc-addr2line.1 \
diff --git a/devel/openzz/Makefile b/devel/openzz/Makefile
index 14dc4f081119..cd1c58c5bd4e 100644
--- a/devel/openzz/Makefile
+++ b/devel/openzz/Makefile
@@ -19,7 +19,7 @@ COMMENT= An interpreted dynamic parser
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
USE_REINPLACE= yes
-USE_INC_LIBTOOL_VER= 13
+USE_LIBTOOL_VER=15
INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
diff --git a/devel/shapelib/Makefile b/devel/shapelib/Makefile
index 72da8f3cf575..d14171473fca 100644
--- a/devel/shapelib/Makefile
+++ b/devel/shapelib/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= http://dl.maptools.org/dl/shapelib/
MAINTAINER= ports@FreeBSD.org
COMMENT= C API for reading and writing ArcView Shapefiles
-WANT_LIBTOOL_VER=13
+WANT_LIBTOOL_VER=15
ALL_TARGET= lib
INSTALLS_SHLIB= yes
diff --git a/devel/styx/Makefile b/devel/styx/Makefile
index 4961cb41a74f..63fb3c3a51d0 100644
--- a/devel/styx/Makefile
+++ b/devel/styx/Makefile
@@ -17,7 +17,7 @@ COMMENT= A scanner/parser generator
USE_ICONV= yes
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER= 13
+USE_LIBTOOL_VER=15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib -liconv ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --includedir=${PREFIX}/include/${PORTNAME}
diff --git a/devel/t1lib/Makefile b/devel/t1lib/Makefile
index 9d9cb4a0af18..566a36f411d2 100644
--- a/devel/t1lib/Makefile
+++ b/devel/t1lib/Makefile
@@ -20,7 +20,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A Type 1 Rasterizer Library for UNIX/X11
USE_GMAKE= yes
-USE_LIBTOOL_VER= 13
+USE_REINPLACE= yes
+USE_INC_LIBTOOL_VER=15
ALL_TARGET= without_doc
INSTALLS_SHLIB= yes
@@ -33,6 +34,15 @@ CONFIGURE_ARGS+= --without-x
PLIST_SUB+= X11="@comment "
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|^LIBTOOL[ ]*=.*|LIBTOOL=${LIBTOOL}|' \
+ ${WRKSRC}/xglyph/Makefile.in ${WRKSRC}/lib/type1/Makefile.in \
+ ${WRKSRC}/lib/t1lib/Makefile.in ${WRKSRC}/lib/Makefile.in \
+ ${WRKSRC}/type1afm/Makefile.in ${WRKSRC}/examples/Makefile.in
+
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}