aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/florist-gpl/Makefile27
-rw-r--r--devel/florist-gpl/distinfo2
-rw-r--r--devel/florist-gpl/files/patch-Makefile.in18
-rw-r--r--devel/florist-gpl/files/patch-c-posix-signals.c23
-rw-r--r--devel/florist-gpl/files/patch-c-posix.c57
-rw-r--r--devel/florist-gpl/files/patch-configure21
-rw-r--r--devel/florist-gpl/files/patch-configure.in21
-rw-r--r--devel/florist-gpl/files/patch-florist.gpr20
-rw-r--r--devel/florist-gpl/files/pconfig.DragonFly4
-rw-r--r--devel/florist-gpl/files/pconfig.NetBSD6
-rw-r--r--devel/florist-gpl/pkg-descr12
-rw-r--r--devel/florist-gpl/pkg-plist196
13 files changed, 408 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index cb38573732d8..6ea81953e3a1 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -439,6 +439,7 @@
SUBDIR += flexjson
SUBDIR += flick
SUBDIR += flickrnet
+ SUBDIR += florist-gpl
SUBDIR += flowdesigner
SUBDIR += flyspray
SUBDIR += fmake
diff --git a/devel/florist-gpl/Makefile b/devel/florist-gpl/Makefile
new file mode 100644
index 000000000000..63106fde9bf3
--- /dev/null
+++ b/devel/florist-gpl/Makefile
@@ -0,0 +1,27 @@
+# Created by: John Marino <draco@marino.st>
+# $FreeBSD$
+
+PORTNAME= florist-gpl
+PORTVERSION= 2012
+CATEGORIES= devel
+MASTER_SITES= http://downloads.dragonlace.net/src/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= draco@marino.st
+COMMENT= POSIX Ada binding, IEEE Standards 1003.5(b,c)
+
+LICENSE= GPLv3
+
+USES= ada
+GNU_CONFIGURE= yes
+DESTINY= ${WRKDIR}/destino
+MAKE_ENV+= DESTDIR=${DESTINY}
+
+post-extract:
+ ${CP} ${FILESDIR}/pconfig.* ${WRKSRC}/configs
+
+post-install:
+ ${CP} -pR ${DESTINY}${PREFIX}/ ${PREFIX}/
+
+.include <bsd.port.mk>
diff --git a/devel/florist-gpl/distinfo b/devel/florist-gpl/distinfo
new file mode 100644
index 000000000000..4473198ffb70
--- /dev/null
+++ b/devel/florist-gpl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (florist-gpl-2012-src.tgz) = 6f85e137820ffd234177217cac036b7348d129a8f2b66dce6f27600461fa6a8d
+SIZE (florist-gpl-2012-src.tgz) = 224141
diff --git a/devel/florist-gpl/files/patch-Makefile.in b/devel/florist-gpl/files/patch-Makefile.in
new file mode 100644
index 000000000000..cf59dd25f39f
--- /dev/null
+++ b/devel/florist-gpl/files/patch-Makefile.in
@@ -0,0 +1,18 @@
+--- Makefile.in.orig 2012-05-10 13:32:06.000000000 +0000
++++ Makefile.in
+@@ -187,8 +187,12 @@ distclean:
+
+ # install floristlib
+ install:
+- mkdir -p $(PREFIX)/lib/gnat
+- cp -pr floristlib $(PREFIX)/floristlib
+- cp -p florist.gpr $(PREFIX)/lib/gnat
++ mkdir -p $(DESTDIR)$(PREFIX)/lib/gnat \
++ $(DESTDIR)$(PREFIX)/lib/florist \
++ $(DESTDIR)$(PREFIX)/include/florist
++ $(BSD_INSTALL_DATA) floristlib/*.ad[bs] $(DESTDIR)$(PREFIX)/include/florist
++ $(BSD_INSTALL_DATA) floristlib/*.ali $(DESTDIR)$(PREFIX)/lib/florist
++ $(BSD_INSTALL_LIB) floristlib/*.a $(DESTDIR)$(PREFIX)/lib/florist
++ $(BSD_INSTALL_DATA) florist.gpr $(DESTDIR)$(PREFIX)/lib/gnat
+
+ .PHONY: install clean distclean regen
diff --git a/devel/florist-gpl/files/patch-c-posix-signals.c b/devel/florist-gpl/files/patch-c-posix-signals.c
new file mode 100644
index 000000000000..2fc53b4e8122
--- /dev/null
+++ b/devel/florist-gpl/files/patch-c-posix-signals.c
@@ -0,0 +1,23 @@
+--- c-posix-signals.c.orig 2012-05-10 13:32:15.000000000 +0000
++++ c-posix-signals.c
+@@ -467,9 +467,9 @@ int guess_nsigs () {
+ */
+
+ #if defined(__APPLE__)
+-# define BADSIG (0)
++# define FLOR_BADSIG (0)
+ #else
+-# define BADSIG (-1)
++# define FLOR_BADSIG (-1)
+ #endif
+
+ sigset_t set;
+@@ -483,7 +483,7 @@ int guess_nsigs () {
+ result = sigismember (&set, sig);
+ if (result == 1) {
+ last_good = sig;
+- } else if ((result == BADSIG) && (first_bad == -1)) {
++ } else if ((result == FLOR_BADSIG) && (first_bad == -1)) {
+ if (sig == 0) {
+ fprintf (stderr, "WARNING: C library problem? "
+ "sigfillset does not include zero\n");
diff --git a/devel/florist-gpl/files/patch-c-posix.c b/devel/florist-gpl/files/patch-c-posix.c
new file mode 100644
index 000000000000..bbe656cf8785
--- /dev/null
+++ b/devel/florist-gpl/files/patch-c-posix.c
@@ -0,0 +1,57 @@
+--- c-posix.c.orig 2012-05-10 13:32:15.000000000 +0000
++++ c-posix.c
+@@ -689,6 +689,25 @@ typedef struct siginfo {
+
+ /* sigevent must precede aiocb
+ */
++#if defined(__DragonFly__)
++/*
++ * union _sigev_info {
++ * int sigev_signo;
++ * int sigev_notify_kqueue;
++ * void *sigev_notify_attributes;
++ * };
++ * sizeof(union _sigev_info) = sizeof(int)
++ * Use "int" rather than fooling with union
++ * For simplicity, The Ada part is only going to list sigev_signo
++ * as the other two elements of the union are unused.
++ */
++ GT1(sigevent, 1)
++ GT2(sigev_notify, int)
++ GT2(sigev_signo, int)
++ GT2(sigev_value, union sigval)
++ GT2(sigev_notify_function, void (*)(union sigval))
++ GT3
++#else /* __DragonFly__ */
+ #ifdef HAVE_struct_sigevent
+ GT1(sigevent, 1)
+ #else
+@@ -711,6 +730,7 @@ struct sigevent {
+ GT2(sigev_notify_attributes,pthread_attr_t *)
+ #endif
+ GT3
++#endif /* __DragonFly__ */
+
+ #ifdef HAVE_struct_aiocb
+ GT1(aiocb, 1)
+@@ -5130,9 +5150,9 @@ void create_c() {
+ */
+
+ #if defined(__APPLE__)
+-# define BADSIG 0
++# define FLOR_BADSIG 0
+ #else
+-# define BADSIG (-1)
++# define FLOR_BADSIG (-1)
+ #endif
+ {sigset_t set;
+ int sig;
+@@ -5143,7 +5163,7 @@ void create_c() {
+ for (sig = 0; sig < 1024; sig++) {
+ result = sigismember (&set, sig);
+ if (result == 1) last_good = sig;
+- else if ((result == BADSIG) && (first_bad = -1)) first_bad = sig;
++ else if ((result == FLOR_BADSIG) && (first_bad = -1)) first_bad = sig;
+ }
+ if (last_good == 1023)
+ printf("c-posix: WARNING: signal range estimate probably too small\n");
diff --git a/devel/florist-gpl/files/patch-configure b/devel/florist-gpl/files/patch-configure
new file mode 100644
index 000000000000..fb5f3c652c56
--- /dev/null
+++ b/devel/florist-gpl/files/patch-configure
@@ -0,0 +1,21 @@
+--- configure.orig 2009-02-17 19:18:05.000000000 +0000
++++ configure
+@@ -2278,10 +2278,18 @@ case ${UNAME_SYSTEM} in
+ echo "Using Configuration for" ${UNAME_SYSTEM} ${UNAME_RELEASE};
+ cp ./configs/pconfig.LynxOS ./pconfig.h.in;
+ ;;
++ DragonFly)
++ echo "Using Configuration for" ${UNAME_SYSTEM} ${UNAME_RELEASE};
++ cp ./configs/pconfig.DragonFly ./pconfig.h.in;
++ ;;
+ FreeBSD)
+ echo "Using Configuration for" ${UNAME_SYSTEM} ${UNAME_RELEASE};
+ cp ./configs/pconfig.FreeBSD ./pconfig.h.in;
+ ;;
++ NetBSD)
++ echo "Using Configuration for" ${UNAME_SYSTEM} ${UNAME_RELEASE};
++ cp ./configs/pconfig.NetBSD ./pconfig.h.in;
++ ;;
+ Darwin)
+ echo "Using Configuration for" ${UNAME_SYSTEM} ${UNAME_RELEASE};
+ cp ./configs/pconfig.Darwin ./pconfig.h.in;
diff --git a/devel/florist-gpl/files/patch-configure.in b/devel/florist-gpl/files/patch-configure.in
new file mode 100644
index 000000000000..67f3a206b6b2
--- /dev/null
+++ b/devel/florist-gpl/files/patch-configure.in
@@ -0,0 +1,21 @@
+--- configure.in.orig 2009-02-17 19:15:53.000000000 +0000
++++ configure.in
+@@ -113,10 +113,18 @@ case ${UNAME_SYSTEM} in
+ echo "Using Configuration for" ${UNAME_SYSTEM} ${UNAME_RELEASE};
+ cp ./configs/pconfig.LynxOS ./pconfig.h.in;
+ ;;
++ DragonFly)
++ echo "Using Configuration for" ${UNAME_SYSTEM} ${UNAME_RELEASE};
++ cp ./configs/pconfig.DragonFly ./pconfig.h.in;
++ ;;
+ FreeBSD)
+ echo "Using Configuration for" ${UNAME_SYSTEM} ${UNAME_RELEASE};
+ cp ./configs/pconfig.FreeBSD ./pconfig.h.in;
+ ;;
++ NetBSD)
++ echo "Using Configuration for" ${UNAME_SYSTEM} ${UNAME_RELEASE};
++ cp ./configs/pconfig.NetBSD ./pconfig.h.in;
++ ;;
+ Darwin)
+ echo "Using Configuration for" ${UNAME_SYSTEM} ${UNAME_RELEASE};
+ cp ./configs/pconfig.Darwin ./pconfig.h.in;
diff --git a/devel/florist-gpl/files/patch-florist.gpr b/devel/florist-gpl/files/patch-florist.gpr
new file mode 100644
index 000000000000..78339d87f6e8
--- /dev/null
+++ b/devel/florist-gpl/files/patch-florist.gpr
@@ -0,0 +1,20 @@
+--- florist.gpr.orig 2012-05-10 13:32:15.000000000 +0000
++++ florist.gpr
+@@ -1,12 +1,9 @@
+ project Florist is
+
+- for Source_Dirs use ("../../floristlib");
+- for Object_Dir use "../../floristlib";
+-
+- for Externally_Built use "True";
+-
+- package Linker is
+- for Linker_Options use ("-lflorist");
+- end Linker;
++ for Languages use ("ada");
++ for Source_Dirs use ("../../include/florist");
++ for Library_Name use "florist";
++ for Library_Dir use "../../lib/florist";
++ for Externally_Built use "true";
+
+ end Florist;
diff --git a/devel/florist-gpl/files/pconfig.DragonFly b/devel/florist-gpl/files/pconfig.DragonFly
new file mode 100644
index 000000000000..c47cae4ff151
--- /dev/null
+++ b/devel/florist-gpl/files/pconfig.DragonFly
@@ -0,0 +1,4 @@
+#define _XOPEN_SOURCE
+#define _XOPEN_SOURCE_EXTENDED 1
+#define _REENTRANT
+#define _P1003_1B_VISIBLE
diff --git a/devel/florist-gpl/files/pconfig.NetBSD b/devel/florist-gpl/files/pconfig.NetBSD
new file mode 100644
index 000000000000..453ae50d7403
--- /dev/null
+++ b/devel/florist-gpl/files/pconfig.NetBSD
@@ -0,0 +1,6 @@
+#define _POSIX_SOURCE
+#define _POSIX_C_SOURCE 199506L
+#define _XOPEN_SOURCE
+#define _XOPEN_SOURCE_EXTENDED 1
+#define _REENTRANT
+#define _P1003_1B_VISIBLE
diff --git a/devel/florist-gpl/pkg-descr b/devel/florist-gpl/pkg-descr
new file mode 100644
index 000000000000..359d76bcb628
--- /dev/null
+++ b/devel/florist-gpl/pkg-descr
@@ -0,0 +1,12 @@
+Florist was produced by students and faculty of the Florida State University
+Department of Computer Science, under contract to the US Department of
+Defense, Defense Information Systems Agency, as a product of the POSIX Ada
+Real-Time (PART) Project. When the contract was completed, in 1999, FSU turned
+maintenance of Florist over to Ada Core Technologies, Inc.). The latest and
+most complete free version is available from Adacore.
+
+FLORIST is an implementation of the IEEE Standards 1003.5: 1992,
+IEEE STD 1003.5b: 1996, and parts of IEEE STD 1003.5c: 1998, also known as
+the POSIX Ada Bindings.
+
+WWW: http://libre.adacore.com
diff --git a/devel/florist-gpl/pkg-plist b/devel/florist-gpl/pkg-plist
new file mode 100644
index 000000000000..6ad52fe1795e
--- /dev/null
+++ b/devel/florist-gpl/pkg-plist
@@ -0,0 +1,196 @@
+include/florist/ada_streams.ads
+include/florist/ada_task_identification.ads
+include/florist/deps.adb
+include/florist/deps.ads
+include/florist/deps_no_thread.adb
+include/florist/posix-asynchronous_io.adb
+include/florist/posix-asynchronous_io.ads
+include/florist/posix-c.adb
+include/florist/posix-c.ads
+include/florist/posix-calendar.adb
+include/florist/posix-calendar.ads
+include/florist/posix-condition_variables.adb
+include/florist/posix-condition_variables.ads
+include/florist/posix-configurable_file_limits.adb
+include/florist/posix-configurable_file_limits.ads
+include/florist/posix-configurable_system_limits.adb
+include/florist/posix-configurable_system_limits.ads
+include/florist/posix-error_codes.ads
+include/florist/posix-file_locking.adb
+include/florist/posix-file_locking.ads
+include/florist/posix-file_status.adb
+include/florist/posix-file_status.ads
+include/florist/posix-files.adb
+include/florist/posix-files.ads
+include/florist/posix-generic_shared_memory.adb
+include/florist/posix-generic_shared_memory.ads
+include/florist/posix-group_database.adb
+include/florist/posix-group_database.ads
+include/florist/posix-implementation-ok_signals.ads
+include/florist/posix-implementation.adb
+include/florist/posix-implementation.ads
+include/florist/posix-io.adb
+include/florist/posix-io.ads
+include/florist/posix-limits.ads
+include/florist/posix-memory_locking.adb
+include/florist/posix-memory_locking.ads
+include/florist/posix-memory_mapping.adb
+include/florist/posix-memory_mapping.ads
+include/florist/posix-memory_range_locking.adb
+include/florist/posix-memory_range_locking.ads
+include/florist/posix-message_queues.adb
+include/florist/posix-message_queues.ads
+include/florist/posix-mutexes.adb
+include/florist/posix-mutexes.ads
+include/florist/posix-options.ads
+include/florist/posix-page_alignment.adb
+include/florist/posix-page_alignment.ads
+include/florist/posix-permissions-implementation.adb
+include/florist/posix-permissions-implementation.ads
+include/florist/posix-permissions.adb
+include/florist/posix-permissions.ads
+include/florist/posix-process_environment.adb
+include/florist/posix-process_environment.ads
+include/florist/posix-process_identification.adb
+include/florist/posix-process_identification.ads
+include/florist/posix-process_primitives.adb
+include/florist/posix-process_primitives.ads
+include/florist/posix-process_scheduling.adb
+include/florist/posix-process_scheduling.ads
+include/florist/posix-process_times.adb
+include/florist/posix-process_times.ads
+include/florist/posix-semaphores.adb
+include/florist/posix-semaphores.ads
+include/florist/posix-shared_memory_objects.adb
+include/florist/posix-shared_memory_objects.ads
+include/florist/posix-signals.adb
+include/florist/posix-signals.ads
+include/florist/posix-supplement_to_ada_io.adb
+include/florist/posix-supplement_to_ada_io.ads
+include/florist/posix-terminal_functions.adb
+include/florist/posix-terminal_functions.ads
+include/florist/posix-timers-extensions.adb
+include/florist/posix-timers-extensions.ads
+include/florist/posix-timers.adb
+include/florist/posix-timers.ads
+include/florist/posix-unsafe_process_primitives.adb
+include/florist/posix-unsafe_process_primitives.ads
+include/florist/posix-user_database.adb
+include/florist/posix-user_database.ads
+include/florist/posix.adb
+include/florist/posix.ads
+include/florist/posix_asynchronous_io.ads
+include/florist/posix_c.ads
+include/florist/posix_calendar.ads
+include/florist/posix_condition_variables.ads
+include/florist/posix_configurable_file_limits.ads
+include/florist/posix_configurable_system_limits.ads
+include/florist/posix_error_codes.ads
+include/florist/posix_file_locking.ads
+include/florist/posix_file_status.ads
+include/florist/posix_files.ads
+include/florist/posix_generic_shared_memory.ads
+include/florist/posix_group_database.ads
+include/florist/posix_io.ads
+include/florist/posix_limits.ads
+include/florist/posix_memory_locking.ads
+include/florist/posix_memory_mapping.ads
+include/florist/posix_memory_range_locking.ads
+include/florist/posix_message_queues.ads
+include/florist/posix_mutexes.ads
+include/florist/posix_options.ads
+include/florist/posix_page_alignment.ads
+include/florist/posix_permissions.ads
+include/florist/posix_process_environment.ads
+include/florist/posix_process_identification.ads
+include/florist/posix_process_primitives.ads
+include/florist/posix_process_scheduling.ads
+include/florist/posix_process_times.ads
+include/florist/posix_semaphores.ads
+include/florist/posix_shared_memory_objects.ads
+include/florist/posix_signals.ads
+include/florist/posix_supplement_to_ada_io.ads
+include/florist/posix_terminal_functions.ads
+include/florist/posix_timers.ads
+include/florist/posix_unsafe_process_primitives.ads
+include/florist/posix_user_database.ads
+include/florist/system_storage_elements.ads
+lib/florist/ada_streams.ali
+lib/florist/ada_task_identification.ali
+lib/florist/libflorist.a
+lib/florist/posix-asynchronous_io.ali
+lib/florist/posix-c.ali
+lib/florist/posix-calendar.ali
+lib/florist/posix-condition_variables.ali
+lib/florist/posix-configurable_file_limits.ali
+lib/florist/posix-configurable_system_limits.ali
+lib/florist/posix-file_locking.ali
+lib/florist/posix-file_status.ali
+lib/florist/posix-files.ali
+lib/florist/posix-generic_shared_memory.ali
+lib/florist/posix-group_database.ali
+lib/florist/posix-implementation-ok_signals.ali
+lib/florist/posix-implementation.ali
+lib/florist/posix-io.ali
+lib/florist/posix-limits.ali
+lib/florist/posix-memory_locking.ali
+lib/florist/posix-memory_mapping.ali
+lib/florist/posix-memory_range_locking.ali
+lib/florist/posix-message_queues.ali
+lib/florist/posix-mutexes.ali
+lib/florist/posix-options.ali
+lib/florist/posix-page_alignment.ali
+lib/florist/posix-permissions-implementation.ali
+lib/florist/posix-permissions.ali
+lib/florist/posix-process_environment.ali
+lib/florist/posix-process_identification.ali
+lib/florist/posix-process_primitives.ali
+lib/florist/posix-process_scheduling.ali
+lib/florist/posix-process_times.ali
+lib/florist/posix-semaphores.ali
+lib/florist/posix-shared_memory_objects.ali
+lib/florist/posix-signals.ali
+lib/florist/posix-supplement_to_ada_io.ali
+lib/florist/posix-terminal_functions.ali
+lib/florist/posix-timers-extensions.ali
+lib/florist/posix-timers.ali
+lib/florist/posix-unsafe_process_primitives.ali
+lib/florist/posix-user_database.ali
+lib/florist/posix.ali
+lib/florist/posix_asynchronous_io.ali
+lib/florist/posix_calendar.ali
+lib/florist/posix_condition_variables.ali
+lib/florist/posix_configurable_file_limits.ali
+lib/florist/posix_configurable_system_limits.ali
+lib/florist/posix_file_locking.ali
+lib/florist/posix_file_status.ali
+lib/florist/posix_files.ali
+lib/florist/posix_generic_shared_memory.ali
+lib/florist/posix_group_database.ali
+lib/florist/posix_io.ali
+lib/florist/posix_limits.ali
+lib/florist/posix_memory_locking.ali
+lib/florist/posix_memory_mapping.ali
+lib/florist/posix_memory_range_locking.ali
+lib/florist/posix_message_queues.ali
+lib/florist/posix_mutexes.ali
+lib/florist/posix_options.ali
+lib/florist/posix_page_alignment.ali
+lib/florist/posix_permissions.ali
+lib/florist/posix_process_environment.ali
+lib/florist/posix_process_identification.ali
+lib/florist/posix_process_primitives.ali
+lib/florist/posix_process_scheduling.ali
+lib/florist/posix_process_times.ali
+lib/florist/posix_semaphores.ali
+lib/florist/posix_shared_memory_objects.ali
+lib/florist/posix_signals.ali
+lib/florist/posix_supplement_to_ada_io.ali
+lib/florist/posix_terminal_functions.ali
+lib/florist/posix_timers.ali
+lib/florist/posix_unsafe_process_primitives.ali
+lib/florist/posix_user_database.ali
+lib/gnat/florist.gpr
+@dirrm include/florist
+@dirrm lib/florist
+@dirrmtry lib/gnat