aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-CPAN-Inject/Makefile27
-rw-r--r--devel/p5-CPAN-Inject/distinfo3
-rw-r--r--devel/p5-CPAN-Inject/pkg-descr13
-rw-r--r--devel/p5-CPAN-Inject/pkg-plist6
5 files changed, 50 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 78bc7b51c7c6..4629d7bbebc0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1043,6 +1043,7 @@
SUBDIR += p5-CLASS
SUBDIR += p5-CPAN-Checksums
SUBDIR += p5-CPAN-DistnameInfo
+ SUBDIR += p5-CPAN-Inject
SUBDIR += p5-CPAN-Mini
SUBDIR += p5-CPAN-SQLite
SUBDIR += p5-CPAN-YACSmoke
diff --git a/devel/p5-CPAN-Inject/Makefile b/devel/p5-CPAN-Inject/Makefile
new file mode 100644
index 000000000000..b3094b5ff9a7
--- /dev/null
+++ b/devel/p5-CPAN-Inject/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-CPAN-Inject
+# Date created: September 21st 2009
+# Whom: Cezary Morga <cm@therek.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CPAN-Inject
+PORTVERSION= 0.11
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= cm@therek.net
+COMMENT= Base class for injecting distributions into CPAN sources
+
+BUILD_DEPENDS= p5-File-chmod>=0.30:${PORTSDIR}/devel/p5-File-chmod \
+ p5-Params-Util>=0.21:${PORTSDIR}/devel/p5-Params-Util \
+ p5-CPAN-Checksums>=1.05:${PORTSDIR}/devel/p5-CPAN-Checksums
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN1= cpaninject.1
+MAN3= CPAN::Inject.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-CPAN-Inject/distinfo b/devel/p5-CPAN-Inject/distinfo
new file mode 100644
index 000000000000..a647c88d14f0
--- /dev/null
+++ b/devel/p5-CPAN-Inject/distinfo
@@ -0,0 +1,3 @@
+MD5 (CPAN-Inject-0.11.tar.gz) = 505d71440ddd20c6eb0175c49a145f20
+SHA256 (CPAN-Inject-0.11.tar.gz) = 7607f4060d7ab22329c4b4069ce45115d5d39e0376c06c92acb2211d094f93be
+SIZE (CPAN-Inject-0.11.tar.gz) = 54564
diff --git a/devel/p5-CPAN-Inject/pkg-descr b/devel/p5-CPAN-Inject/pkg-descr
new file mode 100644
index 000000000000..e896114cc169
--- /dev/null
+++ b/devel/p5-CPAN-Inject/pkg-descr
@@ -0,0 +1,13 @@
+Following the release of CPAN::Mini, the CPAN::Mini::Inject module
+was created to add additional distributions into a minicpan mirror.
+
+While it was created for use with a minicpan mirror, similar
+functionality can be reused in other situations.
+
+CPAN::Inject replicates the basics of this functionality.
+
+Specifically, it takes an arbitrary tarball and adds it to the CPAN
+sources directory for a particular author, and then add the new
+file to the CHECKSUMS file.
+
+WWW: http://search.cpan.org/dist/CPAN-Inject/
diff --git a/devel/p5-CPAN-Inject/pkg-plist b/devel/p5-CPAN-Inject/pkg-plist
new file mode 100644
index 000000000000..79b52021ef6f
--- /dev/null
+++ b/devel/p5-CPAN-Inject/pkg-plist
@@ -0,0 +1,6 @@
+bin/cpaninject
+%%SITE_PERL%%/CPAN/Inject.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/CPAN/Inject/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CPAN/Inject
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CPAN
+@dirrmtry %%SITE_PERL%%/CPAN