aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/cervisia/Makefile4
-rw-r--r--devel/cmake/Makefile4
-rw-r--r--devel/dolphin-plugins/Makefile4
-rw-r--r--devel/kapptemplate/Makefile4
-rw-r--r--devel/kcachegrind/Makefile4
-rw-r--r--devel/kdbg/Makefile4
-rw-r--r--devel/kde-dev-scripts/Makefile4
-rw-r--r--devel/kde-dev-utils/Makefile4
-rw-r--r--devel/kdebindings4/Makefile13
-rw-r--r--devel/kdesdk4-kioslaves/Makefile4
-rw-r--r--devel/kdesdk4-strigi-analyzers/Makefile4
-rw-r--r--devel/kdesdk4-thumbnailers/Makefile4
-rw-r--r--devel/kdesdk4/Makefile35
-rw-r--r--devel/kdesvn-kde4/Makefile5
-rw-r--r--devel/kdevelop-kde4/Makefile7
-rw-r--r--devel/kdevelop-pg-qt/Makefile4
-rw-r--r--devel/kdevelop-php-docs/Makefile4
-rw-r--r--devel/kdevelop-php/Makefile8
-rw-r--r--devel/kdevplatform/Makefile5
-rw-r--r--devel/libkgapi/Makefile4
-rw-r--r--devel/libkolab/Makefile4
-rw-r--r--devel/lokalize/Makefile4
-rw-r--r--devel/okteta/Makefile4
-rw-r--r--devel/p5-perlkde/Makefile16
-rw-r--r--devel/p5-perlqt/Makefile8
-rw-r--r--devel/piklab/Makefile4
-rw-r--r--devel/poxml/Makefile4
-rw-r--r--devel/py-krosspython/Makefile4
-rw-r--r--devel/py-pykde4/Makefile4
-rw-r--r--devel/py-pykdeuic4/Makefile4
-rw-r--r--devel/ruby-korundum/Makefile4
-rw-r--r--devel/ruby-krossruby/Makefile4
-rw-r--r--devel/ruby-qtruby/Makefile4
-rw-r--r--devel/smokegen/Makefile3
-rw-r--r--devel/smokekde/Makefile4
-rw-r--r--devel/smokeqt/Makefile4
-rw-r--r--devel/umbrello/Makefile4
37 files changed, 106 insertions, 106 deletions
diff --git a/devel/cervisia/Makefile b/devel/cervisia/Makefile
index b9d48bc36a2a..b8a8406b9b1e 100644
--- a/devel/cervisia/Makefile
+++ b/devel/cervisia/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= CVS Frontend for KDE
-USE_KDE4= kdelibs automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/devel/cmake/Makefile b/devel/cmake/Makefile
index d22b6b989c22..787860cc8778 100644
--- a/devel/cmake/Makefile
+++ b/devel/cmake/Makefile
@@ -13,7 +13,7 @@ COMMENT?= Cross-platform Makefile generator
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/Copyright.txt
-USE_KDE4= # env
+USES= kde:4 # Just pull in env for KDE_PREFIX
CONFIGURE_ENV= MAKE=make
CONFIGURE_ARGS= --prefix=${PREFIX} \
--datadir="/${DATADIR_REL}" \
@@ -53,7 +53,7 @@ post-patch:
${WRKSRC}/Source/cmLocalGenerator.cxx \
${WRKSRC}/Source/CPack/cmCPackGenerator.cxx \
${WRKSRC}/bootstrap
- @${REINPLACE_CMD} -e 's,/opt/kde4,${KDE4_PREFIX},g' \
+ @${REINPLACE_CMD} -e 's,/opt/kde4,${KDE_PREFIX},g' \
${WRKSRC}/Modules/FindKDE4.cmake
@${REINPLACE_CMD} -e 's,/usr/include,${LOCALBASE}/include,' \
${WRKSRC}/Modules/FindDCMTK.cmake
diff --git a/devel/dolphin-plugins/Makefile b/devel/dolphin-plugins/Makefile
index 7b22ac991759..89762ccdd395 100644
--- a/devel/dolphin-plugins/Makefile
+++ b/devel/dolphin-plugins/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Plugins for Dolphin file manager
-USES= cmake:outsource tar:xz
-USE_KDE4= kdelibs libkonq automoc4
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkonq automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/devel/kapptemplate/Makefile b/devel/kapptemplate/Makefile
index 93c5d7ec67a1..9427e813b061 100644
--- a/devel/kapptemplate/Makefile
+++ b/devel/kapptemplate/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE template generator
-USE_KDE4= kdelibs automoc4
-USES= cmake:outsource gmake tar:xz
+USES= cmake:outsource gmake kde:4 tar:xz
+USE_KDE= kdelibs automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build \
corelib dbus declarative
diff --git a/devel/kcachegrind/Makefile b/devel/kcachegrind/Makefile
index 775d6b49056b..9d98d3c1a898 100644
--- a/devel/kcachegrind/Makefile
+++ b/devel/kcachegrind/Makefile
@@ -10,8 +10,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Profiler frontend for KDE
-USE_KDE4= kdelibs automoc4
-USES= cmake:outsource tar:xz shebangfix
+USES= cmake:outsource kde:4 tar:xz shebangfix
+USE_KDE= kdelibs automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build \
corelib dbus gui
SHEBANG_FILES= converters/op2calltree converters/dprof2calltree \
diff --git a/devel/kdbg/Makefile b/devel/kdbg/Makefile
index 709d4a26517a..761c37e0ff2a 100644
--- a/devel/kdbg/Makefile
+++ b/devel/kdbg/Makefile
@@ -11,8 +11,8 @@ COMMENT= Graphical user interface around gdb using KDE
LICENSE= GPLv2
-USES= cmake
-USE_KDE4= kdelibs automoc4
+USES= cmake kde:4
+USE_KDE= kdelibs automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
INSTALLS_ICONS= yes
diff --git a/devel/kde-dev-scripts/Makefile b/devel/kde-dev-scripts/Makefile
index cd0228ce0261..0f839727f140 100644
--- a/devel/kde-dev-scripts/Makefile
+++ b/devel/kde-dev-scripts/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE development scripts
-USES= cmake:outsource shebangfix tar:xz
-USE_KDE4= kdelibs automoc4
+USES= cmake:outsource kde:4 shebangfix tar:xz
+USE_KDE= kdelibs automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
SHEBANG_FILES= cxxmetric \
diff --git a/devel/kde-dev-utils/Makefile b/devel/kde-dev-utils/Makefile
index c568a6490053..e305f8b58bce 100644
--- a/devel/kde-dev-utils/Makefile
+++ b/devel/kde-dev-utils/Makefile
@@ -10,9 +10,9 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE development utilities
-USE_KDE4= kdelibs automoc4
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build \
corelib designer gui qt3support xml
-USES= cmake:outsource tar:xz
.include <bsd.port.mk>
diff --git a/devel/kdebindings4/Makefile b/devel/kdebindings4/Makefile
index 9d0d8a4778ea..71dc545ccc1c 100644
--- a/devel/kdebindings4/Makefile
+++ b/devel/kdebindings4/Makefile
@@ -7,21 +7,20 @@ CATEGORIES= devel kde
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE bindings (meta port)
-USE_KDE4= # blank, needed to get KDE4_VERSION
-USES= metaport
+USES= kde:4 metaport
OPTIONS_DEFINE= PERL PYTHON RUBY
OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
PERL_DESC= Perl bindings
-PERL_USE= KDE4=perlkde_run
+PERL_USE= KDE=perlkde_run
PYTHON_DESC= Python bindings
-PYTHON_RUN_DEPENDS= ${KDE4_PREFIX}/lib/kde4/krosspython.so:devel/py-krosspython
-PYTHON_USE= KDE4=pykde4_run,pykdeuic4_run
+PYTHON_RUN_DEPENDS= ${KDE_PREFIX}/lib/kde4/krosspython.so:devel/py-krosspython
+PYTHON_USE= KDE=pykde4_run,pykdeuic4_run
RUBY_DESC= Ruby bindings
-RUBY_RUN_DEPENDS= ${KDE4_PREFIX}/lib/kde4/krossruby.so:devel/ruby-krossruby
-RUBY_USE= KDE4=korundum_run
+RUBY_RUN_DEPENDS= ${KDE_PREFIX}/lib/kde4/krossruby.so:devel/ruby-krossruby
+RUBY_USE= KDE=korundum_run
.include <bsd.port.mk>
diff --git a/devel/kdesdk4-kioslaves/Makefile b/devel/kdesdk4-kioslaves/Makefile
index 7b500787b144..2bf4c1508559 100644
--- a/devel/kdesdk4-kioslaves/Makefile
+++ b/devel/kdesdk4-kioslaves/Makefile
@@ -11,8 +11,8 @@ COMMENT= SDK related KIO slaves
LIB_DEPENDS= libsvn_client-1.so:devel/subversion
-USES= cmake:outsource perl5 shebangfix tar:xz
-USE_KDE4= kdelibs automoc4
+USES= cmake:outsource kde:4 perl5 shebangfix tar:xz
+USE_KDE= kdelibs automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
SHEBANG_FILES= perldoc/pod2html.pl
diff --git a/devel/kdesdk4-strigi-analyzers/Makefile b/devel/kdesdk4-strigi-analyzers/Makefile
index 4ca97c0ae106..bb9cd6a4e540 100644
--- a/devel/kdesdk4-strigi-analyzers/Makefile
+++ b/devel/kdesdk4-strigi-analyzers/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Strigi analyzers for SDK related file formats
-USES= cmake:outsource tar:xz
-USE_KDE4= kdelibs automoc4 strigi
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs automoc4 strigi
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/devel/kdesdk4-thumbnailers/Makefile b/devel/kdesdk4-thumbnailers/Makefile
index d3aff2fb39e5..725b1fb5091e 100644
--- a/devel/kdesdk4-thumbnailers/Makefile
+++ b/devel/kdesdk4-thumbnailers/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE thumbnail generator for gettext po files
-USES= cmake:outsource gettext tar:xz
-USE_KDE4= kdelibs automoc4
+USES= cmake:outsource gettext kde:4 tar:xz
+USE_KDE= kdelibs automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/devel/kdesdk4/Makefile b/devel/kdesdk4/Makefile
index f7b27f06188c..65ea722c52d4 100644
--- a/devel/kdesdk4/Makefile
+++ b/devel/kdesdk4/Makefile
@@ -7,8 +7,7 @@ CATEGORIES= devel kde
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE Software Development Kit
-USE_KDE4= # blank, needed to get KDE4_VERSION
-USES= metaport
+USES= kde:4 metaport
OPTIONS_DEFINE= CERVISIA \
DEVUTILS \
@@ -29,51 +28,51 @@ OPTIONS_DEFINE= CERVISIA \
OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
CERVISIA_DESC= CVS frontend
-CERVISIA_RUN_DEPENDS= ${KDE4_PREFIX}/bin/cervisia:devel/cervisia
+CERVISIA_RUN_DEPENDS= ${KDE_PREFIX}/bin/cervisia:devel/cervisia
DEVUTILS_DESC= KDE development utilities
-DEVUTILS_RUN_DEPENDS= ${KDE4_PREFIX}/bin/kuiviewer:devel/kde-dev-utils
+DEVUTILS_RUN_DEPENDS= ${KDE_PREFIX}/bin/kuiviewer:devel/kde-dev-utils
DEVSCRIPTS_DESC= KDE development scripts
-DEVSCRIPTS_RUN_DEPENDS= ${KDE4_PREFIX}/bin/kdekillall:devel/kde-dev-scripts
+DEVSCRIPTS_RUN_DEPENDS= ${KDE_PREFIX}/bin/kdekillall:devel/kde-dev-scripts
DOLPHIN_DESC= Plugins for Dolphin file manager
-DOLPHIN_RUN_DEPENDS= ${KDE4_PREFIX}/lib/kde4/fileviewgitplugin.so:devel/dolphin-plugins
+DOLPHIN_RUN_DEPENDS= ${KDE_PREFIX}/lib/kde4/fileviewgitplugin.so:devel/dolphin-plugins
KAPPTEMPLATE_DESC= Template generator
-KAPPTEMPLATE_RUN_DEPENDS= ${KDE4_PREFIX}/bin/kapptemplate:devel/kapptemplate
+KAPPTEMPLATE_RUN_DEPENDS= ${KDE_PREFIX}/bin/kapptemplate:devel/kapptemplate
KATE_DESC= KDE advanced text editor
-KATE_USE= KDE4=kate_run
+KATE_USE= KDE=kate_run
KATE_PATE_DESC= Support for Python plugins in Kate
-KATE_PATE_RUN_DEPENDS= ${KDE4_PREFIX}/lib/kde4/katepateplugin.so:editors/kate-plugin-pate
+KATE_PATE_RUN_DEPENDS= ${KDE_PREFIX}/lib/kde4/katepateplugin.so:editors/kate-plugin-pate
KCACHEGRIND_DESC= Profiler frontend
-KCACHEGRIND_RUN_DEPENDS= ${KDE4_PREFIX}/bin/kcachegrind:devel/kcachegrind
+KCACHEGRIND_RUN_DEPENDS= ${KDE_PREFIX}/bin/kcachegrind:devel/kcachegrind
KIOSLAVES_DESC= SDK related KIO slaves
-KIOSLAVES_RUN_DEPENDS= ${KDE4_PREFIX}/lib/kde4/kio_svn.so:devel/kdesdk4-kioslaves
+KIOSLAVES_RUN_DEPENDS= ${KDE_PREFIX}/lib/kde4/kio_svn.so:devel/kdesdk4-kioslaves
KOMPARE_DESC= Diff/Patch frontend
-KOMPARE_RUN_DEPENDS= ${KDE4_PREFIX}/bin/kompare:textproc/kompare
+KOMPARE_RUN_DEPENDS= ${KDE_PREFIX}/bin/kompare:textproc/kompare
LOKALIZE_DESC= Computer-aided translation system
-LOKALIZE_RUN_DEPENDS= ${KDE4_PREFIX}/bin/lokalize:devel/lokalize
+LOKALIZE_RUN_DEPENDS= ${KDE_PREFIX}/bin/lokalize:devel/lokalize
OKTETA_DESC= Hex editor
-OKTETA_RUN_DEPENDS= ${KDE4_PREFIX}/bin/okteta:devel/okteta
+OKTETA_RUN_DEPENDS= ${KDE_PREFIX}/bin/okteta:devel/okteta
POXML_DESC= Tools to translate DocBook XML using gettext
-POXML_RUN_DEPENDS= ${KDE4_PREFIX}/bin/po2xml:devel/poxml
+POXML_RUN_DEPENDS= ${KDE_PREFIX}/bin/po2xml:devel/poxml
STRIGI_DESC= Strigi analyzers for SDK file formats
-STRIGI_RUN_DEPENDS= ${KDE4_PREFIX}/lib/strigi/strigila_diff.so:devel/kdesdk4-strigi-analyzers
+STRIGI_RUN_DEPENDS= ${KDE_PREFIX}/lib/strigi/strigila_diff.so:devel/kdesdk4-strigi-analyzers
THUMBNAILER_DESC= Thumbnail generator for gettext po files
-THUMBNAILER_RUN_DEPENDS= ${KDE4_PREFIX}/lib/kde4/pothumbnail.so:devel/kdesdk4-thumbnailers
+THUMBNAILER_RUN_DEPENDS= ${KDE_PREFIX}/lib/kde4/pothumbnail.so:devel/kdesdk4-thumbnailers
UMBRELLO_DESC= UML modeller
-UMBRELLO_RUN_DEPENDS= ${KDE4_PREFIX}/bin/umbrello:devel/umbrello
+UMBRELLO_RUN_DEPENDS= ${KDE_PREFIX}/bin/umbrello:devel/umbrello
.include <bsd.port.mk>
diff --git a/devel/kdesvn-kde4/Makefile b/devel/kdesvn-kde4/Makefile
index fbd66f81f181..2d12d86646e1 100644
--- a/devel/kdesvn-kde4/Makefile
+++ b/devel/kdesvn-kde4/Makefile
@@ -15,10 +15,11 @@ LIB_DEPENDS= libsvn_client-1.so:devel/subversion
CONFLICTS= qsvn-[0-9]*
-USES= cmake:outsource compiler:c11 tar:xz
CMAKE_ARGS+= -DSUBVERSION_INCLUDE_DIR=${LOCALBASE}/include/subversion-1 \
-DMAN_INSTALL_DIR=${MANPREFIX}/man
-USE_KDE4= kdelibs automoc4
+
+USES= cmake:outsource compiler:c11 kde:4 tar:xz
+USE_KDE= kdelibs automoc4
USE_LDCONFIG= yes
USE_QT4= corelib gui xml network dbus svg sql \
qmake_build moc_build rcc_build uic_build linguist_build
diff --git a/devel/kdevelop-kde4/Makefile b/devel/kdevelop-kde4/Makefile
index ec712da4a781..0bf0f4ede4ff 100644
--- a/devel/kdevelop-kde4/Makefile
+++ b/devel/kdevelop-kde4/Makefile
@@ -13,10 +13,11 @@ COMMENT= Plugin extensible IDE for KDE
LIB_DEPENDS= libkdevplatforminterfaces.so:devel/kdevplatform
RUN_DEPENDS= gmake:devel/gmake
-USE_KDE4= kdelibs workspace automoc4
+USES= cmake:outsource compiler:c++11-lib gmake kde:4 \
+ shared-mime-info tar:bz2
+USE_KDE= kdelibs workspace automoc4
USE_QT4= qmake_build moc_build uic_build rcc_build \
corelib declarative gui help script webkit xml
-USES= cmake:outsource compiler:c++11-lib gmake shared-mime-info tar:bz2
OPTIONS_DEFINE= OKTETA PHP NLS
OPTIONS_DEFAULT= OKTETA PHP
@@ -28,7 +29,7 @@ OKTETA_CMAKE_OFF= -DWITH_LibOktetaKasten:BOOL=OFF
OKTETA_CMAKE_ON= -DWITH_LibOktetaKasten:BOOL=ON
PHP_DESC= PHP support for KDevelop
-PHP_RUN_DEPENDS= ${KDE4_PREFIX}/lib/kde4/kdevphplanguagesupport.so:devel/kdevelop-php
+PHP_RUN_DEPENDS= ${KDE_PREFIX}/lib/kde4/kdevphplanguagesupport.so:devel/kdevelop-php
NLS_USES= gettext
NLS_CMAKE_OFF= -DBUILD_po:BOOL=FALSE
diff --git a/devel/kdevelop-pg-qt/Makefile b/devel/kdevelop-pg-qt/Makefile
index c642bf1effee..135822b9a8d0 100644
--- a/devel/kdevelop-pg-qt/Makefile
+++ b/devel/kdevelop-pg-qt/Makefile
@@ -12,8 +12,8 @@ COMMENT= Parser-generator from KDevplatform
BUILD_DEPENDS= ${LOCALBASE}/bin/flex:textproc/flex
-USES= bison cmake:outsource compiler:c++11-lib tar:bzip2
-USE_KDE4= automoc4 kdelibs
+USES= bison cmake:outsource compiler:c++11-lib kde:4 tar:bzip2
+USE_KDE= automoc4 kdelibs
USE_QT4= qmake_build moc_build uic_build rcc_build
.include <bsd.port.mk>
diff --git a/devel/kdevelop-php-docs/Makefile b/devel/kdevelop-php-docs/Makefile
index 122b7f9e8943..40d19e523e11 100644
--- a/devel/kdevelop-php-docs/Makefile
+++ b/devel/kdevelop-php-docs/Makefile
@@ -11,9 +11,9 @@ COMMENT= PHP documentation for KDevelop
LIB_DEPENDS= libkdevplatforminterfaces.so:devel/kdevplatform
-USE_KDE4= kdelibs automoc4
+USES= cmake:outsource compiler:c++11-lib kde:4 tar:bz2
+USE_KDE= kdelibs automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
-USES= cmake:outsource compiler:c++11-lib tar:bz2
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
diff --git a/devel/kdevelop-php/Makefile b/devel/kdevelop-php/Makefile
index 0b152304be25..fd112a96b10f 100644
--- a/devel/kdevelop-php/Makefile
+++ b/devel/kdevelop-php/Makefile
@@ -10,11 +10,11 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= PHP support for KDevelop
LIB_DEPENDS= libkdevplatforminterfaces.so:devel/kdevplatform
-BUILD_DEPENDS= ${KDE4_PREFIX}/bin/kdev-pg-qt:devel/kdevelop-pg-qt
+BUILD_DEPENDS= ${KDE_PREFIX}/bin/kdev-pg-qt:devel/kdevelop-pg-qt
-USE_KDE4= kdelibs automoc4
+USES= cmake:outsource compiler:c++11-lib gmake kde:4 tar:bz2
+USE_KDE= kdelibs automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
-USES= cmake:outsource compiler:c++11-lib gmake tar:bz2
MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFINE= PHPDOCS NLS
@@ -22,7 +22,7 @@ OPTIONS_DEFAULT= PHPDOCS
OPTIONS_SUB= yes
PHPDOCS_DESC= Integrate with PHP.net documentation
-PHPDOCS_RUN_DEPENDS= ${KDE4_PREFIX}/lib/kde4/kdevphpdocs.so:devel/kdevelop-php-docs
+PHPDOCS_RUN_DEPENDS= ${KDE_PREFIX}/lib/kde4/kdevphpdocs.so:devel/kdevelop-php-docs
NLS_USES= gettext
NLS_CMAKE_OFF= -DBUILD_po:BOOL=Off
diff --git a/devel/kdevplatform/Makefile b/devel/kdevplatform/Makefile
index c080069d9d21..24f8d09cf26d 100644
--- a/devel/kdevplatform/Makefile
+++ b/devel/kdevplatform/Makefile
@@ -14,10 +14,11 @@ LIB_DEPENDS= libsvn_client-1.so:devel/subversion \
libboost_thread.so:devel/boost-libs \
libqjson.so:devel/qjson
-USE_KDE4= kate_run kdelibs automoc4
+USES= cmake:outsource compiler:c++11-lib grantlee:4 kde:4 shebangfix \
+ tar:bz2
+USE_KDE= kate_run kdelibs automoc4
USE_QT4= qmake_build moc_build uic_build rcc_build \
corelib designer_build gui webkit
-USES= cmake:outsource compiler:c++11-lib grantlee:4 shebangfix tar:bz2
USE_LDCONFIG= yes
SHEBANG_FILES= util/kdev_format_source util/kdevplatform_shell_environment.sh
diff --git a/devel/libkgapi/Makefile b/devel/libkgapi/Makefile
index 27214c338cee..e22451111a7a 100644
--- a/devel/libkgapi/Makefile
+++ b/devel/libkgapi/Makefile
@@ -14,8 +14,8 @@ LICENSE= GPLv2
LIB_DEPENDS= libqjson.so:devel/qjson
-USES= cmake:outsource tar:bzip2
-USE_KDE4= automoc4 kdelibs pimlibs
+USES= cmake:outsource kde:4 tar:bzip2
+USE_KDE= automoc4 kdelibs pimlibs
USE_LDCONFIG= yes
USE_QT4= corelib network webkit xml \
qmake_build moc_build rcc_build uic_build
diff --git a/devel/libkolab/Makefile b/devel/libkolab/Makefile
index 5f29e4864861..96009a65f0c9 100644
--- a/devel/libkolab/Makefile
+++ b/devel/libkolab/Makefile
@@ -19,8 +19,8 @@ CMAKE_ARGS= -DBUILD_TESTS:BOOL=OFF \
-DPHP_BINDINGS:BOOL=OFF \
-DPYTHON_BINDINGS:BOOL=OFF \
-DUSE_LIBCALENDARING:BOOL=OFF
-USES= cmake:outsource
-USE_KDE4= automoc4 kdelibs pimlibs
+USES= cmake:outsource kde:4
+USE_KDE= automoc4 kdelibs pimlibs
USE_LDCONFIG= yes
USE_QT4= corelib gui xml \
moc_build qmake_build rcc_build uic_build
diff --git a/devel/lokalize/Makefile b/devel/lokalize/Makefile
index e43b0398f7ba..1edf86a3cada 100644
--- a/devel/lokalize/Makefile
+++ b/devel/lokalize/Makefile
@@ -11,8 +11,8 @@ COMMENT= Computer-aided translation system
LIB_DEPENDS= libhunspell-1.3.so:textproc/hunspell
-USE_KDE4= kdelibs automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build \
sql
diff --git a/devel/okteta/Makefile b/devel/okteta/Makefile
index eb35c35e956f..8ec7cf199db1 100644
--- a/devel/okteta/Makefile
+++ b/devel/okteta/Makefile
@@ -12,8 +12,8 @@ COMMENT= KDE hex editor
LIB_DEPENDS= libqca.so:devel/qca
-USE_KDE4= kdelibs automoc4
-USES= cmake:outsource shared-mime-info tar:xz
+USES= cmake:outsource kde:4 shared-mime-info tar:xz
+USE_KDE= kdelibs automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build \
corelib designer gui script scripttools xml
USE_LDCONFIG= yes
diff --git a/devel/p5-perlkde/Makefile b/devel/p5-perlkde/Makefile
index 7f869ce1248b..66d5e5cb058e 100644
--- a/devel/p5-perlkde/Makefile
+++ b/devel/p5-perlkde/Makefile
@@ -10,18 +10,18 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Perl bindings for KDE
-USE_KDE4= perlqt smokekde automoc4
+USES= cmake:outsource compiler:c++11-lib kde:4 perl5 tar:xz
+USE_KDE= perlqt smokekde automoc4
USE_QT4= network opengl sql svg xml \
qmake_build moc_build uic_build rcc_build
-USES= cmake:outsource compiler:c++11-lib perl5 tar:xz
# Respect PREFIX
CMAKE_ARGS+= -DCUSTOM_PERL_SITE_ARCH_DIR=${PREFIX}/${SITE_ARCH_REL}
-# Fix build PREFIX != KDE4_PREFIX
-CMAKE_ARGS+= -DSmoke_DIR=${KDE4_PREFIX}/lib/cmake/smoke \
- -DPerlQt_DIR=${KDE4_PREFIX}/share/perlqt/cmake \
- -DOkular_DIR=${KDE4_PREFIX}/lib/cmake/Okular
+# Fix build PREFIX != KDE_PREFIX
+CMAKE_ARGS+= -DSmoke_DIR=${KDE_PREFIX}/lib/cmake/smoke \
+ -DPerlQt_DIR=${KDE_PREFIX}/share/perlqt/cmake \
+ -DOkular_DIR=${KDE_PREFIX}/lib/cmake/Okular
OPTIONS_DEFINE= ATTICA
ATTICA_DESC= Bindings for libattica (may crash build)
@@ -29,8 +29,8 @@ ATTICA_DESC= Bindings for libattica (may crash build)
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MATTICA}
-.if exists(${KDE4_PREFIX}/lib/libsmokekdecore.so) && \
- !exists(${KDE4_PREFIX}/lib/libsmokeattica.so)
+.if exists(${KDE_PREFIX}/lib/libsmokekdecore.so) && \
+ !exists(${KDE_PREFIX}/lib/libsmokeattica.so)
IGNORE= requires devel/smokekde built with ATTICA option
.endif
PLIST_SUB+= ATTICA=""
diff --git a/devel/p5-perlqt/Makefile b/devel/p5-perlqt/Makefile
index c9cf69c78922..1e247ea0d205 100644
--- a/devel/p5-perlqt/Makefile
+++ b/devel/p5-perlqt/Makefile
@@ -13,15 +13,15 @@ COMMENT= Perl bindings for Qt
LIB_DEPENDS= libqscintilla2.so:devel/qscintilla2 \
libqwt.so:x11-toolkits/qwt5
-USE_KDE4= smokeqt qimageblitz
+USES= cmake:outsource kde:4 perl5 tar:xz
+USE_KDE= smokeqt qimageblitz
USE_QT4= corelib dbus gui network xml \
qmake_build moc_build uic_build rcc_build
-USES= cmake:outsource perl5 tar:xz
# Respect PREFIX
CMAKE_ARGS+= -DCUSTOM_PERL_SITE_ARCH_DIR=${PREFIX}/${SITE_ARCH_REL}
-# Fix build PREFIX != KDE4_PREFIX
-CMAKE_ARGS+= -DSmoke_DIR=${KDE4_PREFIX}/lib/cmake/smoke
+# Fix build PREFIX != KDE_PREFIX
+CMAKE_ARGS+= -DSmoke_DIR=${KDE_PREFIX}/lib/cmake/smoke
SUB_FILES= perl-kdebindings-env.sh pkg-message
SUB_LIST+= PERL5LIBDIR="${PREFIX}/${SITE_ARCH_REL}:\
diff --git a/devel/piklab/Makefile b/devel/piklab/Makefile
index e7f52027906a..b610d124182a 100644
--- a/devel/piklab/Makefile
+++ b/devel/piklab/Makefile
@@ -21,8 +21,8 @@ OPTIONS_DEFINE= KDE4
OPTIONS_DEFAULT= KDE4
OPTIONS_SUB= yes
-KDE4_USES= shared-mime-info
-KDE4_USE= KDE4=automoc4,kdelibs
+KDE4_USES= kde:4 shared-mime-info
+KDE4_USE= KDE=automoc4,kdelibs
KDE4_CMAKE_OFF= -DQT_ONLY:BOOL=ON \
-DLOCALE_INSTALL_DIR:STRING="${PREFIX}/share/locale"
diff --git a/devel/poxml/Makefile b/devel/poxml/Makefile
index 9f8318e3eeeb..65f7e7683199 100644
--- a/devel/poxml/Makefile
+++ b/devel/poxml/Makefile
@@ -11,8 +11,8 @@ COMMENT= Tools to translate Docbook XML using gettext
BUILD_DEPENDS= ${LOCALBASE}/lib/libantlr.a:devel/antlr
-USE_KDE4= kdelibs automoc4
-USES= cmake:outsource gettext-tools:build,run tar:xz
+USES= cmake:outsource gettext-tools:build,run kde:4 tar:xz
+USE_KDE= kdelibs automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build \
corelib xml
diff --git a/devel/py-krosspython/Makefile b/devel/py-krosspython/Makefile
index 841d13b80e01..581d3d4eb78e 100644
--- a/devel/py-krosspython/Makefile
+++ b/devel/py-krosspython/Makefile
@@ -11,9 +11,9 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Kross Python scripting library
-USE_KDE4= kdelibs automoc4
+USES= cmake:outsource kde:4 python:2 tar:xz
+USE_KDE= kdelibs automoc4
USE_QT4= corelib gui qmake_build moc_build uic_build rcc_build
-USES= cmake:outsource python:2 tar:xz
CMAKE_ARGS+= -DBUILD_falcon:BOOL=FALSE \
-DBUILD_ruby:BOOL=FALSE \
-DBUILD_java:BOOL=FALSE
diff --git a/devel/py-pykde4/Makefile b/devel/py-pykde4/Makefile
index ccfca98bd53c..7825856082e0 100644
--- a/devel/py-pykde4/Makefile
+++ b/devel/py-pykde4/Makefile
@@ -13,7 +13,8 @@ COMMENT= Python bindings for KDE
LIB_DEPENDS= libqwt.so:x11-toolkits/qwt5
-USE_KDE4= kdelibs nepomuk-core okular pimlibs \
+USES= cmake:outsource kde:4 python:2 pyqt:4 tar:xz
+USE_KDE= kdelibs nepomuk-core okular pimlibs \
akonadi automoc4 soprano
USE_PYQT= declarative designer gui network opengl phonon script sip \
sql svg webkit xml \
@@ -21,7 +22,6 @@ USE_PYQT= declarative designer gui network opengl phonon script sip \
USE_QT4= corelib dbus designer_build gui network xml \
qmake_build moc_build uic_build rcc_build
-USES= cmake:outsource python:2 pyqt:4 tar:xz
CMAKE_ARGS+= -DWITH_PolkitQt:BOOL=FALSE \
-DENABLE_PYTHON=ON \
-DPYTHON_INCLUDE_DIR:PATH=${WRKDIR}/include/${PYTHON_VERSION}
diff --git a/devel/py-pykdeuic4/Makefile b/devel/py-pykdeuic4/Makefile
index a9719585b025..bbb99d2a3cb2 100644
--- a/devel/py-pykdeuic4/Makefile
+++ b/devel/py-pykdeuic4/Makefile
@@ -11,10 +11,10 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Enhanced version of pyuic4
-USE_KDE4= kdelibs automoc4 pykde4
+USES= cmake:outsource python:2 kde:4 tar:xz
+USE_KDE= kdelibs automoc4 pykde4
USE_QT4= moc_build qmake_build rcc_build uic_build
DISTINFO_FILE= ${.CURDIR:H:H}/devel/py-pykde4/distinfo
-USES= cmake:outsource python:2 tar:xz
WRKSRC= ${WRKDIR}/${DISTNAME}/tools/${PORTNAME}
diff --git a/devel/ruby-korundum/Makefile b/devel/ruby-korundum/Makefile
index db34948b7842..f2939ae9f637 100644
--- a/devel/ruby-korundum/Makefile
+++ b/devel/ruby-korundum/Makefile
@@ -10,13 +10,13 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Ruby bindings for KDE
-USE_KDE4= kate kdelibs okular pimlibs \
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kate kdelibs okular pimlibs \
qtruby smokegen smokekde smokeqt \
akonadi automoc4 soprano
USE_QT4= corelib network opengl sql svg xml \
qmake_build moc_build uic_build rcc_build
USE_RUBY= yes
-USES= cmake:outsource tar:xz
CMAKE_ARGS+= -DRUBY_LIBRARY=${LOCALBASE}/lib/lib${RUBY_NAME}.so \
-DRUBY_INCLUDE_PATH=${LOCALBASE}/lib/ruby/${RUBY_VER}/${RUBY_ARCH} \
diff --git a/devel/ruby-krossruby/Makefile b/devel/ruby-krossruby/Makefile
index f6669969879d..eb9f1500775e 100644
--- a/devel/ruby-krossruby/Makefile
+++ b/devel/ruby-krossruby/Makefile
@@ -11,10 +11,10 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Ruby bindings for Qt/KDE
-USE_KDE4= kdelibs pimlibs automoc4
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs pimlibs automoc4
USE_QT4= corelib gui qmake_build moc_build uic_build rcc_build
USE_RUBY= yes
-USES= cmake:outsource tar:xz
CMAKE_ARGS+= -DBUILD_python:BOOL=FALSE \
-DBUILD_falcon:BOOL=FALSE \
-DBUILD_java:BOOL=FALSE
diff --git a/devel/ruby-qtruby/Makefile b/devel/ruby-qtruby/Makefile
index 45ea7ee4325e..dddfe9c48043 100644
--- a/devel/ruby-qtruby/Makefile
+++ b/devel/ruby-qtruby/Makefile
@@ -14,11 +14,11 @@ COMMENT= Ruby bindings for Qt
LIB_DEPENDS= libqwt.so:x11-toolkits/qwt5 \
libqscintilla2.so:devel/qscintilla2
-USE_KDE4= smokeqt
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= smokeqt
USE_QT4= corelib dbus declarative gui network phonon script webkit xml \
qmake_build moc_build uic_build rcc_build
USE_RUBY= yes
-USES= cmake:outsource tar:xz
USE_LDCONFIG= yes
SUB_FILES= ruby-kdebindings-env.sh pkg-message
diff --git a/devel/smokegen/Makefile b/devel/smokegen/Makefile
index c6860632a5f7..72948f3c4685 100644
--- a/devel/smokegen/Makefile
+++ b/devel/smokegen/Makefile
@@ -9,9 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= SMOKE bindings for KDE
-USE_KDE4= # blank, needed to get KDE4_VERSION
+USES= cmake:outsource kde:4 tar:xz
USE_QT4= corelib xml qmake_build moc_build uic_build rcc_build
-USES= cmake:outsource tar:xz
CMAKE_ARGS+= -DSMOKE_CMAKE_MODULE_DIR:PATH=${PREFIX}/lib/cmake/smoke
USE_LDCONFIG= yes
diff --git a/devel/smokekde/Makefile b/devel/smokekde/Makefile
index 62fabe2283a0..bb4ae4c0fb3f 100644
--- a/devel/smokekde/Makefile
+++ b/devel/smokekde/Makefile
@@ -9,11 +9,11 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= SMOKE bindings for KDE
-USE_KDE4= kate kdelibs okular pimlibs \
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kate kdelibs okular pimlibs \
smokegen smokeqt akonadi automoc4 soprano
USE_QT4= corelib dbus designer_build gui network opengl sql svg xml \
qmake_build moc_build uic_build rcc_build
-USES= cmake:outsource tar:xz
USE_LDCONFIG= yes
OPTIONS_DEFINE= ATTICA
diff --git a/devel/smokeqt/Makefile b/devel/smokeqt/Makefile
index dbc8608e885c..3529fe3c52f9 100644
--- a/devel/smokeqt/Makefile
+++ b/devel/smokeqt/Makefile
@@ -13,12 +13,12 @@ COMMENT= SMOKE bindings for Qt
LIB_DEPENDS= libqscintilla2.so:devel/qscintilla2 \
libqwt.so:x11-toolkits/qwt5
-USE_KDE4= smokegen qimageblitz
+USES= cmake:outsource kde:4 pkgconfig tar:xz
+USE_KDE= smokegen qimageblitz
USE_QT4= corelib dbus declarative designer_build gui help \
multimedia network opengl phonon qtestlib script \
sql svg webkit xml xmlpatterns \
qmake_build moc_build uic_build rcc_build
-USES= cmake:outsource pkgconfig tar:xz
USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/devel/umbrello/Makefile b/devel/umbrello/Makefile
index 0a7e0d0b17c9..3d4bdf484061 100644
--- a/devel/umbrello/Makefile
+++ b/devel/umbrello/Makefile
@@ -11,9 +11,9 @@ COMMENT= UML modeller for KDE
LIB_DEPENDS= libboost_thread.so:devel/boost-libs
-USE_KDE4= kdelibs automoc4
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs automoc4
USE_GNOME= libxml2 libxslt
-USES= cmake:outsource tar:xz
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <bsd.port.mk>