aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/ice/Makefile2
-rw-r--r--devel/py-ice/Makefile4
2 files changed, 2 insertions, 4 deletions
diff --git a/devel/ice/Makefile b/devel/ice/Makefile
index 25ab0ed8b5ae..bb80d5aa2afd 100644
--- a/devel/ice/Makefile
+++ b/devel/ice/Makefile
@@ -19,7 +19,7 @@ MAKE_JOBS_UNSAFE= yes
.if ${SLAVE_PORT} == "no"
LIB_DEPENDS= libexpat.so:textproc/expat2 \
libmcpp.so:devel/mcpp
-USES+= ssl
+USES+= compiler:c++11-lang ssl
.else
LIB_VRS= ${PORTVERSION:R:S|.||g}
LIB_DEPENDS+= libIce.so.${LIB_VRS}:devel/ice
diff --git a/devel/py-ice/Makefile b/devel/py-ice/Makefile
index 20b9995795e9..e38b755419cf 100644
--- a/devel/py-ice/Makefile
+++ b/devel/py-ice/Makefile
@@ -12,9 +12,7 @@ LICENSE= GPLv2
BUILD_DEPENDS= mcpp:devel/mcpp
LIB_DEPENDS= libIce.so.${LIB_VRS}:devel/ice
-BROKEN_powerpc64= fails to compile: gmake: Ice_BuiltinSequences_ice.py: Segmentation fault (core dumped)
-
-USES= python shebangfix
+USES= compiler:c++11-lang python shebangfix
USE_PYTHON= py3kplist
SLAVE_PORT= yes
MASTERDIR= ${.CURDIR}/../ice