aboutsummaryrefslogtreecommitdiff
path: root/dns/adns/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'dns/adns/Makefile')
-rw-r--r--dns/adns/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/dns/adns/Makefile b/dns/adns/Makefile
index df906fd019c9..222adf9e2c17 100644
--- a/dns/adns/Makefile
+++ b/dns/adns/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= adns
-PORTVERSION= 0.7
+PORTVERSION= 1.0
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_GNU} \
ftp://ftp.chiark.greenend.org.uk/users/ian/adns/
@@ -18,7 +18,11 @@ GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
USE_GMAKE= yes
+LIBVERSION= 1
+PLIST_SUB+= LIBVERSION="${LIBVERSION}"
+
post-install:
- strip ${PREFIX}/bin/adnstest ${PREFIX}/bin/adnslogres ${PREFIX}/bin/adnshost
+ @${LN} -sf libadns.so.${LIBVERSION} ${PREFIX}/lib/libadns.so
+ strip ${PREFIX}/bin/adnslogres ${PREFIX}/bin/adnshost
.include <bsd.port.mk>