aboutsummaryrefslogtreecommitdiff
path: root/dns/nsping
diff options
context:
space:
mode:
Diffstat (limited to 'dns/nsping')
-rw-r--r--dns/nsping/Makefile23
-rw-r--r--dns/nsping/distinfo3
-rw-r--r--dns/nsping/files/patch-aa17
-rw-r--r--dns/nsping/files/patch-ab28
-rw-r--r--dns/nsping/pkg-comment1
-rw-r--r--dns/nsping/pkg-descr7
-rw-r--r--dns/nsping/pkg-plist1
7 files changed, 0 insertions, 80 deletions
diff --git a/dns/nsping/Makefile b/dns/nsping/Makefile
deleted file mode 100644
index 644e3cad5230..000000000000
--- a/dns/nsping/Makefile
+++ /dev/null
@@ -1,23 +0,0 @@
-# New ports collection makefile for: nsping
-# Date created: 04 March 2000
-# Whom: Kris Kennaway <kris@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= nsping
-PORTVERSION= 0.8
-CATEGORIES= net
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= roam
-DISTFILES= nsping.tar.gz
-
-MAINTAINER= roam@FreeBSD.org
-
-MAN8= nsping.8
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/nsping ${PREFIX}/sbin
- ${INSTALL_DATA} ${WRKSRC}/nsping.8 ${PREFIX}/man/man8
-
-.include <bsd.port.mk>
diff --git a/dns/nsping/distinfo b/dns/nsping/distinfo
deleted file mode 100644
index c0d519e6d4a1..000000000000
--- a/dns/nsping/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (nsping.tar.gz) = 64785a50eb065a9b28ee33ec8c1ccab2
-RMD160 (nsping.tar.gz) = 6f64f04a3b97c04ab978dcd170e0f9f590f2952a
-SHA1 (nsping.tar.gz) = 3e85186a1db7566728426b13c5683afe5ed96752
diff --git a/dns/nsping/files/patch-aa b/dns/nsping/files/patch-aa
deleted file mode 100644
index 6b3d4f607e20..000000000000
--- a/dns/nsping/files/patch-aa
+++ /dev/null
@@ -1,17 +0,0 @@
---- Makefile.orig Mon Nov 24 04:56:28 1997
-+++ Makefile Fri Nov 12 15:53:26 1999
-@@ -1,4 +1,4 @@
--CFLAGS= -g
-+#CFLAGS= -g
- #Solaris
- #CFLAGS= -g -Dsys5
- LDFLAGS=
-@@ -10,6 +10,8 @@
- OBJS= nsping.o dns-lib.o dns-rr.o
- SRCS= nsping.c dns-lib.c dns-rr.c
- HEADERS= nsping.h dns-lib.h dns-rr.h
-+
-+all: ${TARGET}
-
- ${TARGET} : ${OBJS}
- ${CC} ${CFLAGS} -o ${TARGET} ${OBJS} ${LDFLAGS} ${LIBS}
diff --git a/dns/nsping/files/patch-ab b/dns/nsping/files/patch-ab
deleted file mode 100644
index 970acc7d39cc..000000000000
--- a/dns/nsping/files/patch-ab
+++ /dev/null
@@ -1,28 +0,0 @@
---- nsping.c.orig Fri Nov 12 15:30:42 1999
-+++ nsping.c Fri Nov 12 15:44:06 1999
-@@ -189,10 +189,14 @@
-
- int guess_zone() {
- char lhn[MAXDNAME];
-+ struct hostent *hp;
- char *cp;
-
- if(gethostname(lhn, MAXDNAME) < 0)
- return(0);
-+ if((hp = gethostbyname(lhn)) == NULL)
-+ return(0);
-+ strlcpy(lhn, hp->h_name, sizeof(lhn));
-
- cp = strchr(lhn, '.');
- if(!cp || !(*(++cp)))
-@@ -679,9 +683,7 @@
- /* -------------------------------------------------------------------------- */
-
- void usage() {
-- fprintf(stderr, "nsping [ -z <zone> | -h <hostname> ] -p <port> -t <timeout>\n"
-- "\t\t-a <local address> -P <local port>\n"
-- "\t\t-T <type> <-r | -R, recurse?>\n");
-+ fprintf(stderr, "Usage: nsping [-dR] [-c count] [-z zone | -h hostname] [-t timeout] [-p dport] [-P sport] [-a saddr] [-T querytype]\n");
- return;
- }
-
diff --git a/dns/nsping/pkg-comment b/dns/nsping/pkg-comment
deleted file mode 100644
index 7ea95bbb5d7b..000000000000
--- a/dns/nsping/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-DNS "ping"
diff --git a/dns/nsping/pkg-descr b/dns/nsping/pkg-descr
deleted file mode 100644
index f367812a6614..000000000000
--- a/dns/nsping/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-from nsping.8:
-
- Nsping uses DNS queries to monitor reachability and operation of name-
- servers, as well as the latency of DNS queries. It does this by sending
- random recursive DNS queries to the nameserver (avoiding the effects of
- DNS caching) and measuring the amount of time between the sending of the
- query and the receipt of the response packet.
diff --git a/dns/nsping/pkg-plist b/dns/nsping/pkg-plist
deleted file mode 100644
index af88623b47cd..000000000000
--- a/dns/nsping/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-sbin/nsping