aboutsummaryrefslogtreecommitdiff
path: root/dns/powerdns-devel
diff options
context:
space:
mode:
Diffstat (limited to 'dns/powerdns-devel')
-rw-r--r--dns/powerdns-devel/Makefile114
-rw-r--r--dns/powerdns-devel/distinfo1
-rw-r--r--dns/powerdns-devel/files/configure.powerdns87
-rw-r--r--dns/powerdns-devel/files/patch-configure11
-rw-r--r--dns/powerdns-devel/files/patch-modules_gmysqlbackend_Makefile_in11
-rw-r--r--dns/powerdns-devel/files/patch-modules_gpgsqlbackend_Makefile_in29
-rw-r--r--dns/powerdns-devel/files/patch-modules_gpgsqlbackend_OBJECTLIBS5
-rw-r--r--dns/powerdns-devel/files/patch-modules_pipebackend_Makefile_in11
-rw-r--r--dns/powerdns-devel/files/patch-pdns_backends_bind_bindbackend2_cc16
-rw-r--r--dns/powerdns-devel/files/patch-pdns_backends_bind_bindbackend2_hh39
-rw-r--r--dns/powerdns-devel/files/patch-pdns_backends_bind_bindbackend_cc16
-rw-r--r--dns/powerdns-devel/files/patch-pdns_backends_bind_bindbackend_hh39
-rw-r--r--dns/powerdns-devel/files/patch-pdns_iputils_hh18
-rw-r--r--dns/powerdns-devel/files/pdns.conf300
-rw-r--r--dns/powerdns-devel/files/pdns_mysql.sql38
-rw-r--r--dns/powerdns-devel/files/pdns_postgresql.sql40
-rw-r--r--dns/powerdns-devel/pkg-descr6
-rw-r--r--dns/powerdns-devel/pkg-plist12
18 files changed, 0 insertions, 793 deletions
diff --git a/dns/powerdns-devel/Makefile b/dns/powerdns-devel/Makefile
deleted file mode 100644
index b81c6be0d200..000000000000
--- a/dns/powerdns-devel/Makefile
+++ /dev/null
@@ -1,114 +0,0 @@
-# New ports collection makefile for: powerdns
-# Date Created: 14.Jan 2003
-# Whom: dirk.meyer@dinoex.sub.org
-#
-# $FreeBSD$
-#
-
-PORTNAME= powerdns
-PORTVERSION= 2.9.12
-PORTREVISION= 1
-CATEGORIES= dns ipv6
-MASTER_SITES= http://downloads.powerdns.com/releases/
-DISTNAME= pdns-${PORTVERSION}
-
-MAINTAINER= dinoex@FreeBSD.org
-COMMENT= An advanced DNS server with SQL backend
-
-USE_GMAKE= YES
-USE_SUBMAKE= YES
-USE_REINPLACE= YES
-GNU_CONFIGURE= YES
-CONFIGURE_ARGS+= --with-modules="${CONFIGURE_MODULES} pipe" \
- --with-dynmodules=""
-# --enable-debug
-
-# use user config if possible
-.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
-.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
-.else
-.if defined(BATCH)
-# default package, can be configured in /etc/make.conf
-POWERDNS_OPTIONS?= \"PostgreSQL\"
-.endif
-# make INDEX match
-NO_DESCRIBE=yes
-.endif
-
-.if defined(WITH_POSTGRESQL_DRIVER) && !defined(WITHOUT_POSTGRESQL_DRIVER)
-LIB_DEPENDS= pq[+][+].4:${PORTSDIR}/databases/postgresql-libpq++
-CONFIGURE_ARGS+= --enable-pgsql
-CONFIGURE_MODULES+= "gpgsql"
-.else
-CONFIGURE_ARGS+= --disable-pgsql
-.endif
-
-.if defined(WITH_MYSQL_DRIVER)
-MYSQL_PORT?= databases/mysql323-client
-LIB_DEPENDS+= mysqlclient:${PORTSDIR}/${MYSQL_PORT}
-CONFIGURE_ARGS+= --enable-mysql
-CONFIGURE_MODULES+= "gmysql"
-.else
-CONFIGURE_ARGS+= --disable-mysql
-.endif
-
-SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
- CURDIR2="${.CURDIR}" \
- MKDIR="${MKDIR}" \
- DISTNAME="${DISTNAME}" \
- POWERDNS_OPTIONS="${POWERDNS_OPTIONS}"
-
-MAN8= pdns_control.8 pdns_server.8 zone2sql.8
-
-pre-everything::
- @ ${SETENV} ${SCRIPTS_ENV} ${SH} ${FILESDIR}/configure.powerdns
-
-post-clean:
- @ ${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc
-
-.if defined(NO_DESCRIBE)
-describe:
-.if defined(BATCH)
- @ ${SETENV} ${SCRIPTS_ENV} ${SH} ${FILESDIR}/configure.powerdns
-.endif
- @cd ${.CURDIR} && ${MAKE} ${__softMAKEFLAGS} BATCH=yes ${.TARGET}
-.endif
-
-.include <bsd.port.pre.mk>
-
-.if defined(POWERDNS_WITH_RECURSOR)
-USE_GCC=3.2
-CONFIGURE_ARGS+= --enable-recursor
-PLIST_SUB+= RECURSOR=""
-.else
-PLIST_SUB+= RECURSOR="@comment "
-.endif
-
-.if defined(WITH_LDAP)
-USE_GCC=3.2
-LDAP_PORT?= net/openldap20-client
-LIB_DEPENDS+= ldap.2:${PORTSDIR}/${LDAP_PORT}
-LIB_DEPENDS+= lber.2:${PORTSDIR}/${LDAP_PORT}
-CONFIGURE_MODULES+= "ldap"
-
-post-patch:
- ${REINPLACE_CMD} -e 's;-I. ;-I. -I${LOCALBASE}/include ;' \
- -e 's;la_LDFLAGS =;la_LDFLAGS = -L${LOCALBASE}/lib;' \
- ${WRKSRC}/modules/ldapbackend/Makefile.in
- ${REINPLACE_CMD} -e 's;@LIBDL@;@LIBDL@ -L${LOCALBASE}/lib;' \
- -e 's;@modulelibs@;@modulelibs@ -llber;' \
- ${WRKSRC}/pdns/Makefile.in
-.endif
-
-post-install:
-.if !exists(${PREFIX}/etc/pdns.conf)
- ${INSTALL_DATA} ${PREFIX}/etc/pdns.conf-dist ${PREFIX}/etc/pdns.conf
-.endif
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${EXAMPLESDIR}
-.for i in pdns.conf pdns_mysql.sql pdns_postgresql.sql
- ${INSTALL_DATA} ${FILESDIR}/$i ${EXAMPLESDIR}/
-.endfor
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/dns/powerdns-devel/distinfo b/dns/powerdns-devel/distinfo
deleted file mode 100644
index 8137f0bbe5c0..000000000000
--- a/dns/powerdns-devel/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (pdns-2.9.12.tar.gz) = c30c664b7f1c3baad4422e99c9dd1f18
diff --git a/dns/powerdns-devel/files/configure.powerdns b/dns/powerdns-devel/files/configure.powerdns
deleted file mode 100644
index da3636e5b234..000000000000
--- a/dns/powerdns-devel/files/configure.powerdns
+++ /dev/null
@@ -1,87 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-if [ -f ${WRKDIRPREFIX}${CURDIR2}/Makefile.inc ]; then
- exit
-fi
-
-if [ "${POWERDNS_OPTIONS}" ]; then
- set ${POWERDNS_OPTIONS}
-else
- dialog --title "configuration options" --clear \
- --checklist "\n\
-Please select desired options:" -1 -1 8 \
-PostgreSQL "PostgreSQL driver" ON \
-MySQL323 "MySQL 3.23 driver" OFF \
-MySQL40 "MySQL 4.0 driver" OFF \
-MySQL41 "MySQL 4.1 driver" OFF \
-OpenLDAP20 "OpenLDAP 2.0 backend" OFF \
-OpenLDAP21 "OpenLDAP 2.1 backend" OFF \
-OpenLDAP22 "OpenLDAP 2.2 backend" OFF \
-Recursor "Build Recursor" OFF \
-2> /tmp/checklist.tmp.$$
-
- retval=$?
- if [ -s /tmp/checklist.tmp.$$ ]; then
- set `cat /tmp/checklist.tmp.$$`
- fi
- rm -f /tmp/checklist.tmp.$$
-
- case $retval in
- 0) if [ -z "$*" ]; then
- echo "Nothing selected"
- fi
- ;;
- 1) echo "Cancel pressed."
- exit 1
- ;;
- esac
-fi
-
-${MKDIR} ${WRKDIRPREFIX}${CURDIR2}
-exec > ${WRKDIRPREFIX}${CURDIR2}/Makefile.inc
-
-while [ "$1" ]; do
- case $1 in
- \"PostgreSQL\")
- echo WITH_POSTGRESQL_DRIVER=YES
- ;;
- \"MySQL323\")
- echo WITH_MYSQL_DRIVER=YES
- echo MYSQL_PORT?=databases/mysql323-client
- ;;
- \"MySQL40\")
- echo WITH_MYSQL_DRIVER=YES
- echo MYSQL_PORT?=databases/mysql40-client
- ;;
- \"MySQL41\")
- echo WITH_MYSQL_DRIVER=YES
- echo MYSQL_PORT?=databases/mysql41-client
- ;;
- \"OpenLDAP20\")
- echo WITH_LDAP=YES
- echo LDAP_PORT?=net/openldap20-client
- ;;
- \"OpenLDAP21\")
- echo WITH_LDAP=YES
- echo LDAP_PORT?=net/openldap21-client
- ;;
- \"OpenLDAP22\")
- echo WITH_LDAP=YES
- echo LDAP_PORT?=net/openldap22-client
- ;;
- \"Recursor\")
- echo POWERDNS_WITH_RECURSOR=YES
- ;;
- \"nothing\"|true)
- ;;
- *)
- echo "Invalid option(s): $*" > /dev/stderr
- rm -f ${WRKDIRPREFIX}${CURDIR2}/Makefile.inc
- exit 1
- ;;
- esac
- shift
-done
-exec > /dev/stderr
diff --git a/dns/powerdns-devel/files/patch-configure b/dns/powerdns-devel/files/patch-configure
deleted file mode 100644
index f4121d2c92d6..000000000000
--- a/dns/powerdns-devel/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Mon Dec 16 22:45:46 2002
-+++ configure Mon Dec 16 22:45:59 2002
-@@ -10385,7 +10385,7 @@
- echo "$as_me:$LINENO: result: $PGSQL_incdir" >&5
- echo "${ECHO_T}$PGSQL_incdir" >&6
-
--# LIBS="$LIBS -lpq++ -lpq -lssl -lcrypt -lcrypto"
-+# LIBS="$LIBS -lpq++ -lpq -lssl -lcrypto"
- fi
-
-
diff --git a/dns/powerdns-devel/files/patch-modules_gmysqlbackend_Makefile_in b/dns/powerdns-devel/files/patch-modules_gmysqlbackend_Makefile_in
deleted file mode 100644
index dc74b8e00628..000000000000
--- a/dns/powerdns-devel/files/patch-modules_gmysqlbackend_Makefile_in
+++ /dev/null
@@ -1,11 +0,0 @@
---- modules/gmysqlbackend/Makefile.in.orig Tue Dec 17 10:38:38 2002
-+++ modules/gmysqlbackend/Makefile.in Tue Dec 17 10:38:39 2002
-@@ -181,7 +181,7 @@
- clean-libLTLIBRARIES:
- -test -z "$(lib_LTLIBRARIES)" || rm -f $(lib_LTLIBRARIES)
- libgmysqlbackend.la: $(libgmysqlbackend_la_OBJECTS) $(libgmysqlbackend_la_DEPENDENCIES)
-- $(CXXLINK) -rpath $(libdir) $(libgmysqlbackend_la_LDFLAGS) $(libgmysqlbackend_la_OBJECTS) $(libgmysqlbackend_la_LIBADD) $(LIBS)
-+# $(CXXLINK) -rpath $(libdir) $(libgmysqlbackend_la_LDFLAGS) $(libgmysqlbackend_la_OBJECTS) $(libgmysqlbackend_la_LIBADD) $(LIBS)
-
- mostlyclean-compile:
- -rm -f *.$(OBJEXT) core *.core
diff --git a/dns/powerdns-devel/files/patch-modules_gpgsqlbackend_Makefile_in b/dns/powerdns-devel/files/patch-modules_gpgsqlbackend_Makefile_in
deleted file mode 100644
index a6342919d3fd..000000000000
--- a/dns/powerdns-devel/files/patch-modules_gpgsqlbackend_Makefile_in
+++ /dev/null
@@ -1,29 +0,0 @@
---- modules/gpgsqlbackend/Makefile.in.orig Mon Dec 16 22:32:29 2002
-+++ modules/gpgsqlbackend/Makefile.in Fri Dec 20 14:24:06 2002
-@@ -95,7 +95,7 @@
- lib_LTLIBRARIES = libgpgsqlbackend.la
-
- EXTRA_DIST = OBJECTFILES OBJECTLIBS
--INCLUDES = -I@PGSQL_incdir@
-+INCLUDES = -I@includedir@ -I@PGSQL_incdir@
-
- libgpgsqlbackend_la_SOURCES = gpgsqlbackend.cc gpgsqlbackend.hh \
- spgsql.hh spgsql.cc
-@@ -105,7 +105,7 @@
- -Wl,-Bdynamic
-
-
--libgpgsqlbackend_la_LIBADD = -lssl -lcrypt -lcrypto
-+libgpgsqlbackend_la_LIBADD = -lssl -lcrypto
- subdir = modules/gpgsqlbackend
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
- CONFIG_HEADER = $(top_builddir)/config.h
-@@ -184,7 +184,7 @@
- clean-libLTLIBRARIES:
- -test -z "$(lib_LTLIBRARIES)" || rm -f $(lib_LTLIBRARIES)
- libgpgsqlbackend.la: $(libgpgsqlbackend_la_OBJECTS) $(libgpgsqlbackend_la_DEPENDENCIES)
-- $(CXXLINK) -rpath $(libdir) $(libgpgsqlbackend_la_LDFLAGS) $(libgpgsqlbackend_la_OBJECTS) $(libgpgsqlbackend_la_LIBADD) $(LIBS)
-+# $(CXXLINK) -rpath $(libdir) $(libgpgsqlbackend_la_LDFLAGS) $(libgpgsqlbackend_la_OBJECTS) $(libgpgsqlbackend_la_LIBADD) $(LIBS)
-
- mostlyclean-compile:
- -rm -f *.$(OBJEXT) core *.core
diff --git a/dns/powerdns-devel/files/patch-modules_gpgsqlbackend_OBJECTLIBS b/dns/powerdns-devel/files/patch-modules_gpgsqlbackend_OBJECTLIBS
deleted file mode 100644
index 200a917059a1..000000000000
--- a/dns/powerdns-devel/files/patch-modules_gpgsqlbackend_OBJECTLIBS
+++ /dev/null
@@ -1,5 +0,0 @@
---- modules/gpgsqlbackend/OBJECTLIBS.orig Tue Dec 17 08:35:41 2002
-+++ modules/gpgsqlbackend/OBJECTLIBS Tue Dec 17 08:35:50 2002
-@@ -1 +1 @@
---lpq++ -lpq -lssl -lcrypt -lcrypto
-+-lpq++ -lpq -lssl -lcrypto
diff --git a/dns/powerdns-devel/files/patch-modules_pipebackend_Makefile_in b/dns/powerdns-devel/files/patch-modules_pipebackend_Makefile_in
deleted file mode 100644
index c166925057b6..000000000000
--- a/dns/powerdns-devel/files/patch-modules_pipebackend_Makefile_in
+++ /dev/null
@@ -1,11 +0,0 @@
---- modules/pipebackend/Makefile.in.orig Tue Dec 17 09:39:14 2002
-+++ modules/pipebackend/Makefile.in Tue Dec 17 09:39:39 2002
-@@ -181,7 +181,7 @@
- clean-libLTLIBRARIES:
- -test -z "$(lib_LTLIBRARIES)" || rm -f $(lib_LTLIBRARIES)
- libpipebackend.la: $(libpipebackend_la_OBJECTS) $(libpipebackend_la_DEPENDENCIES)
-- $(CXXLINK) -rpath $(libdir) $(libpipebackend_la_LDFLAGS) $(libpipebackend_la_OBJECTS) $(libpipebackend_la_LIBADD) $(LIBS)
-+# $(CXXLINK) -rpath $(libdir) $(libpipebackend_la_LDFLAGS) $(libpipebackend_la_OBJECTS) $(libpipebackend_la_LIBADD) $(LIBS)
-
- mostlyclean-compile:
- -rm -f *.$(OBJEXT) core *.core
diff --git a/dns/powerdns-devel/files/patch-pdns_backends_bind_bindbackend2_cc b/dns/powerdns-devel/files/patch-pdns_backends_bind_bindbackend2_cc
deleted file mode 100644
index 657994c5c919..000000000000
--- a/dns/powerdns-devel/files/patch-pdns_backends_bind_bindbackend2_cc
+++ /dev/null
@@ -1,16 +0,0 @@
---- pdns/backends/bind/bindbackend2.cc.orig Sat Oct 4 16:15:46 2003
-+++ pdns/backends/bind/bindbackend2.cc Mon Nov 17 20:54:19 2003
-@@ -61,11 +61,10 @@
- d_loaded=false;
- d_last_check=0;
- d_checknow=false;
-- d_rwlock=new pthread_rwlock_t;
- d_status="Seen in bind configuration";
- d_confcount=0;
-- // cout<<"Generated a new bbdomaininfo: "<<(void*)d_rwlock<<"/"<<getpid()<<endl;
-- pthread_rwlock_init(d_rwlock,0);
-+ // cout<<"Generated a new bbdomaininfo: "<<d_rwlock<<"/"<<getpid()<<endl;
-+ pthread_rwlock_init(&d_rwlock,0);
- }
-
- void BB2DomainInfo::setCheckInterval(time_t seconds)
diff --git a/dns/powerdns-devel/files/patch-pdns_backends_bind_bindbackend2_hh b/dns/powerdns-devel/files/patch-pdns_backends_bind_bindbackend2_hh
deleted file mode 100644
index a35c0411fa9a..000000000000
--- a/dns/powerdns-devel/files/patch-pdns_backends_bind_bindbackend2_hh
+++ /dev/null
@@ -1,39 +0,0 @@
---- pdns/backends/bind/bindbackend2.hh.orig Sun Sep 28 20:20:03 2003
-+++ pdns/backends/bind/bindbackend2.hh Mon Nov 17 20:54:19 2003
-@@ -58,21 +58,20 @@
-
- bool tryRLock()
- {
-- // cout<<"[trylock!] "<<(void*)d_rwlock<<"/"<<getpid()<<endl;
-- return pthread_rwlock_tryrdlock(d_rwlock)!=EBUSY;
-+ // cout<<"[trylock!] "<<d_rwlock<<"/"<<getpid()<<endl;
-+ return pthread_rwlock_tryrdlock(&d_rwlock)!=EBUSY;
- }
-
- void unlock()
- {
-- // cout<<"[unlock] "<<(void*)d_rwlock<<"/"<<getpid()<<endl;
-- pthread_rwlock_unlock(d_rwlock);
-+ // cout<<"[unlock] "<<d_rwlock<<"/"<<getpid()<<endl;
-+ pthread_rwlock_unlock(&d_rwlock);
- }
-
- void lock()
- {
-- //cout<<"[writelock!] "<<(void*)d_rwlock<<"/"<<getpid()<<endl;
--
-- pthread_rwlock_wrlock(d_rwlock);
-+ // cout<<"[writelock!] "<<d_rwlock<<"/"<<getpid()<<endl;
-+ pthread_rwlock_wrlock(&d_rwlock);
- }
-
- void setCheckInterval(time_t seconds);
-@@ -81,7 +80,7 @@
- time_t getCtime();
- time_t d_checkinterval;
- time_t d_lastcheck;
-- pthread_rwlock_t *d_rwlock;
-+ pthread_rwlock_t d_rwlock;
- };
-
-
diff --git a/dns/powerdns-devel/files/patch-pdns_backends_bind_bindbackend_cc b/dns/powerdns-devel/files/patch-pdns_backends_bind_bindbackend_cc
deleted file mode 100644
index 19f7cc671c2f..000000000000
--- a/dns/powerdns-devel/files/patch-pdns_backends_bind_bindbackend_cc
+++ /dev/null
@@ -1,16 +0,0 @@
---- pdns/backends/bind/bindbackend.cc.orig Sat Aug 23 16:35:35 2003
-+++ pdns/backends/bind/bindbackend.cc Mon Nov 17 20:54:19 2003
-@@ -58,11 +58,10 @@
- d_loaded=false;
- d_last_check=0;
- d_checknow=false;
-- d_rwlock=new pthread_rwlock_t;
- d_status="Seen in bind configuration";
- d_confcount=0;
-- //cout<<"Generated a new bbdomaininfo: "<<(void*)d_rwlock<<"/"<<getpid()<<endl;
-- pthread_rwlock_init(d_rwlock,0);
-+ //cout<<"Generated a new bbdomaininfo: "<<d_rwlock<<"/"<<getpid()<<endl;
-+ pthread_rwlock_init(&d_rwlock,0);
- }
-
- void BBDomainInfo::setCheckInterval(time_t seconds)
diff --git a/dns/powerdns-devel/files/patch-pdns_backends_bind_bindbackend_hh b/dns/powerdns-devel/files/patch-pdns_backends_bind_bindbackend_hh
deleted file mode 100644
index 0b9e828b9a38..000000000000
--- a/dns/powerdns-devel/files/patch-pdns_backends_bind_bindbackend_hh
+++ /dev/null
@@ -1,39 +0,0 @@
---- pdns/backends/bind/bindbackend.hh.orig Sat Aug 23 16:35:35 2003
-+++ pdns/backends/bind/bindbackend.hh Mon Nov 17 20:54:19 2003
-@@ -58,21 +58,20 @@
-
- bool tryRLock()
- {
-- // cout<<"[trylock!] "<<(void*)d_rwlock<<"/"<<getpid()<<endl;
-- return pthread_rwlock_tryrdlock(d_rwlock)!=EBUSY;
-+ // cout<<"[trylock!] "<<d_rwlock<<"/"<<getpid()<<endl;
-+ return pthread_rwlock_tryrdlock(&d_rwlock)!=EBUSY;
- }
-
- void unlock()
- {
-- // cout<<"[unlock] "<<(void*)d_rwlock<<"/"<<getpid()<<endl;
-- pthread_rwlock_unlock(d_rwlock);
-+ // cout<<"[unlock] "<<d_rwlock<<"/"<<getpid()<<endl;
-+ pthread_rwlock_unlock(&d_rwlock);
- }
-
- void lock()
- {
-- //cout<<"[writelock!] "<<(void*)d_rwlock<<"/"<<getpid()<<endl;
--
-- pthread_rwlock_wrlock(d_rwlock);
-+ // cout<<"[writelock!] "<<d_rwlock<<"/"<<getpid()<<endl;
-+ pthread_rwlock_wrlock(&d_rwlock);
- }
-
- void setCheckInterval(time_t seconds);
-@@ -80,7 +79,7 @@
- time_t getCtime();
- time_t d_checkinterval;
- time_t d_lastcheck;
-- pthread_rwlock_t *d_rwlock;
-+ pthread_rwlock_t d_rwlock;
- };
-
-
diff --git a/dns/powerdns-devel/files/patch-pdns_iputils_hh b/dns/powerdns-devel/files/patch-pdns_iputils_hh
deleted file mode 100644
index 1dcd09077f33..000000000000
--- a/dns/powerdns-devel/files/patch-pdns_iputils_hh
+++ /dev/null
@@ -1,18 +0,0 @@
---- pdns/iputils.hh.orig Sat Aug 30 16:27:48 2003
-+++ pdns/iputils.hh Mon Nov 10 17:27:02 2003
-@@ -51,10 +51,13 @@
- Netmask(const string &mask)
- {
- char *p;
-- char bits=32;
-+ u_int8_t bits=32;
-+ d_mask=0xFFFFFFFF;
-+
- if((p=strchr(mask.c_str(),'/')))
-- bits=atoi(p+1);
-+ bits = (u_int8_t) atoi(p+1);
-
-+ if( bits < 32 )
- d_mask=~(0xFFFFFFFF>>bits);
-
- struct in_addr a;
diff --git a/dns/powerdns-devel/files/pdns.conf b/dns/powerdns-devel/files/pdns.conf
deleted file mode 100644
index a45251872b73..000000000000
--- a/dns/powerdns-devel/files/pdns.conf
+++ /dev/null
@@ -1,300 +0,0 @@
-# MySQL
-#launch=gmysql
-#gmysql-host=127.0.0.1
-#gmysql-dbname=pdns
-#gmysql-user=pdns
-#gmysql-password=pdns
-
-# PostgreSQL
-#launch=gpgsql
-#gpgsql-host=127.0.0.1
-#gpgsql-dbname=pdns
-#gpgsql-user=pdns
-#gpgsql-password=pdns
-
-#################################
-# allow-axfr-ips If disabled, DO allow zonetransfers from these IP addresses
-#
-# allow-axfr-ips=
-
-#################################
-# allow-recursion List of netmasks that are allowed to recurse
-#
-# allow-recursion=
-
-#################################
-# cache-ttl Seconds to store packets in the PacketCache
-#
-# cache-ttl=20
-
-#################################
-# chroot If set, chroot to this directory for more security
-#
-chroot=/var/empty
-
-#################################
-# config-dir Location of configuration directory (pdns.conf)
-#
-# config-dir=/etc
-
-#################################
-# config-name Name of this virtual configuration - will rename the binary image
-#
-# config-name=
-
-#################################
-# control-console Debugging switch - don't use
-#
-# control-console=no
-
-#################################
-# daemon Operate as a daemon
-#
-daemon=yes
-
-#################################
-# default-soa-name name to insert in the SOA record if none set in the backend
-#
-# default-soa-name=ns.example.com
-
-#################################
-# disable-axfr Disable zonetransfers but do allow TCP queries
-#
-# disable-axfr=no
-
-#################################
-# disable-tcp Do not listen to TCP queries
-#
-disable-tcp=no
-
-#################################
-# distributor-threads Default number of Distributor (backend) threads to start
-#
-# distributor-threads=3
-
-#################################
-# fancy-records Process URL and MBOXFW records
-#
-# fancy-records=no
-
-#################################
-# guardian Run within a guardian process
-#
-guardian=yes
-
-#################################
-# launch Which backends to launch and order to query them in
-#
-# launch=
-
-#################################
-# lazy-recursion Only recurse if question cannot be answered locally
-#
-# lazy-recursion=yes
-
-#################################
-# load-modules Load this module - supply absolute or relative path
-#
-# load-modules=
-
-#################################
-# local-address Local IP address to which we bind
-#
-# local-address=0.0.0.0
-
-#################################
-# local-ipv6 Local IP address to which we bind
-#
-# local-ipv6=
-
-#################################
-# local-port The port on which we listen
-#
-# local-port=53
-
-#################################
-# log-dns-details If PDNS should log failed update requests
-#
-# log-dns-details=
-
-#################################
-# log-failed-updates If PDNS should log failed update requests
-#
-# log-failed-updates=
-
-#################################
-# logfile Logfile to use
-#
-# logfile=pdns.log
-
-#################################
-# logging-facility Log under a specific facility
-#
-# logging-facility=
-
-#################################
-# loglevel Amount of logging. Higher is more. Do not set below 3
-#
-# loglevel=4
-
-#################################
-# master Act as a master
-#
-# master=no
-
-#################################
-# max-queue-length Maximum queuelength before considering situation lost
-#
-# max-queue-length=5000
-
-#################################
-# max-tcp-connections Maximum number of TCP connections
-#
-# max-tcp-connections=10
-
-#################################
-# module-dir Default directory for modules
-#
-# module-dir=/usr/local/bin/../lib
-
-#################################
-# negquery-cache-ttl Seconds to store packets in the PacketCache
-#
-# negquery-cache-ttl=60
-
-#################################
-# only-soa Make sure that no SOA serial is less than this number
-#
-# only-soa=org
-
-#################################
-# out-of-zone-additional-processing Do out of zone additional processing
-#
-# out-of-zone-additional-processing=no
-
-#################################
-# query-cache-ttl Seconds to store packets in the PacketCache
-#
-# query-cache-ttl=20
-
-#################################
-# query-logging Hint backends that queries should be logged
-#
-# query-logging=no
-
-#################################
-# queue-limit Maximum number of milliseconds to queue a query
-#
-# queue-limit=1500
-
-#################################
-# receiver-threads Number of receiver threads to launch
-#
-# receiver-threads=1
-
-#################################
-# recursive-cache-ttl Seconds to store packets in the PacketCache
-#
-# recursive-cache-ttl=10
-
-#################################
-# recursor If recursion is desired, IP address of a recursing nameserver
-#
-# recursor=no
-
-#################################
-# setgid If set, change group id to this gid for more security
-#
-# setgid=
-
-#################################
-# setuid If set, change user id to this uid for more security
-#
-# setuid=
-
-#################################
-# skip-cname Do not perform CNAME indirection for each query
-#
-# skip-cname=no
-
-#################################
-# slave Act as a slave
-#
-# slave=no
-
-#################################
-# slave-cycle-interval Reschedule failed SOA serial checks once every .. seconds
-#
-# slave-cycle-interval=60
-
-#################################
-# smtpredirector Our smtpredir MX host
-#
-smtpredirector=voodoo.codeninja.nl
-
-#################################
-# soa-minimum-ttl Default SOA mininum ttl
-#
-# soa-minimum-ttl=3600
-
-#################################
-# soa-serial-offset Make sure that no SOA serial is less than this number
-#
-# soa-serial-offset=0
-
-#################################
-# socket-dir Where the controlsocket will live
-#
-# socket-dir=/var/run
-
-#################################
-# strict-rfc-axfrs Perform strictly rfc compliant axfrs (very slow)
-#
-# strict-rfc-axfrs=no
-
-#################################
-# urlredirector Where we send hosts to that need to be url redirected
-#
-# urlredirector=127.0.0.1
-
-#################################
-# use-logfile Use a log file
-#
-# use-logfile=no
-
-#################################
-# webserver Start a webserver for monitoring
-#
-webserver=yes
-
-#################################
-# webserver-address IP Address of webserver to listen on
-#
-webserver-address=127.0.0.1
-
-#################################
-# webserver-password Password required for accessing the webserver
-#
-# webserver-password=
-
-#################################
-# webserver-port Port of webserver to listen on
-#
-webserver-port=8081
-
-#################################
-# webserver-print-arguments If the webserver should print arguments
-#
-# webserver-print-arguments=no
-
-#################################
-# wildcard-url Process URL and MBOXFW records
-#
-# wildcard-url=no
-
-#################################
-# wildcards Honor wildcards in the database
-#
-# wildcards=
-
-
diff --git a/dns/powerdns-devel/files/pdns_mysql.sql b/dns/powerdns-devel/files/pdns_mysql.sql
deleted file mode 100644
index 278c5d56c61c..000000000000
--- a/dns/powerdns-devel/files/pdns_mysql.sql
+++ /dev/null
@@ -1,38 +0,0 @@
-create table domains (
- id INT auto_increment,
- name VARCHAR(255) NOT NULL,
- master VARCHAR(20) DEFAULT NULL,
- last_check INT DEFAULT NULL,
- type VARCHAR(6) NOT NULL,
- notified_serial INT DEFAULT NULL,
- account VARCHAR(40) DEFAULT NULL,
- primary key (id)
-)type=InnoDB;
-
-CREATE UNIQUE INDEX name_index ON domains(name);
-
-CREATE TABLE records (
- id INT auto_increment,
- domain_id INT DEFAULT NULL,
- name VARCHAR(255) DEFAULT NULL,
- type VARCHAR(6) DEFAULT NULL,
- content VARCHAR(255) DEFAULT NULL,
- ttl INT DEFAULT NULL,
- prio INT DEFAULT NULL,
- change_date INT DEFAULT NULL,
- primary key(id)
-)type=InnoDB;
-
-CREATE INDEX rec_name_index ON records(name);
-CREATE INDEX nametype_index ON records(name,type);
-CREATE INDEX domain_id ON records(domain_id);
-
-create table supermasters (
- ip VARCHAR(25) NOT NULL,
- nameserver VARCHAR(255) NOT NULL,
- account VARCHAR(40) DEFAULT NULL
-);
-
-GRANT SELECT ON supermasters TO pdns;
-GRANT ALL ON domains TO pdns;
-GRANT ALL ON records TO pdns;
diff --git a/dns/powerdns-devel/files/pdns_postgresql.sql b/dns/powerdns-devel/files/pdns_postgresql.sql
deleted file mode 100644
index c700a2aa6dc2..000000000000
--- a/dns/powerdns-devel/files/pdns_postgresql.sql
+++ /dev/null
@@ -1,40 +0,0 @@
-create table domains (
- id SERIAL PRIMARY KEY,
- name VARCHAR(255) NOT NULL,
- master VARCHAR(20) DEFAULT NULL,
- last_check INT DEFAULT NULL,
- type VARCHAR(6) NOT NULL,
- notified_serial INT DEFAULT NULL,
- account VARCHAR(40) DEFAULT NULL
-);
-CREATE UNIQUE INDEX name_index ON domains(name);
-
-CREATE TABLE records (
- id SERIAL PRIMARY KEY,
- domain_id INT DEFAULT NULL,
- name VARCHAR(255) DEFAULT NULL,
- type VARCHAR(6) DEFAULT NULL,
- content VARCHAR(255) DEFAULT NULL,
- ttl INT DEFAULT NULL,
- prio INT DEFAULT NULL,
- change_date INT DEFAULT NULL,
- CONSTRAINT domain_exists
- FOREIGN KEY(domain_id) REFERENCES domains(id)
- ON DELETE CASCADE
-);
-
-CREATE INDEX rec_name_index ON records(name);
-CREATE INDEX nametype_index ON records(name,type);
-CREATE INDEX domain_id ON records(domain_id);
-
-create table supermasters (
- ip VARCHAR(25) NOT NULL,
- nameserver VARCHAR(255) NOT NULL,
- account VARCHAR(40) DEFAULT NULL
-);
-
-GRANT SELECT ON supermasters TO pdns;
-GRANT ALL ON domains TO pdns;
-GRANT ALL ON domains_id_seq TO pdns;
-GRANT ALL ON records TO pdns;
-GRANT ALL ON records_id_seq TO pdns;
diff --git a/dns/powerdns-devel/pkg-descr b/dns/powerdns-devel/pkg-descr
deleted file mode 100644
index 9e1d2d6dbb2d..000000000000
--- a/dns/powerdns-devel/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-PowerDNS is an advanced DNS server, which allows for several different
-backends. Current backends include MySQL, PostgreSQL, bind, etc.
-
-License: GPL V2
-
-WWW: http://www.powerdns.com/
diff --git a/dns/powerdns-devel/pkg-plist b/dns/powerdns-devel/pkg-plist
deleted file mode 100644
index 9c102b6dc03b..000000000000
--- a/dns/powerdns-devel/pkg-plist
+++ /dev/null
@@ -1,12 +0,0 @@
-bin/pdns_control
-bin/zone2ldap
-bin/zone2sql
-sbin/pdns_server
-%%RECURSOR%%sbin/pdns_recursor
-@unexec if cmp -s %D/etc/pdns.conf %D/etc/pdns.conf-dist; then rm -f %D/etc/pdns.conf; fi
-etc/pdns.conf-dist
-@exec [ -f %B/pdns.conf ] || cp %B/%f %B/pdns.conf
-%%PORTDOCS%%share/examples/powerdns/pdns.conf
-%%PORTDOCS%%share/examples/powerdns/pdns_mysql.sql
-%%PORTDOCS%%share/examples/powerdns/pdns_postgresql.sql
-%%PORTDOCS%%@dirrm share/examples/powerdns