aboutsummaryrefslogtreecommitdiff
path: root/dns/py-dnspython/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'dns/py-dnspython/Makefile')
-rw-r--r--dns/py-dnspython/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/dns/py-dnspython/Makefile b/dns/py-dnspython/Makefile
index bd528d88cb90..f6765f0a1538 100644
--- a/dns/py-dnspython/Makefile
+++ b/dns/py-dnspython/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dnspython
PORTVERSION= 1.3.5
+PORTREVISION= 1
CATEGORIES= dns python
MASTER_SITES= http://www.dnspython.org/kits/stable/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -41,5 +42,8 @@ post-install:
.for file in ${EXAMPLE_FILES}
@${INSTALL_DATA} ${WRKSRC}/examples/${file} ${EXAMPLESDIR}
.endfor
+# permission safeness
+ @${CHMOD} -R ${SHAREMODE} ${PYTHONPREFIX_SITELIBDIR}/dns/*
+ @${CHMOD} -R a+X ${PYTHONPREFIX_SITELIBDIR}/dns/*
.include <bsd.port.mk>