aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
Diffstat (limited to 'dns')
-rw-r--r--dns/bind96/Makefile170
-rw-r--r--dns/bind96/distinfo6
-rw-r--r--dns/bind96/pkg-descr24
-rw-r--r--dns/bind96/pkg-message18
-rw-r--r--dns/bind96/pkg-plist250
-rw-r--r--dns/mydns-ng/Makefile89
-rw-r--r--dns/mydns-ng/distinfo3
-rw-r--r--dns/mydns-ng/files/mydns.sh.in30
-rw-r--r--dns/mydns-ng/files/patch-Makefile.in10
-rw-r--r--dns/mydns-ng/files/patch-src_mydns_recursive.c12
-rw-r--r--dns/mydns-ng/files/pkg-message.in14
-rw-r--r--dns/mydns-ng/pkg-descr15
-rw-r--r--dns/mydns-ng/pkg-plist25
13 files changed, 0 insertions, 666 deletions
diff --git a/dns/bind96/Makefile b/dns/bind96/Makefile
deleted file mode 100644
index b7dc0dd99c17..000000000000
--- a/dns/bind96/Makefile
+++ /dev/null
@@ -1,170 +0,0 @@
-# New ports collection makefile for: BIND 9.5.x
-# Date created: 2 July 2008
-# Whom: dougb
-#
-# $FreeBSD$
-#
-
-# I stay very aware of developments with BIND in general, and with
-# BIND 9 in particular. I frequently delay updating this port from
-# a known-stable version due to concerns about stability of a newer
-# version. If you are concerned about using the most recent ISC
-# release you can generally build it cleanly from the source - Doug
-
-PORTNAME= bind95
-PORTVERSION= 9.5.0.2
-CATEGORIES= dns net ipv6
-MASTER_SITES= ${MASTER_SITE_ISC} \
- http://dougbarton.us/Downloads/%SUBDIR%/
-MASTER_SITE_SUBDIR= bind9/${ISCVERSION}
-DISTNAME= bind-${ISCVERSION}
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.asc
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
-
-MAINTAINER= dougb@FreeBSD.org
-COMMENT= The BIND DNS suite with updated DNSSEC and threads
-
-# ISC releases things like 9.4.0b3, which our versioning doesn't like
-ISCVERSION= 9.5.0-P2
-
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps \
- --with-randomdev=/dev/random
-
-USE_OPENSSL= yes
-
-CONFLICTS= bind9-9.[34].* bind9-dlz-* bind9-sdb-ldap-* host-*
-
-OPTIONS= XML "Support for xml statistics output" on \
- IDN "Add IDN support to dig, host, etc." off \
- REPLACE_BASE "Replace base BIND with this version" off \
- LARGE_FILE "64-bit file support" off \
- SIGCHASE "dig/host/nslookup will do DNSSEC validation" off \
- IPV6 "IPv6 Support (autodetected by default)" off
-
-.include <bsd.port.pre.mk>
-
-# We are ok by default from 7.0-RELEASE on
-.if ${OSVERSION} >= 700055
-OPTIONS+= THREADS "Compile with thread support" on
-.else
-OPTIONS+= THREADS "Compile w/threads (Not Recommended <FreeBSD-7)" off
-.endif
-
-.if defined(WITH_OPENSSL_PORT)
-CONFIGURE_ARGS+= --with-openssl=${LOCALBASE}
-.else
-CONFIGURE_ARGS+= --with-openssl
-.endif
-
-.if !defined(WITHOUT_XML)
-CONFIGURE_ARGS+= --with-libxml2=${LOCALBASE}
-LIB_DEPENDS+= xml2.5:${PORTSDIR}/textproc/libxml2
-.else
-CONFIGURE_ARGS+= --without-libxml2
-.endif
-
-.if defined(WITH_IDN)
-CONFIGURE_ARGS+= --with-idn=${LOCALBASE} --with-libiconv=${LOCALBASE}
-BUILD_DEPENDS+= runidn:${PORTSDIR}/dns/idnkit
-.else
-CONFIGURE_ARGS+= --without-idn
-.endif
-
-.if defined(WITH_LARGE_FILE)
-CONFIGURE_ARGS+= --enable-largefile
-.endif
-
-.if defined(WITH_SIGCHASE)
-CONFIGURE_ARGS+= STD_CDEFINES="-DDIG_SIGCHASE=1"
-.endif
-
-.if defined(WITH_IPV6)
-CONFIGURE_ARGS+= --enable-ipv6
-.endif
-
-.if !defined(WITHOUT_THREADS)
-CONFIGURE_ARGS+= --enable-threads
-.else
-CONFIGURE_ARGS+= --disable-threads
-.endif
-
-.if defined(WITH_REPLACE_BASE)
-PKGNAMESUFFIX= -base
-PREFIX= /usr
-BIND_DESTETC= /etc/namedb
-CONFIGURE_ARGS+= --prefix=${PREFIX} \
- --sysconfdir=${BIND_DESTETC}
-.else
-BIND_DESTETC= ${PREFIX}/etc
-.endif
-
-PLIST_SUB= BIND_DESTETC="${BIND_DESTETC}"
-
-MAN1= dig.1 host.1 nslookup.1
-MAN3= lwres.3 lwres_addr_parse.3 lwres_buffer.3 lwres_buffer_add.3 \
- lwres_buffer_back.3 lwres_buffer_clear.3 lwres_buffer_first.3 \
- lwres_buffer_forward.3 lwres_buffer_getmem.3 lwres_buffer_getuint16.3 \
- lwres_buffer_getuint32.3 lwres_buffer_getuint8.3 lwres_buffer_init.3 \
- lwres_buffer_invalidate.3 lwres_buffer_putmem.3 \
- lwres_buffer_putuint16.3 lwres_buffer_putuint32.3 \
- lwres_buffer_putuint8.3 lwres_buffer_subtract.3 lwres_conf_clear.3 \
- lwres_conf_get.3 lwres_conf_init.3 lwres_conf_parse.3 \
- lwres_conf_print.3 lwres_config.3 lwres_context.3 \
- lwres_context_allocmem.3 lwres_context_create.3 \
- lwres_context_destroy.3 lwres_context_freemem.3 \
- lwres_context_initserial.3 lwres_context_nextserial.3 \
- lwres_context_sendrecv.3 lwres_endhostent.3 lwres_endhostent_r.3 \
- lwres_freeaddrinfo.3 lwres_freehostent.3 lwres_gabn.3 \
- lwres_gabnrequest_free.3 lwres_gabnrequest_parse.3 \
- lwres_gabnrequest_render.3 lwres_gabnresponse_free.3 \
- lwres_gabnresponse_parse.3 lwres_gabnresponse_render.3 \
- lwres_gai_strerror.3 lwres_getaddrinfo.3 lwres_getaddrsbyname.3 \
- lwres_gethostbyaddr.3 lwres_gethostbyaddr_r.3 lwres_gethostbyname.3 \
- lwres_gethostbyname2.3 lwres_gethostbyname_r.3 lwres_gethostent.3 \
- lwres_gethostent_r.3 lwres_getipnode.3 lwres_getipnodebyaddr.3 \
- lwres_getipnodebyname.3 lwres_getnamebyaddr.3 lwres_getnameinfo.3 \
- lwres_getrrsetbyname.3 lwres_gnba.3 lwres_gnbarequest_free.3 \
- lwres_gnbarequest_parse.3 lwres_gnbarequest_render.3 \
- lwres_gnbaresponse_free.3 lwres_gnbaresponse_parse.3 \
- lwres_gnbaresponse_render.3 lwres_herror.3 lwres_hstrerror.3 \
- lwres_inetntop.3 lwres_lwpacket_parseheader.3 \
- lwres_lwpacket_renderheader.3 lwres_net_ntop.3 lwres_noop.3 \
- lwres_nooprequest_free.3 lwres_nooprequest_parse.3 \
- lwres_nooprequest_render.3 lwres_noopresponse_free.3 \
- lwres_noopresponse_parse.3 lwres_noopresponse_render.3 \
- lwres_packet.3 lwres_resutil.3 lwres_sethostent.3 \
- lwres_sethostent_r.3 lwres_string_parse.3
-MAN5= named.conf.5 rndc.conf.5
-MAN8= dnssec-keygen.8 dnssec-signzone.8 lwresd.8 named-checkconf.8 \
- named-checkzone.8 named.8 nsupdate.8 rndc-confgen.8 rndc.8
-MLINKS= named-checkzone.8 named-compilezone.8
-
-verify: checksum
- gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.asc
-
-post-patch:
-.for FILE in check/named-checkconf.8 named/named.8 nsupdate/nsupdate.8 \
- rndc/rndc.8
- @${MV} ${WRKSRC}/bin/${FILE} ${WRKSRC}/bin/${FILE}.Dist
- @${SED} -e 's#/etc/named.conf#${BIND_DESTETC}/named.conf#g' \
- -e 's#/etc/rndc.conf#${BIND_DESTETC}/rndc.conf#g' \
- ${WRKSRC}/bin/${FILE}.Dist > ${WRKSRC}/bin/${FILE}
-.endfor
-
-post-install:
- ${INSTALL_DATA} ${WRKSRC}/bin/rndc/rndc.conf \
- ${BIND_DESTETC}/rndc.conf.sample
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}/arm ${DOCSDIR}/misc
- ${INSTALL_DATA} ${WRKSRC}/doc/arm/*.html ${DOCSDIR}/arm
- ${INSTALL_DATA} ${WRKSRC}/doc/arm/Bv9ARM.pdf ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/doc/misc/[a-z]* ${DOCSDIR}/misc
- ${CP} ${WRKSRC}/CHANGES ${WRKSRC}/COPYRIGHT ${WRKSRC}/FAQ \
- ${WRKSRC}/README ${WRKSRC}/README.idnkit ${WRKSRC}/KNOWN-DEFECTS \
- ${DOCSDIR}/
-.endif
-
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.post.mk>
diff --git a/dns/bind96/distinfo b/dns/bind96/distinfo
deleted file mode 100644
index 0798f39393d4..000000000000
--- a/dns/bind96/distinfo
+++ /dev/null
@@ -1,6 +0,0 @@
-MD5 (bind-9.5.0-P2.tar.gz) = 16c893f73a394c8cc36d7900cb9bb801
-SHA256 (bind-9.5.0-P2.tar.gz) = e614450ddaa9ac9ad0138c4da536ea6443e70455f99ef3dcaca8067b5a846a3c
-SIZE (bind-9.5.0-P2.tar.gz) = 6627081
-MD5 (bind-9.5.0-P2.tar.gz.asc) = 5fffa21aa268938f1039ffc2f686bc4c
-SHA256 (bind-9.5.0-P2.tar.gz.asc) = 64cba2475ab3610f29ac933b3400a192d2dc1eba233d0e745b4b612af7e1dfa5
-SIZE (bind-9.5.0-P2.tar.gz.asc) = 486
diff --git a/dns/bind96/pkg-descr b/dns/bind96/pkg-descr
deleted file mode 100644
index 2ab004884cc7..000000000000
--- a/dns/bind96/pkg-descr
+++ /dev/null
@@ -1,24 +0,0 @@
-BIND version 9 is a major rewrite of nearly all aspects of the underlying BIND
-architecture. Some of the important features of BIND 9 are:
-
-DNS Security: DNSSEC (signed zones), TSIG (signed DNS requests)
-IP version 6: Answers DNS queries on IPv6 sockets, IPv6 resource records (AAAA)
- Experimental IPv6 Resolver Library
-DNS Protocol Enhancements: IXFR, DDNS, Notify, EDNS0
- Improved standards conformance
-Views: One server process can provide multiple "views" of the DNS namespace,
- e.g. an "inside" view to certain clients, and an "outside" view to others.
-Multiprocessor Support, including working threads in this version
-
-BIND 9.5 has a number of new features over previous versions, including:
-GSS-TSIG support (RFC 3645), DHCID support
-Experimental http server and statistics support for named via xml
-More detailed statistics counters, compatible with the ones supported in BIND 8
-Faster ACL processing
-Efficient LRU cache cleaning mechanism.
-NSID support (RFC 5001).
-
-WWW: http://www.isc.org/index.pl?/sw/bind/index.php
-
-- Doug Barton
-DougB@FreeBSD.org
diff --git a/dns/bind96/pkg-message b/dns/bind96/pkg-message
deleted file mode 100644
index bb713abdd1d3..000000000000
--- a/dns/bind96/pkg-message
+++ /dev/null
@@ -1,18 +0,0 @@
-*************************************************************************
-* _ _____ _____ _____ _ _ _____ ___ ___ _ _ *
-* / \|_ _|_ _| ____| \ | |_ _|_ _/ _ \| \ | | *
-* / _ \ | | | | | _| | \| | | | | | | | | \| | *
-* / ___ \| | | | | |___| |\ | | | | | |_| | |\ | *
-* /_/ \_\_| |_| |_____|_| \_| |_| |___\___/|_| \_| *
-* *
-* If you are running BIND 9 in a chroot environment, make *
-* sure that there is a /dev/random device in the chroot. *
-* *
-* BIND 9 also requires configuration of rndc, including a *
-* "secret" key. The easiest, and most secure way to configure *
-* rndc is to run 'rndc-confgen -a' to generate the proper conf *
-* file, with a new random key, and appropriate file permissions. *
-* *
-* The /etc/rc.d/named script in the base will do both for you. *
-* *
-*************************************************************************
diff --git a/dns/bind96/pkg-plist b/dns/bind96/pkg-plist
deleted file mode 100644
index fb5b1606df83..000000000000
--- a/dns/bind96/pkg-plist
+++ /dev/null
@@ -1,250 +0,0 @@
-bin/dig
-bin/host
-bin/isc-config.sh
-bin/nslookup
-bin/nsupdate
-include/bind9/check.h
-include/bind9/getaddresses.h
-include/bind9/version.h
-include/dns/acl.h
-include/dns/adb.h
-include/dns/byaddr.h
-include/dns/cache.h
-include/dns/callbacks.h
-include/dns/cert.h
-include/dns/compress.h
-include/dns/db.h
-include/dns/dbiterator.h
-include/dns/dbtable.h
-include/dns/diff.h
-include/dns/dispatch.h
-include/dns/dnssec.h
-include/dns/ds.h
-include/dns/enumclass.h
-include/dns/enumtype.h
-include/dns/events.h
-include/dns/fixedname.h
-include/dns/iptable.h
-include/dns/journal.h
-include/dns/keyflags.h
-include/dns/keytable.h
-include/dns/keyvalues.h
-include/dns/lib.h
-include/dns/log.h
-include/dns/master.h
-include/dns/masterdump.h
-include/dns/message.h
-include/dns/name.h
-include/dns/ncache.h
-include/dns/nsec.h
-include/dns/peer.h
-include/dns/portlist.h
-include/dns/rbt.h
-include/dns/rcode.h
-include/dns/rdata.h
-include/dns/rdataclass.h
-include/dns/rdatalist.h
-include/dns/rdataset.h
-include/dns/rdatasetiter.h
-include/dns/rdataslab.h
-include/dns/rdatastruct.h
-include/dns/rdatatype.h
-include/dns/request.h
-include/dns/resolver.h
-include/dns/result.h
-include/dns/rootns.h
-include/dns/sdb.h
-include/dns/secalg.h
-include/dns/secproto.h
-include/dns/soa.h
-include/dns/ssu.h
-include/dns/tcpmsg.h
-include/dns/time.h
-include/dns/tkey.h
-include/dns/tsig.h
-include/dns/ttl.h
-include/dns/types.h
-include/dns/validator.h
-include/dns/version.h
-include/dns/view.h
-include/dns/xfrin.h
-include/dns/zone.h
-include/dns/zonekey.h
-include/dns/zt.h
-include/dst/dst.h
-include/dst/gssapi.h
-include/dst/lib.h
-include/dst/result.h
-include/isc/app.h
-include/isc/assertions.h
-include/isc/atomic.h
-include/isc/base64.h
-include/isc/bitstring.h
-include/isc/boolean.h
-include/isc/buffer.h
-include/isc/bufferlist.h
-include/isc/commandline.h
-include/isc/condition.h
-include/isc/dir.h
-include/isc/entropy.h
-include/isc/error.h
-include/isc/event.h
-include/isc/eventclass.h
-include/isc/file.h
-include/isc/formatcheck.h
-include/isc/fsaccess.h
-include/isc/hash.h
-include/isc/heap.h
-include/isc/hex.h
-include/isc/hmacmd5.h
-include/isc/httpd.h
-include/isc/int.h
-include/isc/interfaceiter.h
-include/isc/lang.h
-include/isc/lex.h
-include/isc/lfsr.h
-include/isc/lib.h
-include/isc/list.h
-include/isc/log.h
-include/isc/magic.h
-include/isc/md5.h
-include/isc/mem.h
-include/isc/msgcat.h
-include/isc/msgs.h
-include/isc/mutex.h
-include/isc/mutexblock.h
-include/isc/net.h
-include/isc/netaddr.h
-include/isc/netdb.h
-include/isc/offset.h
-include/isc/once.h
-include/isc/ondestroy.h
-include/isc/os.h
-include/isc/parseint.h
-include/isc/platform.h
-include/isc/print.h
-include/isc/quota.h
-include/isc/random.h
-include/isc/ratelimiter.h
-include/isc/refcount.h
-include/isc/region.h
-include/isc/resource.h
-include/isc/result.h
-include/isc/resultclass.h
-include/isc/rwlock.h
-include/isc/serial.h
-include/isc/sha1.h
-include/isc/sha2.h
-include/isc/sockaddr.h
-include/isc/socket.h
-include/isc/stdio.h
-include/isc/stdlib.h
-include/isc/stdtime.h
-include/isc/string.h
-include/isc/symtab.h
-include/isc/syslog.h
-include/isc/task.h
-include/isc/taskpool.h
-include/isc/thread.h
-include/isc/time.h
-include/isc/timer.h
-include/isc/types.h
-include/isc/util.h
-include/isc/version.h
-include/isc/xml.h
-include/isccc/alist.h
-include/isccc/base64.h
-include/isccc/cc.h
-include/isccc/ccmsg.h
-include/isccc/events.h
-include/isccc/lib.h
-include/isccc/result.h
-include/isccc/sexpr.h
-include/isccc/symtab.h
-include/isccc/symtype.h
-include/isccc/types.h
-include/isccc/util.h
-include/isccc/version.h
-include/isccfg/aclconf.h
-include/isccfg/cfg.h
-include/isccfg/grammar.h
-include/isccfg/log.h
-include/isccfg/namedconf.h
-include/isccfg/version.h
-include/lwres/context.h
-include/lwres/int.h
-include/lwres/ipv6.h
-include/lwres/lang.h
-include/lwres/list.h
-include/lwres/lwbuffer.h
-include/lwres/lwpacket.h
-include/lwres/lwres.h
-include/lwres/net.h
-include/lwres/netdb.h
-include/lwres/platform.h
-include/lwres/result.h
-include/lwres/version.h
-lib/libbind9.a
-lib/libdns.a
-lib/libisc.a
-lib/libisccc.a
-lib/libisccfg.a
-lib/liblwres.a
-sbin/dnssec-keygen
-sbin/dnssec-signzone
-sbin/lwresd
-sbin/named
-sbin/named-checkconf
-sbin/named-checkzone
-sbin/named-compilezone
-sbin/rndc
-sbin/rndc-confgen
-%%PORTDOCS%%%%DOCSDIR%%/Bv9ARM.pdf
-%%PORTDOCS%%%%DOCSDIR%%/CHANGES
-%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT
-%%PORTDOCS%%%%DOCSDIR%%/FAQ
-%%PORTDOCS%%%%DOCSDIR%%/KNOWN-DEFECTS
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/README.idnkit
-%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch01.html
-%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch02.html
-%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch03.html
-%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch04.html
-%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch05.html
-%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch06.html
-%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch07.html
-%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch08.html
-%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch09.html
-%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch10.html
-%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.html
-%%PORTDOCS%%%%DOCSDIR%%/arm/man.dig.html
-%%PORTDOCS%%%%DOCSDIR%%/arm/man.dnssec-keygen.html
-%%PORTDOCS%%%%DOCSDIR%%/arm/man.dnssec-signzone.html
-%%PORTDOCS%%%%DOCSDIR%%/arm/man.host.html
-%%PORTDOCS%%%%DOCSDIR%%/arm/man.named-checkconf.html
-%%PORTDOCS%%%%DOCSDIR%%/arm/man.named-checkzone.html
-%%PORTDOCS%%%%DOCSDIR%%/arm/man.named.html
-%%PORTDOCS%%%%DOCSDIR%%/arm/man.rndc-confgen.html
-%%PORTDOCS%%%%DOCSDIR%%/arm/man.rndc.conf.html
-%%PORTDOCS%%%%DOCSDIR%%/arm/man.rndc.html
-%%PORTDOCS%%%%DOCSDIR%%/misc/dnssec
-%%PORTDOCS%%%%DOCSDIR%%/misc/format-options.pl
-%%PORTDOCS%%%%DOCSDIR%%/misc/ipv6
-%%PORTDOCS%%%%DOCSDIR%%/misc/migration
-%%PORTDOCS%%%%DOCSDIR%%/misc/migration-4to9
-%%PORTDOCS%%%%DOCSDIR%%/misc/options
-%%PORTDOCS%%%%DOCSDIR%%/misc/rfc-compliance
-%%PORTDOCS%%%%DOCSDIR%%/misc/roadmap
-%%PORTDOCS%%%%DOCSDIR%%/misc/sdb
-%%PORTDOCS%%%%DOCSDIR%%/misc/sort-options.pl
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/arm
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/misc
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@unexec rm -f %%BIND_DESTETC%%/rndc.conf.sample
-@dirrm include/bind9
-@dirrm include/dns
-@dirrm include/dst
-@dirrmtry include/isc
-@dirrm include/isccc
-@dirrm include/isccfg
-@dirrm include/lwres
diff --git a/dns/mydns-ng/Makefile b/dns/mydns-ng/Makefile
deleted file mode 100644
index d4d5f7a51059..000000000000
--- a/dns/mydns-ng/Makefile
+++ /dev/null
@@ -1,89 +0,0 @@
-# New ports collection makefile for: mydns
-# Date created: 23 July 2002
-# Whom: Simon Dick <simond@irrelevant.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= mydns
-PORTVERSION= 1.1.0
-PORTREVISION= 3
-CATEGORIES= dns databases
-MASTER_SITES= http://mydns.bboy.net/download/
-
-MAINTAINER= ale@FreeBSD.org
-COMMENT= DNS server designed to utilize the MySQL database
-
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-confdir=${PREFIX}/etc
-USE_ICONV= yes
-USE_BZIP2= yes
-
-USE_RC_SUBR= mydns.sh
-
-SUB_FILES= pkg-message
-PKGMESSAGE= ${WRKDIR}/pkg-message
-
-INFO= mydns
-MAN5= mydns.conf.5
-MAN8= mydns.8 mydnscheck.8 mydnsexport.8 mydnsimport.8 mydnsptrconvert.8 mydns-conf.8
-
-DOCS= AUTHORS COPYING ChangeLog NEWS QUICKSTART.mysql QUICKSTART.postgres README TODO
-
-.if defined(WITH_ALIAS)
-CONFIGURE_ARGS+=--enable-alias
-.endif
-
-.if defined(WITH_OPENSSL)
-USE_OPENSSL= yes
-CONFIGURE_ARGS+=--with-openssl \
- --with-openssl-include=${OPENSSLINC} \
- --with-openssl-lib=${OPENSSLLIB}
-.endif
-
-.if defined(WITH_PGSQL)
-USE_PGSQL= yes
-CONFIGURE_ARGS+=--without-mysql \
- --with-pgsql-include=${LOCALBASE}/include \
- --with-pgsql-lib=${LOCALBASE}/lib
-PKGNAMESUFFIX= -pg
-.else
-CONFIGURE_ARGS+=--without-pgsql \
- --with-mysql-include=${LOCALBASE}/include/mysql \
- --with-mysql-lib=${LOCALBASE}/lib/mysql
-PKGNAMESUFFIX= -mysql
-USE_MYSQL= yes
-.endif
-
-.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
-pre-fetch:
- @${ECHO} ""
- @${ECHO} "You may use the following build options:"
- @${ECHO} ""
- @${ECHO} " WITH_PGSQL=yes Build with PostgreSQL support"
- @${ECHO} " WITH_ALIAS=yes Enable server side aliases"
- @${ECHO} " WITH_OPENSSL=yes Enable OpenSSL (needed if MySQL is linked with OpenSSL)"
- @${ECHO} ""
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}/contrib
-.for f in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
-.endfor
- @${INSTALL_DATA} ${WRKSRC}/contrib/*.php ${DOCSDIR}/contrib/
- @${INSTALL_DATA} ${WRKSRC}/contrib/*.pl ${DOCSDIR}/contrib/
- @${INSTALL_DATA} ${WRKSRC}/contrib/*.pm ${DOCSDIR}/contrib/
- @${INSTALL_DATA} ${WRKSRC}/contrib/README ${DOCSDIR}/contrib/
-.endif
- @${PREFIX}/sbin/mydns --dump-config >${PREFIX}/etc/mydns.conf.sample
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.mk>
diff --git a/dns/mydns-ng/distinfo b/dns/mydns-ng/distinfo
deleted file mode 100644
index 77788d9f1ab2..000000000000
--- a/dns/mydns-ng/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (mydns-1.1.0.tar.bz2) = c613a14686f08486d444cee2d68f9c87
-SHA256 (mydns-1.1.0.tar.bz2) = ecfcc8bb8fd9f707d2e7af808317cdcc3a4d701375265840944c4e0ff0d66bf6
-SIZE (mydns-1.1.0.tar.bz2) = 573261
diff --git a/dns/mydns-ng/files/mydns.sh.in b/dns/mydns-ng/files/mydns.sh.in
deleted file mode 100644
index c4332e643140..000000000000
--- a/dns/mydns-ng/files/mydns.sh.in
+++ /dev/null
@@ -1,30 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-# PROVIDE: mydns
-# REQUIRE: DAEMON mysql postgresql
-# KEYWORD: shutdown
-
-#
-# Add the following line to /etc/rc.conf to enable mydns:
-# mydns_enable (bool): Set to "NO" by default.
-# Set it to "YES" to enable MyDNS.
-#
-
-. %%RC_SUBR%%
-
-name="mydns"
-rcvar=`set_rcvar`
-
-load_rc_config $name
-
-: ${mydns_enable="NO"}
-
-command="%%PREFIX%%/sbin/mydns"
-command_args="-b"
-pidfile="/var/run/mydns.pid"
-required_files="%%PREFIX%%/etc/mydns.conf"
-
-run_rc_command "$1"
diff --git a/dns/mydns-ng/files/patch-Makefile.in b/dns/mydns-ng/files/patch-Makefile.in
deleted file mode 100644
index 0148045df6db..000000000000
--- a/dns/mydns-ng/files/patch-Makefile.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- Makefile.in.orig Wed Dec 18 15:16:33 2002
-+++ Makefile.in Wed Dec 18 15:16:43 2002
-@@ -529,7 +529,6 @@
-
- install-data-am:
- @$(NORMAL_INSTALL)
-- $(MAKE) $(AM_MAKEFLAGS) install-data-hook
-
- install-exec-am:
-
diff --git a/dns/mydns-ng/files/patch-src_mydns_recursive.c b/dns/mydns-ng/files/patch-src_mydns_recursive.c
deleted file mode 100644
index b86c0f2b57df..000000000000
--- a/dns/mydns-ng/files/patch-src_mydns_recursive.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/mydns/recursive.c.orig Mon Apr 30 08:17:52 2007
-+++ src/mydns/recursive.c Mon Apr 30 08:22:13 2007
-@@ -109,8 +109,7 @@
- #endif
-
- /* Send to remote server */
-- if ((rv = sendto(t->recursive_fd, query, querylen, 0,
-- (struct sockaddr *)&recursive_sa, sizeof(struct sockaddr_in))) != querylen)
-+ if ((rv = send(t->recursive_fd, query, querylen, 0)) != querylen)
- {
- if (errno == EAGAIN)
- {
diff --git a/dns/mydns-ng/files/pkg-message.in b/dns/mydns-ng/files/pkg-message.in
deleted file mode 100644
index a4840bb5b715..000000000000
--- a/dns/mydns-ng/files/pkg-message.in
+++ /dev/null
@@ -1,14 +0,0 @@
-**********************************************************************
-To get MyDNS working you will need to do some configuration, first you
-will need to create %%PREFIX%%/etc/mydns.conf based on the
-installed sample file. Following that you will need to setup your
-database tables, you can use the output of
-
- %%PREFIX%%/sbin/mydns --create-tables
-
-as a template. Finally enable MyDNS by adding
-
- mydns_enable="YES"
-
-into your rc.conf.
-*********************************************************************
diff --git a/dns/mydns-ng/pkg-descr b/dns/mydns-ng/pkg-descr
deleted file mode 100644
index 42ed867b0baf..000000000000
--- a/dns/mydns-ng/pkg-descr
+++ /dev/null
@@ -1,15 +0,0 @@
-MyDNS is a free DNS server for UNIX implemented from scratch and
-designed to utilize the MySQL database for data storage.
-
-Its primary objectives are stability, security, interoperability,
-and speed, though not necessarily in that order.
-
-MyDNS does not include recursive name service, nor a resolver library.
-It is primarily designed for organizations with many zones and/or
-resource records who desire the ability to perform real-time dynamic
-updates on their DNS data via MySQL.
-
-WWW: http://mydns.bboy.net/
-
-- Alex Dupre
-ale@FreeBSD.org
diff --git a/dns/mydns-ng/pkg-plist b/dns/mydns-ng/pkg-plist
deleted file mode 100644
index fb79abe9eddf..000000000000
--- a/dns/mydns-ng/pkg-plist
+++ /dev/null
@@ -1,25 +0,0 @@
-bin/mydns-conf
-bin/mydnscheck
-bin/mydnsexport
-bin/mydnsimport
-bin/mydnsptrconvert
-etc/mydns.conf.sample
-sbin/mydns
-%%NLS%%share/locale/es/LC_MESSAGES/mydns.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/mydns.mo
-%%NLS%%share/locale/pt_BR/LC_MESSAGES/mydns.mo
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/NEWS
-%%PORTDOCS%%%%DOCSDIR%%/QUICKSTART.mysql
-%%PORTDOCS%%%%DOCSDIR%%/QUICKSTART.postgres
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%PORTDOCS%%%%DOCSDIR%%/contrib/MyDNS.pm
-%%PORTDOCS%%%%DOCSDIR%%/contrib/README
-%%PORTDOCS%%%%DOCSDIR%%/contrib/admin.php
-%%PORTDOCS%%%%DOCSDIR%%/contrib/create_domain.pl
-%%PORTDOCS%%%%DOCSDIR%%/contrib/stats.php
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/contrib
-%%PORTDOCS%%@dirrm %%DOCSDIR%%