aboutsummaryrefslogtreecommitdiff
path: root/editors/aewan
diff options
context:
space:
mode:
Diffstat (limited to 'editors/aewan')
-rw-r--r--editors/aewan/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/editors/aewan/Makefile b/editors/aewan/Makefile
index 0d69807f9eb8..44ca7db921bb 100644
--- a/editors/aewan/Makefile
+++ b/editors/aewan/Makefile
@@ -9,27 +9,26 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Curses-based program for the creation and editing of ASCII art
+OPTIONS_DEFINE= DOCS
+
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
-MAN1= aecat.1 aewan.1 aemakeflic.1
-MAN5= aewan.5
-PLIST_FILES= bin/aecat bin/aewan bin/aemakeflic
+PLIST_FILES= bin/aecat bin/aewan bin/aemakeflic \
+ man/man1/aecat.1.gz \
+ man/man1/aewan.1.gz \
+ man/man1/aemakeflic.1.gz \
+ man/man5/aewan.5.gz
-.if !defined(NOPORTDOCS)
PORTDOCS= *
-.endif
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|OSTYPE == |OSTYPE = |g' ${WRKSRC}/configure
-.if !defined(NOPORTDOCS)
post-install:
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in README
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>