aboutsummaryrefslogtreecommitdiff
path: root/editors/emacs22/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/emacs22/Makefile')
-rw-r--r--editors/emacs22/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/editors/emacs22/Makefile b/editors/emacs22/Makefile
index 7a8d539e944c..9957ad38ce08 100644
--- a/editors/emacs22/Makefile
+++ b/editors/emacs22/Makefile
@@ -3,7 +3,7 @@
# Date created: 29 October 1994
# Whom: jkh
#
-# $Id: Makefile,v 1.31 1998/04/04 07:36:40 asami Exp $
+# $Id: Makefile,v 1.32 1998/09/14 07:26:02 asami Exp $
#
DISTNAME= emacs-19.34b
@@ -18,7 +18,8 @@ NO_LATEST_LINK= yes
WRKSRC= ${WRKDIR}/emacs-19.34
GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ARGS= i386--freebsd --with-x-toolkit
+CONFIGURE_ARGS= i386--freebsd --with-x-toolkit \
+ --sharedstatedir=/var/run
STRIP=
MAN1= emacs.1 etags.1 ctags.1
@@ -32,5 +33,9 @@ post-install:
.for info in emacs vip viper forms gnus mh-e cl sc dired-x ediff ccmode message
install-info ${PREFIX}/info/${info} ${PREFIX}/info/dir
.endfor
+# install emacs.sh into ${PREFIX}/etc/rc.d
+ chmod 1777 /var/run/emacs/lock
+ @${MKDIR} ${PREFIX}/etc/rc.d
+ @${INSTALL_SCRIPT} ${FILESDIR}/emacs.sh ${PREFIX}/etc/rc.d
.include <bsd.port.mk>