aboutsummaryrefslogtreecommitdiff
path: root/editors/gedit-plugins/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/gedit-plugins/Makefile')
-rw-r--r--editors/gedit-plugins/Makefile55
1 files changed, 55 insertions, 0 deletions
diff --git a/editors/gedit-plugins/Makefile b/editors/gedit-plugins/Makefile
new file mode 100644
index 000000000000..30b967751c0e
--- /dev/null
+++ b/editors/gedit-plugins/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: gedit-plugins
+# Date created: 19 September 2003
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/editors/gedit-plugins/Makefile,v 1.18 2006/09/09 02:54:39 ahze Exp $
+#
+
+PORTNAME= gedit-plugins
+PORTVERSION= 2.16.0
+CATEGORIES= editors gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Plugins for GEdit 2
+
+BUILD_DEPENDS= gedit:${PORTSDIR}/editors/gedit \
+ gucharmap:${PORTSDIR}/deskutils/gucharmap
+RUN_DEPENDS= gedit:${PORTSDIR}/editors/gedit \
+ gucharmap:${PORTSDIR}/deskutils/gucharmap
+
+USE_LDCONFIG= yes
+USE_BZIP2= yes
+USE_XLIB= yes
+USE_GMAKE= yes
+USE_GETTEXT= yes
+GNU_CONFIGURE= yes
+USE_GNOME= gnomehack gnomeprefix gnometarget intlhack
+WANT_GNOME= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+GCONF_SCHEMAS= gedit-show-tabbar-plugin.schemas
+
+.if defined(PACKAGE_BUILDING)
+.undef WITHOUT_GNOME
+WITH_GNOME= yes
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${HAVE_GNOME:Mpygnomedesktop}!="" && ${ARCH}!="sparc64"
+USE_PYTHON= yes
+.include "${PORTSDIR}/Mk/bsd.python.mk"
+USE_GNOME+= pygnomedesktop
+CONFIGURE_ARGS+=--enable-python
+PLIST_SUB+= PYTHON=""
+.else
+CONFIGURE_ARGS+=--disable-python
+PLIST_SUB+= PYTHON="@comment "
+.endif
+
+.include <bsd.port.post.mk>