aboutsummaryrefslogtreecommitdiff
path: root/editors/gedit2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/gedit2/Makefile')
-rw-r--r--editors/gedit2/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/editors/gedit2/Makefile b/editors/gedit2/Makefile
index f452eeceab5f..8d9b9b136b20 100644
--- a/editors/gedit2/Makefile
+++ b/editors/gedit2/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= gedit2
-PORTVERSION= 2.6.2
-PORTREVISION= 2
+PORTVERSION= 2.8.1
CATEGORIES= editors gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.6
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.8
DISTNAME= gedit-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -23,13 +22,15 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
INSTALLS_SHLIB= yes
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER=13
-USE_GNOME= gnomeprefix gnomehack intlhack lthack gnomehier \
- libgnomeprintui libgnomeui eel2 gtksourceview
+USE_LIBTOOL_VER=15
+USE_GNOME= gnomeprefix gnomehack intlhack gnomehier \
+ libgnomeprintui libgnomeui eel2 gtksourceview desktopfileutils
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-PLIST_SUB= VERSION="2.6"
+PLIST_SUB= VERSION="2.8" \
+ POVERSION="2.6"
MAN1= gedit.1
+GCONF_SCHEMAS= gedit.schemas
.include <bsd.port.mk>