aboutsummaryrefslogtreecommitdiff
path: root/editors/komodo-edit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/komodo-edit/Makefile')
-rw-r--r--editors/komodo-edit/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/editors/komodo-edit/Makefile b/editors/komodo-edit/Makefile
index f8a2da20077a..8e0d47b8e353 100644
--- a/editors/komodo-edit/Makefile
+++ b/editors/komodo-edit/Makefile
@@ -23,9 +23,9 @@ USE_PYTHON= yes
.include <bsd.port.pre.mk>
do-install:
- ${MKDIR} ${DATADIR}
- (cd ${WRKSRC}/INSTALLDIR && ${COPYTREE_SHARE} . ${DATADIR})
- (cd ${WRKSRC}/INSTALLDIR && ${COPYTREE_BIN} . ${DATADIR} "-type f -a -perm 755")
- ${LN} -sf ${DATADIR}/bin/komodo ${PREFIX}/bin/komodo
+ ${MKDIR} ${DESKTOPDIR}
+ cd ${WRKSRC} && ${SH} install.sh -I ${DATADIR} -s
+ ${LN} -sf ${DATADIR}/bin/komodo ${PREFIX}/bin/
+ ${LN} -sf ${DATADIR}/share/desktop/komodo-edit-5.desktop ${DESKTOPDIR}/
.include <bsd.port.post.mk>