aboutsummaryrefslogtreecommitdiff
path: root/editors/richtext/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/richtext/Makefile')
-rw-r--r--editors/richtext/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/editors/richtext/Makefile b/editors/richtext/Makefile
new file mode 100644
index 000000000000..0b14b7eb7d7d
--- /dev/null
+++ b/editors/richtext/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: richtext
+# Date created: 2006-07-30
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $MBSDlabs$
+# $FreeBSD$
+#
+
+PORTNAME= richtext
+PORTVERSION= 0.1.6
+CATEGORIES= editors
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= apps/editors/X
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= A simple RTF editor
+
+BUILD_DEPENDS= objc:${PORTSDIR}/lang/objc
+
+USE_IMAKE= yes
+USE_MOTIF= yes
+
+PLIST_FILES= bin/rt
+
+post-configure:
+ ${REINPLACE_CMD} -E \
+ -e "s,([[:space:]]*EXTRA_LOAD_FLAGS[[:space:]]*=).*,\1," \
+ ${WRKSRC}/Makefile
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/rt ${PREFIX}/bin
+
+.include <bsd.port.mk>