aboutsummaryrefslogtreecommitdiff
path: root/editors/spe/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/spe/Makefile')
-rw-r--r--editors/spe/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/editors/spe/Makefile b/editors/spe/Makefile
index a1d354d37906..fbda54872de7 100644
--- a/editors/spe/Makefile
+++ b/editors/spe/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= SPE
-PORTVERSION= 0.8.0b
+PORTVERSION= 0.8.0c
CATEGORIES= editors devel python
MASTER_SITES= http://download.berlios.de/python/ \
${MASTER_SITE_SOURCEFORGE}
@@ -15,11 +15,13 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:C/[a-z]$/.&/g}-wx2.6.1.0.-bl2.35
MAINTAINER= nivit@email.it
COMMENT= Stani's Python Editor
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/${WX_PYTHON_DIR}/wxPython/_wx.py:${PORTSDIR}/x11-toolkits/py-wxPython26
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/${WX_PYTHON_DIR}/wxPython/_wx.py:${PORTSDIR}/x11-toolkits/py-wxPython26
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+OPTIONS= ENCRYPTED_DEBUG "Enable encrypted debug in SPE" off
+
SPEDOCS= ${PYTHON_SITELIBDIR}/_${PORTNAME:L}/doc
SPEXAMPLES= ${PYTHON_SITELIBDIR}/_${PORTNAME:L}/examples
WINSCRIPT= spe_wininst.py
@@ -49,4 +51,7 @@ WX_PYTHON_DIR= wx-2.6-gtk2-unicode
WX_PYTHON_DIR= wx-2.6-gtk2-ansi
.endif
+.if defined(WITH_ENCRYPTED_DEBUG)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/Crypto/__init__.py:${PORTSDIR}/security/py-pycrypto
+.endif
.include <bsd.port.post.mk>