aboutsummaryrefslogtreecommitdiff
path: root/editors/wemi-emacs-current/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/wemi-emacs-current/Makefile')
-rw-r--r--editors/wemi-emacs-current/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/editors/wemi-emacs-current/Makefile b/editors/wemi-emacs-current/Makefile
index 4fbaf5bf5d89..588960cd1440 100644
--- a/editors/wemi-emacs-current/Makefile
+++ b/editors/wemi-emacs-current/Makefile
@@ -105,6 +105,11 @@ post-build:
@${MAKE} info-build
.endif
+pre-install:
+.if defined(EMACS_PACKAGESDIR) && defined(EMACS_PACKAGES_SUBDIRS)
+ @${MAKE} mkdir-site-packages
+.endif
+
post-install:
@${MKDIR} -p ${PREFIX}/share/semi
@${TOUCH} ${PREFIX}/share/semi/${SEMI_COOKIE}
@@ -155,6 +160,11 @@ info-build-by-emacs:
done)
.endif
+mkdir-site-packages:
+ @(for i in ${EMACS_PACKAGES_SUBDIRS} ; do \
+ ${MKDIR} ${PREFIX}/${EMACS_PACKAGESDIR}/$${i} ; \
+ done)
+
doc-install:
@${MKDIR} ${PREFIX}/${WEMIDOCDIR}
@(cd ${WRKSRC} ; \