aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
Diffstat (limited to 'editors')
-rw-r--r--editors/vim5/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/editors/vim5/Makefile b/editors/vim5/Makefile
index f80528cb4118..247261cf566a 100644
--- a/editors/vim5/Makefile
+++ b/editors/vim5/Makefile
@@ -57,6 +57,7 @@ LIBS=-lxpg4
MAKE_ARGS+= CONF_OPT_MAX="--enable-max-features"
I18N= CONF_OPT_MULTIBYTE="--enable-multibyte --enable-fontset --enable-xim"
+.if !defined(NO_GUI)
.if defined(WITH_ATHENA)
MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=athena" ${I18N}
#MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=yes" ${I18N}
@@ -67,6 +68,9 @@ MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=gtk --with-gtk-prefix=${X11BASE}" ${I18N}
USE_MOTIF= yes
MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=motif --with-motif-lib=\"${MOTIFLIB}\"" MOTIFHOME=${X11BASE} ${I18N}
.endif
+.else # NO_GUI
+MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=no --without-x --enable-multibyte"
+.endif # NO_GUI
.if defined(PACKAGE_BUILDING)
MAKE_ARGS+= CONF_OPT_PERL="--enable-perlinterp --enable-pythoninterp --enable-tclinterp --enable-cscope"