aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
Diffstat (limited to 'editors')
-rw-r--r--editors/e93/Makefile8
-rw-r--r--editors/ved/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/editors/e93/Makefile b/editors/e93/Makefile
index cea63ac3efa8..1611b98c2623 100644
--- a/editors/e93/Makefile
+++ b/editors/e93/Makefile
@@ -19,6 +19,12 @@ COMMENT= A nifty editor based on Tcl/Tk
LIB_DEPENDS= tcl82.1:${PORTSDIR}/lang/tcl82 \
tk82.1:${PORTSDIR}/x11-toolkits/tk82
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_X_PREFIX= yes
@@ -50,4 +56,4 @@ do-install:
${INSTALL_DATA} syntaxmaps/c.tcl ${PREFIX}/lib/e93lib/syntaxmaps; \
)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/editors/ved/Makefile b/editors/ved/Makefile
index 0b2b308220f1..eb40293e83f4 100644
--- a/editors/ved/Makefile
+++ b/editors/ved/Makefile
@@ -13,6 +13,12 @@ MASTER_SITES= ftp://ftp.fokus.gmd.de/pub/unix/ved/
MAINTAINER= greid@ukug.uk.freebsd.org
COMMENT= A small and fast screen-oriented editor.
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
USE_GMAKE= yes
MAN1= ved.1
@@ -30,4 +36,4 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/ved/ved.1 ${PREFIX}/man/man1
${INSTALL_DATA} ${WRKSRC}/ved/ved.help ${PREFIX}/share
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>