aboutsummaryrefslogtreecommitdiff
path: root/emulators/bsvc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/bsvc/Makefile')
-rw-r--r--emulators/bsvc/Makefile32
1 files changed, 16 insertions, 16 deletions
diff --git a/emulators/bsvc/Makefile b/emulators/bsvc/Makefile
index 9055a71b9472..7f7ba0917ef7 100644
--- a/emulators/bsvc/Makefile
+++ b/emulators/bsvc/Makefile
@@ -3,7 +3,7 @@
# Date created: 03-Mar-1997
# Whom: tenser
#
-# $Id: Makefile,v 1.6 1998/04/05 07:30:56 asami Exp $
+# $Id: Makefile,v 1.7 1998/08/07 23:56:18 asami Exp $
#
DISTNAME= bsvc-2.0
@@ -23,28 +23,28 @@ WISH= wish4.1
pre-patch:
@awk ' \
{ \
- if (/PROJECT_BASE/ && /AWK_CHANGE_ME/) { \
- print "! PROJECT_BASE='"${WRKDIR}/${DISTNAME}"'" \
- } else if (/INSTALL_DIR/ && /AWK_CHANGE_ME/) { \
- print "! INSTALL_DIR='"${PREFIX}/bin"'" \
- } else if (/LIB_DIR/ && /AWK_CHANGE_ME/) { \
- print "! LIB_DIR ='"${PREFIX}/lib/bsvc"'" \
- } else if (/WISH/ && /AWK_CHANGE_ME/) { \
- print "! WISH='"${WISH}"'" \
+ if (/^## Makefile/) { \
+ print "## Makefile.FreeBSD - System Dependent Makefile for FreeBSD" \
} else { \
print \
} \
- }' < ${FILESDIR}/patch-aa.in > ${PATCHDIR}/patch-aa
+ }' < ${WRKSRC}/Makefile.ULTRIX > ${WRKSRC}/Makefile
+
+post-patch:
@awk ' \
{ \
- if (/^## Makefile/) { \
- print "## Makefile.FreeBSD - System Dependent Makefile for FreeBSD" \
+ if (/PROJECT_BASE/ && /AWK_CHANGE_ME/) { \
+ print "PROJECT_BASE='"${WRKDIR}/${DISTNAME}"'" \
+ } else if (/INSTALL_DIR/ && /AWK_CHANGE_ME/) { \
+ print "INSTALL_DIR='"${PREFIX}/bin"'" \
+ } else if (/LIB_DIR/ && /AWK_CHANGE_ME/) { \
+ print "LIB_DIR ='"${PREFIX}/lib/bsvc"'" \
+ } else if (/WISH/ && /AWK_CHANGE_ME/) { \
+ print "WISH='"${WISH}"'" \
} else { \
print \
} \
- }' < ${WRKSRC}/Makefile.ULTRIX > ${WRKSRC}/Makefile
-
-pre-clean:
- ${RM} -f ${PATCHDIR}/patch-aa
+ }' < ${WRKSRC}/Makefile.common > ${WRKSRC}/Makefile.common.tmp
+ @${MV} -f ${WRKSRC}/Makefile.common.tmp ${WRKSRC}/Makefile.common
.include <bsd.port.mk>