aboutsummaryrefslogtreecommitdiff
path: root/emulators/gnuboy
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/gnuboy')
-rw-r--r--emulators/gnuboy/Makefile5
-rw-r--r--emulators/gnuboy/files/patch-configure.in4
2 files changed, 3 insertions, 6 deletions
diff --git a/emulators/gnuboy/Makefile b/emulators/gnuboy/Makefile
index 62b2a328d2d1..ab29959db131 100644
--- a/emulators/gnuboy/Makefile
+++ b/emulators/gnuboy/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gnuboy
PORTVERSION= 1.0.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= emulators games
MASTER_SITES= http://gnuboy.unix-fu.org/src/ \
http://brightrain.aerifal.cx/~laguna/src/
@@ -32,9 +32,6 @@ PORTDOCS= *
PLIST_FILES= bin/sdlgnuboy bin/sgnuboy bin/xgnuboy
post-patch:
-.for file in sys/sdl/sdl.c sys/sdl/keymap.c
- @${REINPLACE_CMD} -e "s|SDL/|SDL11/|g" ${WRKSRC}/${file}
-.endfor
do-install:
.for file in sdlgnuboy sgnuboy xgnuboy
diff --git a/emulators/gnuboy/files/patch-configure.in b/emulators/gnuboy/files/patch-configure.in
index 2d0e6f9aae3a..a928b9d32aac 100644
--- a/emulators/gnuboy/files/patch-configure.in
+++ b/emulators/gnuboy/files/patch-configure.in
@@ -12,8 +12,8 @@
INCS="$INCS $SDL_CFLAGS"
-AC_CHECK_LIB(SDL, SDL_Init, [
-AC_CHECK_HEADERS(SDL/SDL.h, ,[
-+AC_CHECK_LIB(SDL-1.1, SDL_Init, [
-+AC_CHECK_HEADERS(SDL11/SDL.h, ,[
++AC_CHECK_LIB(SDL, SDL_Init, [
++AC_CHECK_HEADERS(SDL/SDL.h, ,[
AC_MSG_WARN(SDL found but headers are missing!!)
with_sdl=no
])], [with_sdl=no], $SDL_LIBS)