aboutsummaryrefslogtreecommitdiff
path: root/emulators/linux_base-8
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/linux_base-8')
-rw-r--r--emulators/linux_base-8/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/emulators/linux_base-8/Makefile b/emulators/linux_base-8/Makefile
index 4b2e965be041..8a29232ab236 100644
--- a/emulators/linux_base-8/Makefile
+++ b/emulators/linux_base-8/Makefile
@@ -156,23 +156,23 @@ do-install:
#
@for R in ${RPM_SET1}; do \
${ECHO} $$R; \
- rpm -i ${RPMFLAGS} ${RPMDIR}/$$R; \
+ rpm -U ${RPMFLAGS} ${RPMDIR}/$$R; \
done
@${ECHO} ${RPM_LDCONFIG}
- @rpm -i ${RPMFLAGS} --noscripts ${RPMDIR}/${RPM_LDCONFIG}
+ @rpm -U ${RPMFLAGS} --noscripts ${RPMDIR}/${RPM_LDCONFIG}
@brandelf -t Linux ${PREFIX}/sbin/ldconfig
@${PREFIX}/sbin/ldconfig
@${TOUCH} ${PREFIX}/etc/ld.so.conf
@for R in ${RPM_SET2}; do \
${ECHO} $$R; \
- rpm -i ${RPMFLAGS} ${RPMDIR}/$$R; \
+ rpm -U ${RPMFLAGS} ${RPMDIR}/$$R; \
done
@${ECHO} ${RPM_RPM}
- @rpm -i ${RPMFLAGS} --noscripts ${RPMDIR}/${RPM_RPM}
+ @rpm -U ${RPMFLAGS} --noscripts ${RPMDIR}/${RPM_RPM}
@brandelf -t Linux ${PREFIX}/bin/rpm
@for R in ${RPM_SET3}; do \
${ECHO} $$R; \
- rpm -i ${RPMFLAGS} ${RPMDIR}/$$R; \
+ rpm -U ${RPMFLAGS} ${RPMDIR}/$$R; \
done
#
# Install updates