aboutsummaryrefslogtreecommitdiff
path: root/emulators/pearpc
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/pearpc')
-rw-r--r--emulators/pearpc/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/emulators/pearpc/Makefile b/emulators/pearpc/Makefile
index aeb9446e9ae0..13886a8619fe 100644
--- a/emulators/pearpc/Makefile
+++ b/emulators/pearpc/Makefile
@@ -28,7 +28,8 @@ PLIST_DIRS= %%DATADIR%%
.if defined(WITH_OPTIMIZED_CFLAGS)
CFLAGS+= -O3 -ffast-math
.else
-CONFIGURE_ARGS+= --disable-fpo
+CONFIGURE_ARGS+= --disable-fpo \
+ --disable-release
.endif
# GTK and QT ui are broken in this version
@@ -49,6 +50,12 @@ USE_SDL= sdl
CONFIGURE_ARGS+= --enable-ui=x11
.endif
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+.else
+CONFIGURE_ARGS+= --disable-debug
+.endif
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "ia64"