aboutsummaryrefslogtreecommitdiff
path: root/emulators/pipelight
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/pipelight')
-rw-r--r--emulators/pipelight/Makefile2
-rw-r--r--emulators/pipelight/files/pipelight-mkufs.in5
2 files changed, 5 insertions, 2 deletions
diff --git a/emulators/pipelight/Makefile b/emulators/pipelight/Makefile
index f686ee6d262a..e99a9df4afff 100644
--- a/emulators/pipelight/Makefile
+++ b/emulators/pipelight/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pipelight
DISTVERSION= 0.2.7.3
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= emulators
MASTER_SITES= https://bitbucket.org/mmueller2012/pipelight/get/ \
http://repos.fds-team.de/pluginloader/v${DISTVERSION}/:plg
diff --git a/emulators/pipelight/files/pipelight-mkufs.in b/emulators/pipelight/files/pipelight-mkufs.in
index 3a0c1d6cf120..24ee77d99526 100644
--- a/emulators/pipelight/files/pipelight-mkufs.in
+++ b/emulators/pipelight/files/pipelight-mkufs.in
@@ -85,8 +85,11 @@ if [ $? -ne 0 ] ; then
exit 1
fi
+# Get user group
+usergroup=`groups $username | cut -d " " -f 1`
+
# Chown the directory
-chown $username:$username ${userhome}/.wine-pipelight
+chown $username:$usergroup ${userhome}/.wine-pipelight
# Save to fstab
echo "/dev/zvol/$zpool/$username-pipelight ${userhome}/.wine-pipelight ufs rw,late 0 0" >> /etc/fstab