aboutsummaryrefslogtreecommitdiff
path: root/emulators/qemu/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/qemu/Makefile')
-rw-r--r--emulators/qemu/Makefile85
1 files changed, 20 insertions, 65 deletions
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index 1808d99c128e..4e6438a98cbf 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= qemu
-PORTVERSION= 2.5.1.1
+PORTVERSION= 2.6.1
CATEGORIES= emulators
MASTER_SITES= http://wiki.qemu.org/download/
DIST_SUBDIR= qemu/${PORTVERSION}
@@ -16,13 +16,13 @@ HAS_CONFIGURE= yes
USES= cpe gmake pkgconfig bison perl5 python:2,build tar:bzip2
USE_PERL5= build
USE_XORG= pixman
-USE_GNOME+= glib20
+USE_GNOME+= cairo glib20
MAKE_ENV+= BSD_MAKE="${MAKE}"
ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64 # XXX someone wants to debug sparc64 hosts?
OPTIONS_DEFINE= SAMBA X11 GTK2 OPENGL GNUTLS SASL JPEG PNG CURL \
CDROM_DMA PCAP USBREDIR GNS3 X86_TARGETS \
- STATIC_LINK DOCS BSD_USER
+ STATIC_LINK DOCS NCURSES
SAMBA_DESC= samba dependency (for -smb)
GNUTLS_DESC= gnutls dependency (vnc encryption)
SASL_DESC= cyrus-sasl dependency (vnc encryption)
@@ -33,18 +33,16 @@ PCAP_DESC= pcap dependency (networking with bpf)
USBREDIR_DESC= usb device network redirection (experimental!)
GNS3_DESC= gns3 patches (promiscuous multicast)
X86_TARGETS_DESC= Build only x86 system targets
-BSD_USER_DESC= Also build bsd-user targets (for testing)
STATIC_LINK_DESC= Statically link the executables
-OPTIONS_DEFAULT=X11 GTK2 OPENGL GNUTLS SASL JPEG PNG CDROM_DMA CURL PCAP GNS3
+OPTIONS_DEFAULT=X11 GTK2 OPENGL GNUTLS SASL JPEG PNG CDROM_DMA CURL PCAP GNS3 NCURSES
OPTIONS_SUB= yes
-X11_USE= SDL=sdl
-X11_CONFIGURE_ON= --enable-sdl
-X11_CONFIGURE_OFF= --disable-sdl
+X11_USE= SDL=sdl XORG=x11,xext GNOME=gdkpixbuf2
+X11_CONFIGURE_ENABLE= sdl
GTK2_USE= GNOME=gtk20,vte
GTK2_USES= gettext
GTK2_CONFIGURE_OFF= --disable-gtk --disable-vte
GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
-GNUTLS_CONFIGURE_OFF= --disable-vnc-tls
+GNUTLS_CONFIGURE_OFF= --disable-gnutls
SASL_LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
SASL_CONFIGURE_OFF= --disable-vnc-sasl
JPEG_USES= jpeg
@@ -59,76 +57,32 @@ USBREDIR_BUILD_DEPENDS= usbredir>=0.6:net/usbredir
USBREDIR_RUN_DEPENDS= usbredir>=0.6:net/usbredir
USBREDIR_CONFIGURE_OFF= --disable-usb-redir
PCAP_CONFIGURE_ON= --enable-pcap
+PCAP_EXTRA_PATCHES= ${FILESDIR}/pcap-patch ${FILESDIR}/pcap-patch-net_net.c
STATIC_LINK_CONFIGURE_ON= --static
+STATIC_LINK_PREVENTS= GTK2 X11
+STATIC_LINK_PREVENTS_MSG= X11 ui cannot be built static
+NCURSES_USES= ncurses
SAMBA_RUN_DEPENDS= ${LOCALBASE}/sbin/smbd:net/samba36
DOCS_BUILD_DEPENDS= texi2html:textproc/texi2html
DOCS_USES= makeinfo
DOCS_MAKE_ARGS_OFF= NOPORTDOCS=1
-.if !defined(QEMU_USER_STATIC)
-CONFLICTS_INSTALL= qemu-devel-[0-9]* qemu-sbruno-[0-9]*
-.endif
-
PORTDOCS= docs qemu-doc.html qemu-tech.html qmp-commands.txt
WITHOUT_CPU_CFLAGS=yes #to avoid problems with register allocation
CFLAGS:= ${CFLAGS:C/-fno-tree-vrp//}
CONFIGURE_ARGS+=--localstatedir=/var --extra-ldflags=-L\"${LOCALBASE}/lib\" \
- --disable-libssh2 --enable-debug \
+ --disable-libssh2 --enable-debug --enable-curses \
--prefix=${PREFIX} --cc=${CC} --enable-docs --disable-kvm \
--disable-linux-user --disable-linux-aio --disable-xen \
--smbd=${LOCALBASE}/sbin/smbd --enable-debug-info --python=${PYTHON_CMD} \
--extra-cflags=-I${WRKSRC}\ -I${LOCALBASE}/include\ -DPREFIX=\\\"\"${PREFIX}\\\"\"
-.include <bsd.port.options.mk>
-
-.if defined(QEMU_USER_STATIC)
-.if ${ARCH} != "amd64"
-CONFIGURE_ARGS+= --target-list=i386-bsd-user,sparc-bsd-user,arm-bsd-user,mips-bsd-user,mipsel-bsd-user
-.else
-CONFIGURE_ARGS+= --target-list=i386-bsd-user,x86_64-bsd-user,sparc-bsd-user,sparc64-bsd-user,arm-bsd-user,mips-bsd-user,mipsel-bsd-user,mips64-bsd-user,mips64el-bsd-user
-.endif
-.else
-.if ${PORT_OPTIONS:MX86_TARGETS}
-.if ${PORT_OPTIONS:MBSD_USER}
-.if ${ARCH} != "amd64"
-CONFIGURE_ARGS+= --target-list=i386-softmmu,x86_64-softmmu,i386-bsd-user,sparc-bsd-user,arm-bsd-user,mips-bsd-user,mipsel-bsd-user
-.else
-CONFIGURE_ARGS+= --target-list=i386-softmmu,x86_64-softmmu,i386-bsd-user,x86_64-bsd-user,sparc-bsd-user,sparc64-bsd-user,arm-bsd-user,mips-bsd-user,mipsel-bsd-user,mips64-bsd-user,mips64el-bsd-user
-.endif
-.else
-CONFIGURE_ARGS+= --target-list=i386-softmmu,x86_64-softmmu
-.endif
-.else
-.if empty(PORT_OPTIONS:MBSD_USER)
-CONFIGURE_ARGS+= --disable-bsd-user
-.else
-.if ${ARCH} != "amd64"
-CONFIGURE_ARGS+= --target-list=i386-softmmu,x86_64-softmmu,aarch64-softmmu,alpha-softmmu,arm-softmmu,cris-softmmu,lm32-softmmu,m68k-softmmu,microblaze-softmmu,microblazeel-softmmu,mips-softmmu,mipsel-softmmu,mips64-softmmu,mips64el-softmmu,or32-softmmu,ppc-softmmu,ppcemb-softmmu,ppc64-softmmu,sh4-softmmu,sh4eb-softmmu,sparc-softmmu,sparc64-softmmu,s390x-softmmu,xtensa-softmmu,xtensaeb-softmmu,unicore32-softmmu,moxie-softmmu,i386-bsd-user,sparc-bsd-user,arm-bsd-user,mips-bsd-user,mipsel-bsd-user
-.endif
-.endif
-.endif
-.endif
-
-.if ${PORT_OPTIONS:MBSD_USER} && ${ARCH} == "sparc64"
-IGNORE= bsd-user targets not tested on sparc64
-.endif
-
-.if empty(PORT_OPTIONS:MBSD_USER) || ${ARCH} != "amd64"
-PLIST_SUB+= BSD_USER64="@comment "
-.else
-PLIST_SUB+= BSD_USER64=""
-.endif
-
-.if defined(QEMU_USER_STATIC)
-PLIST_SUB+= SOFTMMU="@comment " STATIC="-static"
-.else
-PLIST_SUB+= SOFTMMU="" STATIC=""
-.endif
+LIB_DEPENDS+= libnettle.so:security/nettle \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
-.if ${PORT_OPTIONS:MSTATIC_LINK} && (${PORT_OPTIONS:MGTK2} || ${PORT_OPTIONS:MX11})
-IGNORE= X11 ui cannot be built static
-.endif
+.include <bsd.port.options.mk>
.if !defined(STRIP) || ${STRIP} == ""
CONFIGURE_ARGS+=--disable-strip
@@ -153,6 +107,9 @@ CONFIGURE_ARGS+= --sparc_cpu=v9
# -lprocstat actually only _needs_ -lelf after r249666 or r250870 (MFC)
# but it shouldn't matter much
post-patch:
+ @${REINPLACE_CMD} -e '/LIBS/s|-lprocstat|-lprocstat -lelf|' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/libs_qga=/s|glib_libs|glib_libs -lintl|' ${WRKSRC}/configure
@${REINPLACE_CMD} -E \
-e "/^by Tibor .TS. S/s|Sch.*z.$$|Schuetz.|" \
${WRKSRC}/qemu-doc.texi
@@ -175,9 +132,6 @@ post-patch-GNS3-on:
@${REINPLACE_CMD} -e 's|(buf\[0\] & 1) && (rctl & E1000_RCTL_MPE)|buf[0] \& 1|' \
${WRKSRC}/hw/net/e1000.c
-post-patch-PCAP-on:
- @cd ${WRKSRC} && ${PATCH} --quiet < ${FILESDIR}/pcap-patch
-
# XXX need to disable usb host code on head while it's not ported to the
# new usb stack yet
post-configure:
@@ -190,6 +144,7 @@ post-install:
${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifup.sample ${STAGEDIR}${PREFIX}/etc
${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifdown.sample ${STAGEDIR}${PREFIX}/etc
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/qemu-*
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/ivshmem-*
post-install-DOCS-on:
@(cd ${WRKSRC} && ${COPYTREE_SHARE} docs ${STAGEDIR}${DOCSDIR}/)