aboutsummaryrefslogtreecommitdiff
path: root/emulators/snespp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/snespp/Makefile')
-rw-r--r--emulators/snespp/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/emulators/snespp/Makefile b/emulators/snespp/Makefile
new file mode 100644
index 000000000000..9afab0539515
--- /dev/null
+++ b/emulators/snespp/Makefile
@@ -0,0 +1,35 @@
+# Ports collection makefile for: snespp
+# Date created: 16 April 2007
+# Whom: Timothy Bourke <timbob@bigpond.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= snespp
+PORTVERSION= 1.0
+CATEGORIES= emulators
+MASTER_SITES= http://www.cse.unsw.edu.au/~tbourke/software/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= timbob@bigpond.com
+COMMENT= Kernel module for SNES controllers on a parallel port
+
+KMODDIR= /boot/modules
+
+NO_PACKAGE= this port should be recompiled for a particular FreeBSD kernel
+PLIST_SUB= KMODDIR="${KMODDIR}"
+
+MAN4= snespp.4
+MANCOMPRESSED= no
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000
+IGNORE= versions of FreeBSD before 6.0 are not supported
+.endif
+
+do-install:
+ @${INSTALL_MAN} ${WRKSRC}/snespp.4 ${PREFIX}/man/man4
+ @${INSTALL_PROGRAM} ${WRKSRC}/snespp.ko ${KMODDIR}
+
+.include <bsd.port.post.mk>