aboutsummaryrefslogtreecommitdiff
path: root/emulators/wine-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/wine-devel/Makefile')
-rw-r--r--emulators/wine-devel/Makefile82
1 files changed, 0 insertions, 82 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
deleted file mode 100644
index db372573a018..000000000000
--- a/emulators/wine-devel/Makefile
+++ /dev/null
@@ -1,82 +0,0 @@
-# ex:ts=8
-# New ports collection makefile for: wine
-# Date created: Sa 9 Nov 1996 00:52:22 MET
-# Whom: se
-#
-# $FreeBSD$
-#
-
-PORTNAME= wine
-DISTVERSION= 1.0-rc2
-PORTEPOCH= 1
-CATEGORIES= emulators
-MASTER_SITES= SFE \
- http://ibiblio.org/pub/linux/system/emulators/wine/
-MASTER_SITE_SUBDIR= ${PORTNAME}
-
-MAINTAINER= gerald@FreeBSD.org
-COMMENT= Microsoft Windows compatibility layer for Unix-like systems
-
-LIB_DEPENDS= cups.2:${PORTSDIR}/print/cups-base \
- fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
- freetype.9:${PORTSDIR}/print/freetype2 \
- jpeg.9:${PORTSDIR}/graphics/jpeg \
- lcms.1:${PORTSDIR}/graphics/lcms \
- xml2:${PORTSDIR}/textproc/libxml2
-
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --datadir=${DATADIR} --verbose
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/wine
-MAN1= widl.1 wine.1 winebuild.1 winedbg.1 winedump.1 winegcc.1 \
- winemaker.1 wineprefixcreate.1 wineserver.1 wmc.1 wrc.1
-MLINKS= winegcc.1 wineg++.1
-ONLY_FOR_ARCHS= i386
-USE_BISON= build
-USE_BZIP2= yes
-USE_GMAKE= yes
-USE_GL= glut
-USE_XORG= xpm
-
-SUB_FILES= pkg-message
-PKGMESSAGE= ${WRKDIR}/pkg-message
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 602000
-IGNORE= fails to properly work on versions of FreeBSD before 6.2 (due to problems with threading support)
-.endif
-
-post-patch:
-.if ${OSVERSION} < 700041
- ${REINPLACE_CMD} 's/-lpthread/-lthr/g' ${WRKSRC}/configure
-.endif
-
-pre-build:
- cd ${WRKSRC} && make depend
-
-post-install:
- @${RM} -f ${MAN1PREFIX}/man/de.UTF-8/man1/wine.1 \
- ${MAN1PREFIX}/man/fr.UTF-8/man1/wine.1 \
- ${MAN1PREFIX}/man/fr.UTF-8/man1/wineserver.1
- @-${RMDIR} -p ${MAN1PREFIX}/man/de.UTF-8/man1 \
- ${MAN1PREFIX}/man/fr.UTF-8/man1
- ${MV} -f ${PREFIX}/lib/libwine.so.1.0 ${PREFIX}/lib/libwine.so.1
- ${LN} -sf libwine.so.1 ${PREFIX}/lib/libwine.so
-.if !defined(NOPORTDOCS)
- -@${MKDIR} ${DOCSDIR}
-.for i in README ANNOUNCE AUTHORS LICENSE
- @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
-.endfor
-.for i in progman uninstaller winedbg winemine
- @${INSTALL_DATA} ${WRKSRC}/programs/${i}/README ${DOCSDIR}/README.${i}
-.endfor
- @${INSTALL_DATA} ${WRKSRC}/tools/winedump/README ${DOCSDIR}/README.winedump
-.endif
- @${MKDIR} ${DESKTOPDIR}
- @${MV} ${DATADIR}/applications/wine.desktop ${DESKTOPDIR}/
- @${ECHO}
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.post.mk>