aboutsummaryrefslogtreecommitdiff
path: root/emulators/wine/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/wine/Makefile')
-rw-r--r--emulators/wine/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index 0a46ca4c4813..fa41aedb7ab3 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -50,6 +50,10 @@ pre-extract:
@${ECHO} "that when running, only when it has to enter the debugger...)"
.endif
+post-extract:
+ @${SED} -e "s=%%PREFIX%%=${PREFIX}=g" ${FILESDIR}/wine.sh \
+ > ${WRKSRC}/wine.sh
+
post-configure:
cd ${WRKSRC} && make depend
@@ -89,4 +93,7 @@ do-install:
${ECHO}
@${SED} s+%%PREFIX%%+${PREFIX}+g <${PKGMESSAGE}
+post-install:
+ @$INSTALL_SCRIPT} ${WRKSRC}/wine.sh > ${PREFIX}/etc/rc.d/000.wine.sh
+
.include <bsd.port.post.mk>