aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
Diffstat (limited to 'emulators')
-rw-r--r--emulators/linux-ePSXe/Makefile16
-rw-r--r--emulators/linux-geepee32/Makefile5
-rw-r--r--emulators/linux-peops-softgpu/Makefile13
-rw-r--r--emulators/linux-peops-spu/Makefile13
-rw-r--r--emulators/linux-pete-mesagpu/Makefile14
-rw-r--r--emulators/linux-vmware-toolbox2/Makefile5
-rw-r--r--emulators/linux-vmware-toolbox4/Makefile7
-rw-r--r--emulators/linux-vmware-toolbox5/Makefile5
-rw-r--r--emulators/linux-vmware-toolbox6/Makefile5
-rw-r--r--emulators/linux-winetools/Makefile10
-rw-r--r--emulators/linux_base-8/Makefile10
-rw-r--r--emulators/linux_base-8/pkg-message15
-rw-r--r--emulators/rtc/Makefile2
-rw-r--r--emulators/vmware2/Makefile8
-rw-r--r--emulators/vmware3/Makefile8
-rw-r--r--emulators/winetools/Makefile10
16 files changed, 67 insertions, 79 deletions
diff --git a/emulators/linux-ePSXe/Makefile b/emulators/linux-ePSXe/Makefile
index a76e73d80f1a..4d328358dc62 100644
--- a/emulators/linux-ePSXe/Makefile
+++ b/emulators/linux-ePSXe/Makefile
@@ -16,26 +16,21 @@ MAINTAINER= jylefort@FreeBSD.org
COMMENT= A Sony Playstation emulator (Linux version)
# The binary is built against glibc 2.3, so we need linux_base-8.
-RUN_DEPENDS= ${LINUXBASE}/lib/libc-2.3.2.so:${PORTSDIR}/emulators/linux_base-8 \
- ${LINUXBASE}/usr/X11R6/lib/libX11.so.6:${PORTSDIR}/x11/linux-XFree86-libs \
- ${LINUXBASE}/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux-gtk
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux-gtk
+USE_LINUX= yes
USE_X_PREFIX= yes
USE_ZIP= yes
NO_WRKSUBDIR= yes
ONLY_FOR_ARCHS= i386
-# Linux binary should not be stripped by INSTALL_PROGRAM
-# because as a side effect it brands the binary as FreeBSD.
-STRIP=
-
.include <bsd.port.pre.mk>
EPSXE= ${PREFIX}/libexec/epsxe
-PSEMUPRO_PLUGINS_DIR= ${LOCALBASE}/lib/psemupro/plugins
-PSEMUPRO_CFGBINS_DIR= ${LOCALBASE}/libexec/psemupro/cfg
-PSEMUPRO_CFGFILES_DIR= ${LOCALBASE}/share/psemupro/cfg
+PSEMUPRO_PLUGINS_DIR= ${PREFIX}/lib/psemupro/plugins
+PSEMUPRO_CFGBINS_DIR= ${PREFIX}/libexec/psemupro/cfg
+PSEMUPRO_CFGFILES_DIR= ${PREFIX}/share/psemupro/cfg
do-build:
${MKDIR} ${WRKSRC}/FreeBSD
@@ -57,6 +52,7 @@ do-install:
${MKDIR} ${PREFIX}/libexec
${INSTALL_PROGRAM} ${WRKSRC}/epsxe ${EPSXE}
+ ${BRANDELF} -t Linux ${EPSXE}
${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/keycodes.lst ${DATADIR}
diff --git a/emulators/linux-geepee32/Makefile b/emulators/linux-geepee32/Makefile
index 1ce7f856b758..c33d030b6b15 100644
--- a/emulators/linux-geepee32/Makefile
+++ b/emulators/linux-geepee32/Makefile
@@ -15,17 +15,16 @@ DISTNAME= ${PORTNAME}_linux_sdl_${PORTVERSION}
MAINTAINER= arundel@h3c.de
COMMENT= The only GP32 emulator for i386
-RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12 \
- ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12
ONLY_FOR_ARCHS= i386
USE_X_PREFIX= yes
+USE_LINUX= yes
USE_ZIP= yes
NO_WRKSUBDIR= yes
NO_BUILD= yes
USE_REINPLACE= yes
REINPLACE_ARGS=
-STRIP=
TARGET_DIR= ${PREFIX}/${PORTNAME}
diff --git a/emulators/linux-peops-softgpu/Makefile b/emulators/linux-peops-softgpu/Makefile
index cc520d34417a..d54d0978b4bd 100644
--- a/emulators/linux-peops-softgpu/Makefile
+++ b/emulators/linux-peops-softgpu/Makefile
@@ -7,6 +7,7 @@
PORTNAME= peops-softgpu
PORTVERSION= 1.16
+PORTREVISION= 1
CATEGORIES= emulators linux
MASTER_SITES= http://www.pbernert.com/
PKGNAMEPREFIX= linux-
@@ -19,22 +20,20 @@ RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux
NO_WRKSUBDIR= yes
NO_BUILD= yes
+USE_LINUX= yes
+USE_X_PREFIX= yes
ONLY_FOR_ARCHS= i386
-# Linux binary should not be stripped by INSTALL_PROGRAM
-# because as a side effect it brands the binary as FreeBSD.
-STRIP=
-
MAJOR= ${PORTVERSION:R}
MINOR= ${PORTVERSION:E}
PLIST_SUB+= MAJOR=${MAJOR} MINOR=${MINOR}
.include <bsd.port.pre.mk>
-PSEMUPRO_PLUGINS_DIR= ${LOCALBASE}/lib/psemupro/plugins
-PSEMUPRO_CFGBINS_DIR= ${LOCALBASE}/libexec/psemupro/cfg
-PSEMUPRO_CFGFILES_DIR= ${LOCALBASE}/share/psemupro/cfg
+PSEMUPRO_PLUGINS_DIR= ${PREFIX}/lib/psemupro/plugins
+PSEMUPRO_CFGBINS_DIR= ${PREFIX}/libexec/psemupro/cfg
+PSEMUPRO_CFGFILES_DIR= ${PREFIX}/share/psemupro/cfg
do-install:
${MKDIR} ${PSEMUPRO_PLUGINS_DIR}
diff --git a/emulators/linux-peops-spu/Makefile b/emulators/linux-peops-spu/Makefile
index a0c8c5c2f9dc..c152868e6537 100644
--- a/emulators/linux-peops-spu/Makefile
+++ b/emulators/linux-peops-spu/Makefile
@@ -7,6 +7,7 @@
PORTNAME= peops-spu
PORTVERSION= 1.9
+PORTREVISION= 1
CATEGORIES= emulators linux
MASTER_SITES= http://www.pbernert.com/
PKGNAMEPREFIX= linux-
@@ -19,22 +20,20 @@ RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux
NO_WRKSUBDIR= yes
NO_BUILD= yes
+USE_LINUX= yes
+USE_X_PREFIX= yes
ONLY_FOR_ARCHS= i386
-# Linux binary should not be stripped by INSTALL_PROGRAM
-# because as a side effect it brands the binary as FreeBSD.
-STRIP=
-
MAJOR= ${PORTVERSION:R}
MINOR= ${PORTVERSION:E}
PLIST_SUB+= MAJOR=${MAJOR} MINOR=${MINOR}
.include <bsd.port.pre.mk>
-PSEMUPRO_PLUGINS_DIR= ${LOCALBASE}/lib/psemupro/plugins
-PSEMUPRO_CFGBINS_DIR= ${LOCALBASE}/libexec/psemupro/cfg
-PSEMUPRO_CFGFILES_DIR= ${LOCALBASE}/share/psemupro/cfg
+PSEMUPRO_PLUGINS_DIR= ${PREFIX}/lib/psemupro/plugins
+PSEMUPRO_CFGBINS_DIR= ${PREFIX}/libexec/psemupro/cfg
+PSEMUPRO_CFGFILES_DIR= ${PREFIX}/share/psemupro/cfg
do-install:
${MKDIR} ${PSEMUPRO_PLUGINS_DIR}
diff --git a/emulators/linux-pete-mesagpu/Makefile b/emulators/linux-pete-mesagpu/Makefile
index f1574d17dbee..aadd42953aba 100644
--- a/emulators/linux-pete-mesagpu/Makefile
+++ b/emulators/linux-pete-mesagpu/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pete-mesagpu
PORTVERSION= 1.75
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= emulators linux
MASTER_SITES= http://www.pbernert.com/
PKGNAMEPREFIX= linux-
@@ -21,22 +21,20 @@ RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux
NO_WRKSUBDIR= yes
NO_BUILD= yes
+USE_LINUX= yes
+USE_X_PREFIX= yes
ONLY_FOR_ARCHS= i386
-# Linux binary should not be stripped by INSTALL_PROGRAM
-# because as a side effect it brands the binary as FreeBSD.
-STRIP=
-
MAJOR= ${PORTVERSION:R}
MINOR= ${PORTVERSION:E}
PLIST_SUB+= MAJOR=${MAJOR} MINOR=${MINOR}
.include <bsd.port.pre.mk>
-PSEMUPRO_PLUGINS_DIR= ${LOCALBASE}/lib/psemupro/plugins
-PSEMUPRO_CFGBINS_DIR= ${LOCALBASE}/libexec/psemupro/cfg
-PSEMUPRO_CFGFILES_DIR= ${LOCALBASE}/share/psemupro/cfg
+PSEMUPRO_PLUGINS_DIR= ${PREFIX}/lib/psemupro/plugins
+PSEMUPRO_CFGBINS_DIR= ${PREFIX}/libexec/psemupro/cfg
+PSEMUPRO_CFGFILES_DIR= ${PREFIX}/share/psemupro/cfg
do-install:
${MKDIR} ${PSEMUPRO_PLUGINS_DIR}
diff --git a/emulators/linux-vmware-toolbox2/Makefile b/emulators/linux-vmware-toolbox2/Makefile
index e31b3a929bbb..79df27b0d7f2 100644
--- a/emulators/linux-vmware-toolbox2/Makefile
+++ b/emulators/linux-vmware-toolbox2/Makefile
@@ -16,10 +16,9 @@ DISTNAME= vmware-linux-tools
MAINTAINER= matusita@FreeBSD.org
COMMENT=VMware toolbox for guest OS (for VMware 2.x, Linux version)
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
-
ONLY_FOR_ARCHS= i386
PLIST_FILES= bin/linux-vmware-toolbox
+USE_LINUX= yes
USE_X_PREFIX= yes
NO_BUILD= yes
.if !defined(BATCH)
@@ -47,7 +46,6 @@ MOUNT_DEV?= vn0
.else
MOUNT_DEV?= fd0
.endif
-STRIP=
VMWARE_VER= 2.0.4
BUILD_VER= 1142
@@ -98,6 +96,7 @@ do-fetch:
.endif
do-install:
+ ${BRANDELF} -t Linux ${WRKSRC}/vmware-toolbox
${INSTALL_PROGRAM} ${WRKSRC}/vmware-toolbox ${PREFIX}/bin/linux-vmware-toolbox
.include <bsd.port.post.mk>
diff --git a/emulators/linux-vmware-toolbox4/Makefile b/emulators/linux-vmware-toolbox4/Makefile
index 8b7e4836a98e..51d74980c208 100644
--- a/emulators/linux-vmware-toolbox4/Makefile
+++ b/emulators/linux-vmware-toolbox4/Makefile
@@ -16,17 +16,15 @@ DISTNAME= vmware-linux-tools
MAINTAINER= matusita@FreeBSD.org
COMMENT=VMware toolbox for guest OS (for VMware 4.x, Linux version)
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
-
DISTDIR= ${MOUNT_PT}
IGNOREFILES= ${DISTFILES}
PLIST_FILES= bin/linux-vmware-toolbox
WRKSRC= ${WRKDIR}/vmware-tools-distrib
-STRIP=
ONLY_FOR_ARCHS= i386
-USE_X_PREFIX= yes
NO_BUILD= yes
+USE_LINUX= yes
+USE_X_PREFIX= yes
.if !defined(BATCH)
IS_INTERACTIVE= yes
.endif
@@ -90,6 +88,7 @@ post-extract:
${UMOUNT} ${MOUNT_DEV}
do-install:
+ ${BRANDELF} -t Linux ${WRKSRC}/bin/vmware-toolbox
${INSTALL_PROGRAM} ${WRKSRC}/bin/vmware-toolbox ${PREFIX}/bin/linux-vmware-toolbox
.include <bsd.port.post.mk>
diff --git a/emulators/linux-vmware-toolbox5/Makefile b/emulators/linux-vmware-toolbox5/Makefile
index 2d5b96db128c..0d507ed4001f 100644
--- a/emulators/linux-vmware-toolbox5/Makefile
+++ b/emulators/linux-vmware-toolbox5/Makefile
@@ -16,15 +16,13 @@ DISTNAME= VMwareTools-${VMWARE_VER}-${BUILD_VER}
MAINTAINER= matusita@FreeBSD.org
COMMENT=VMware toolbox for guest OS (for VMware 5.x, Linux version)
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
-
DISTDIR= ${MOUNT_PT}
IGNOREFILES= ${DISTFILES}
PLIST_FILES= bin/linux-vmware-toolbox
WRKSRC= ${WRKDIR}/vmware-tools-distrib
-STRIP=
ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
USE_X_PREFIX= yes
NO_BUILD= yes
.if !defined(BATCH)
@@ -89,6 +87,7 @@ post-extract:
${UMOUNT} ${MOUNT_DEV}
do-install:
+ ${BRANDELF} -t Linux ${WRKSRC}/bin/vmware-toolbox-old
${INSTALL_PROGRAM} ${WRKSRC}/bin/vmware-toolbox-old ${PREFIX}/bin/linux-vmware-toolbox
.include <bsd.port.post.mk>
diff --git a/emulators/linux-vmware-toolbox6/Makefile b/emulators/linux-vmware-toolbox6/Makefile
index 2d5b96db128c..0d507ed4001f 100644
--- a/emulators/linux-vmware-toolbox6/Makefile
+++ b/emulators/linux-vmware-toolbox6/Makefile
@@ -16,15 +16,13 @@ DISTNAME= VMwareTools-${VMWARE_VER}-${BUILD_VER}
MAINTAINER= matusita@FreeBSD.org
COMMENT=VMware toolbox for guest OS (for VMware 5.x, Linux version)
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
-
DISTDIR= ${MOUNT_PT}
IGNOREFILES= ${DISTFILES}
PLIST_FILES= bin/linux-vmware-toolbox
WRKSRC= ${WRKDIR}/vmware-tools-distrib
-STRIP=
ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
USE_X_PREFIX= yes
NO_BUILD= yes
.if !defined(BATCH)
@@ -89,6 +87,7 @@ post-extract:
${UMOUNT} ${MOUNT_DEV}
do-install:
+ ${BRANDELF} -t Linux ${WRKSRC}/bin/vmware-toolbox-old
${INSTALL_PROGRAM} ${WRKSRC}/bin/vmware-toolbox-old ${PREFIX}/bin/linux-vmware-toolbox
.include <bsd.port.post.mk>
diff --git a/emulators/linux-winetools/Makefile b/emulators/linux-winetools/Makefile
index bfd4c6e430d5..0fe7cfd6f13d 100644
--- a/emulators/linux-winetools/Makefile
+++ b/emulators/linux-winetools/Makefile
@@ -7,7 +7,7 @@
PORTNAME= winetools
PORTVERSION= 1.25a
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators linux
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S/%SUBDIR%/winetools/}
PKGNAMEPREFIX= linux-
@@ -16,17 +16,15 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= A setup and configuration tool for WINE
-RUN_DEPENDS= wine:${PORTSDIR}/emulators/wine \
- ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
+RUN_DEPENDS= wine:${PORTSDIR}/emulators/wine
NO_WRKSUBDIR= yes
NO_BUILD= yes
+USE_LINUX= yes
+USE_X_PREFIX= yes
ONLY_FOR_ARCHS= i386
PLIST_FILES= bin/winetools
-BRANDELF?= /usr/bin/brandelf
-STRIP=
-
post-extract:
@${BRANDELF} -t Linux ${WRKDIR}/${PORTNAME}
diff --git a/emulators/linux_base-8/Makefile b/emulators/linux_base-8/Makefile
index 4b2e1cd958d8..756cf87721e6 100644
--- a/emulators/linux_base-8/Makefile
+++ b/emulators/linux_base-8/Makefile
@@ -60,7 +60,7 @@ CONFLICTS= linux_base-7* linux_base-deb* linux_base-gentoo* \
linux_base-rh* linux_base-suse*
ONLY_FOR_ARCHS= i386 amd64
DIST_SUBDIR= rpm/${ARCH}/${PORTVERSION}
-PREFIX= ${LINUXBASE}
+PREFIX?= ${LINUXBASE}
NO_BUILD= yes
NO_FILTER_SHLIBS= yes
NO_MTREE= yes
@@ -106,12 +106,6 @@ pre-install:
@cd ${WRKSRC}/lib && ${LN} -sf libtermcap.so.2.0.8 libtermcap.so.2
@${RPM} --initdb --root ${WRKSRC} --dbpath ${DBPATH}
#
-# Make sure we have a /dev/null in the chrooted environment.
- @${MKDIR} ${WRKSRC}/dev
- @${RM} -f ${WRKSRC}/dev/null
- @mknod ${WRKSRC}/dev/null c 2 2
- @${CHMOD} 666 ${WRKSRC}/dev/null
-#
# Install all packages. Ignore dependencies just like the Red Hat installer.
# Also, set the ELF fallback brand to Linux, so that we don't have to do
# anything special to run staticly linked binaries.
@@ -121,7 +115,7 @@ pre-install:
${RPM} -U ${RPMFLAGS} ${RPMDIR}/$$R; \
done
@for F in ${BRAND_FILES}; do \
- brandelf -t Linux ${WRKSRC}/$$F; \
+ ${BRANDELF} -t Linux ${WRKSRC}/$$F; \
done
@/sbin/sysctl -w ${FALLBACK_ELF_MIB}=${PREVIOUS_ELF}
#
diff --git a/emulators/linux_base-8/pkg-message b/emulators/linux_base-8/pkg-message
index b7d8d197ca8f..29791da973dc 100644
--- a/emulators/linux_base-8/pkg-message
+++ b/emulators/linux_base-8/pkg-message
@@ -8,5 +8,16 @@ is now enabled. Linux mode can be enabled
permanently with the linux_enable variable
of rc.conf(5).
-When using NIS, don't forget to edit
-yp.conf in /compat/linux/etc.
+To make use of NIS you have to adjust yp.conf and nsswitch.conf in
+/compat/linux/etc/ accordingly. For example:
+
+Set your yp-server and yp-domainname in yp.conf:
+domainname my.yp.domainname
+ypserver my.yp.server
+
+Let your lists for hosts, passwd and group be resolved via nsswitch.conf:
+passwd: files nis
+shadow: files nis
+group: files nis
+hosts: files dns nis
+
diff --git a/emulators/rtc/Makefile b/emulators/rtc/Makefile
index 1d54e5ffa33c..bb8d2fb8fb97 100644
--- a/emulators/rtc/Makefile
+++ b/emulators/rtc/Makefile
@@ -18,7 +18,7 @@ COMMENT= Kernel module which provides /dev/rtc device support
WRKSRC= ${WRKDIR}/files
NO_FETCH= yes
-USE_LINUX?= yes
+USE_LINUX= yes # because of ${DEVDIR}
KMODDIR= ${PREFIX}/modules
diff --git a/emulators/vmware2/Makefile b/emulators/vmware2/Makefile
index 9aac5f1e92cd..0254c7182993 100644
--- a/emulators/vmware2/Makefile
+++ b/emulators/vmware2/Makefile
@@ -8,7 +8,7 @@
PORTNAME= vmware2
PORTVERSION= 2.0.4.1142
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators linux
MASTER_SITES= ${FREEBSD_MODULE_SITES} \
${VMWARE_MIRROR_SITES}
@@ -21,8 +21,7 @@ DISTFILES= VMware-${PORTVERSION:R}-${PORTVERSION:E}${EXTRACT_SUFX}:vmware \
MAINTAINER= vsilyaev@mindspring.com
COMMENT= A virtual machine emulator - a full PC in a window
-RUN_DEPENDS= ${LINUXBASE}/dev/rtc:${PORTSDIR}/emulators/rtc \
- ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
+RUN_DEPENDS= ${LINUXBASE}/dev/rtc:${PORTSDIR}/emulators/rtc
RESTRICTED= "Not sure if we can redistribute it"
@@ -45,7 +44,8 @@ VMDIR= ${PREFIX}/lib/vmware
SRC_BASE?= /usr/src
ONLY_FOR_ARCHS= i386
-USE_XLIB= yes
+USE_LINUX= yes
+USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/vmware-distrib
GZCAT= ${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/extract
MAN1= vmware.1
diff --git a/emulators/vmware3/Makefile b/emulators/vmware3/Makefile
index 69679054dba4..f2cd79750896 100644
--- a/emulators/vmware3/Makefile
+++ b/emulators/vmware3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vmware3
PORTVERSION= 3.2.1.2242
-PORTREVISION= 10
+PORTREVISION= 11
PORTEPOCH= 1
CATEGORIES= emulators linux
MASTER_SITES= http://www4.vmware.com/software/ \
@@ -22,8 +22,7 @@ DISTFILES= VMware-workstation-${PORTVERSION:R}-${PORTVERSION:E}${EXTRACT_SUFX}:v
MAINTAINER= orlando@break.net
COMMENT= A virtual machine emulator - a full PC in a window
-RUN_DEPENDS= /dev/rtc:${PORTSDIR}/emulators/rtc \
- ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
+RUN_DEPENDS= ${LINUXBASE}/dev/rtc:${PORTSDIR}/emulators/rtc
RESTRICTED= "Not sure if we can redistribute it"
@@ -39,7 +38,8 @@ VMDIR= ${PREFIX}/lib/vmware
SRC_BASE?= /usr/src
ONLY_FOR_ARCHS= i386
-USE_XLIB= yes
+USE_LINUX= yes
+USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/vmware-distrib
GZCAT= ${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/extract
MAN1= vmware.1
diff --git a/emulators/winetools/Makefile b/emulators/winetools/Makefile
index bfd4c6e430d5..0fe7cfd6f13d 100644
--- a/emulators/winetools/Makefile
+++ b/emulators/winetools/Makefile
@@ -7,7 +7,7 @@
PORTNAME= winetools
PORTVERSION= 1.25a
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators linux
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S/%SUBDIR%/winetools/}
PKGNAMEPREFIX= linux-
@@ -16,17 +16,15 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= A setup and configuration tool for WINE
-RUN_DEPENDS= wine:${PORTSDIR}/emulators/wine \
- ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
+RUN_DEPENDS= wine:${PORTSDIR}/emulators/wine
NO_WRKSUBDIR= yes
NO_BUILD= yes
+USE_LINUX= yes
+USE_X_PREFIX= yes
ONLY_FOR_ARCHS= i386
PLIST_FILES= bin/winetools
-BRANDELF?= /usr/bin/brandelf
-STRIP=
-
post-extract:
@${BRANDELF} -t Linux ${WRKDIR}/${PORTNAME}