aboutsummaryrefslogtreecommitdiff
path: root/finance/homebank/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'finance/homebank/Makefile')
-rw-r--r--finance/homebank/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/finance/homebank/Makefile b/finance/homebank/Makefile
index 70204740c55a..5fa380727131 100644
--- a/finance/homebank/Makefile
+++ b/finance/homebank/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= homebank
-PORTVERSION= 3.6
-PORTREVISION= 2
+PORTVERSION= 3.8
CATEGORIES= finance
MASTER_SITES= http://homebank.free.fr/public/
@@ -16,7 +15,6 @@ COMMENT= Manage your personal accounts at home
USE_GMAKE= yes
USE_GNOME= gnomeprefix gtk20 desktopfileutils
-WANT_GNOME= yes
USE_GETTEXT= yes
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
@@ -25,6 +23,13 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
DOCS= AUTHORS COPYING ChangeLog NEWS README
+.if !defined(WITHOUT_OFX)
+LIB_DEPENDS+= ofx.4:${PORTSDIR}/finance/libofx
+CONFIGURE_ARGS+=--with-ofx
+.else
+CONFIGURE_ARGS+=--without-ofx
+.endif
+
post-install:
.ifndef (NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@@ -33,5 +38,6 @@ post-install:
.endfor
.endif
@-update-desktop-database
+ @-update-mime-database ${PREFIX}/share/mime
.include <bsd.port.mk>