aboutsummaryrefslogtreecommitdiff
path: root/finance/kmymoney/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'finance/kmymoney/Makefile')
-rw-r--r--finance/kmymoney/Makefile106
1 files changed, 106 insertions, 0 deletions
diff --git a/finance/kmymoney/Makefile b/finance/kmymoney/Makefile
new file mode 100644
index 000000000000..5aa1f6154792
--- /dev/null
+++ b/finance/kmymoney/Makefile
@@ -0,0 +1,106 @@
+# $FreeBSD$
+
+PORTNAME= kmymoney
+PORTVERSION= 5.0.1
+CATEGORIES= finance kde
+MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}/src
+
+MAINTAINER= jhale@FreeBSD.org
+COMMENT= KDE personal finance manager
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libalkimia5.so:finance/alkimia \
+ libKChart.so:graphics/kdiagram
+
+USES= cmake compiler:c++14-lang desktop-file-utils gettext kde:5 \
+ pkgconfig shared-mime-info shebangfix tar:xz
+USE_QT5= buildtools_build core dbus gui network printsupport qmake_build \
+ sql testlib_build xml webkit widgets
+USE_KDE= activities archive auth bookmarks codecs completion config \
+ configwidgets coreaddons doctools_build ecm_build i18n \
+ iconthemes itemmodels itemviews jobwidgets kcmutils \
+ kio notifications textwidgets service solid sonnet \
+ wallet widgetsaddons xmlgui
+USE_LDCONFIG= yes
+
+CONFLICTS_INSTALL= kmymoney-kde4
+
+SHEBANG_FILES= kmymoney/misc/financequote.pl
+
+OPTIONS_GROUP= PLUGINS
+OPTIONS_GROUP_PLUGINS= CALENDAR KBANKING OFX WEBOOB
+WEB_DESC= Web content renderer
+OPTIONS_SINGLE= WEB
+OPTIONS_SINGLE_WEB= KDEWEBKIT QTWEBENGINE
+OPTIONS_DEFINE= ADDRESSBOOK GNUPG HOLIDAYS QUOTES
+OPTIONS_DEFAULT= CALENDAR GNUPG HOLIDAYS KBANKING KDEWEBKIT OFX QUOTES
+OPTIONS_SUB= yes
+
+ADDRESSBOOK_DESC= Address book support
+ADDRESSBOOK_USE= kde=akonadi,contacts,identitymanagement,pimtextedit
+ADDRESSBOOK_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_KF5Akonadi \
+ CMAKE_DISABLE_FIND_PACKAGE_KF5Contacts \
+ CMAKE_DISABLE_FIND_PACKAGE_KF5IdentityManagement
+
+CALENDAR_DESC= iCalendar exporter
+CALENDAR_LIB_DEPENDS= libical.so:devel/libical
+CALENDAR_CMAKE_BOOL= ENABLE_LIBICAL
+
+GNUPG_LIB_DEPENDS= libgpgme.so:security/gpgme \
+ libgpgmepp.so:security/gpgme-cpp \
+ libassuan.so:security/libassuan \
+ libgpg-error.so:security/libgpg-error
+GNUPG_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_Gpgmepp \
+ CMAKE_DISABLE_FIND_PACKAGE_KF5Gpgmepp
+
+HOLIDAYS_DESC= Holidays support
+HOLIDAYS_USE= kde=holidays
+HOLIDAYS_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_KF5Holidays
+
+KBANKING_DESC= Online banking via KBanking (AqBanking)
+KBANKING_LIB_DEPENDS= libgwenhywfar.so:devel/gwenhywfar \
+ libgwengui-qt5.so:devel/gwenhywfar-qt5 \
+ libaqbanking.so:finance/aqbanking
+KBANKING_USE= qt5=qml,quick
+KBANKING_CMAKE_BOOL= ENABLE_KBANKING
+
+KDEWEBKIT_DESC= Web content rendering via KDEWebKit
+KDEWEBKIT_USE= kde=kdewebkit
+
+OFX_DESC= OFX (Open Financial Exchange) importer
+OFX_LIB_DEPENDS= libofx.so:finance/libofx
+OFX_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_LibOfx
+
+QTWEBENGINE_DESC= Web content rendering via QtWebEngine
+QTWEBENGINE_USE= qt5=location,webchannel,webengine
+QTWEBENGINE_CMAKE_BOOL= ENABLE_WEBENGINE
+
+QUOTES_DESC= Online stock and currency price quotes
+QUOTES_USES= perl5
+QUOTES_USE= PERL5=run
+QUOTES_RUN_DEPENDS= p5-Date-Manip>=0:devel/p5-Date-Manip \
+ p5-Finance-Quote>=0:finance/p5-Finance-Quote \
+ p5-XML-Parser>=0:textproc/p5-XML-Parser \
+ p5-XML-Writer>=0:textproc/p5-XML-Writer \
+ p5-libwww>=0:www/p5-libwww
+
+WEBOOB_DESC= Online banking via Web Outside Of Browsers
+WEBOOB_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}weboob>0:www/py-weboob@${PY_FLAVOR}
+WEBOOB_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}weboob>0:www/py-weboob@${PY_FLAVOR}
+WEBOOB_USES= python:2.7
+WEBOOB_USE= qt5=concurrent
+WEBOOB_CMAKE_BOOL= ENABLE_WEBOOB
+
+.if defined(MAINTAINER_MODE)
+# Apply additional substitutions to pkg-plist generated by the 'makeplist' target
+create-plist: stage
+ @(cd ${.CURDIR} && ${MAKE} makeplist > pkg-plist && \
+ ${SED} -i "" -e '1d' \
+ -e '/icalendar/s|^|%%CALENDAR%%|g' -e '/kbanking/s|^|%%KBANKING%%|g' \
+ -e '/ofximport/s|^|%%OFX%%|g' -e '/weboob/s|^|%%WEBOOB%%|g' \
+ pkg-plist)
+.endif
+
+.include <bsd.port.mk>