aboutsummaryrefslogtreecommitdiff
path: root/ftp/curl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/curl/Makefile')
-rw-r--r--ftp/curl/Makefile17
1 files changed, 5 insertions, 12 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 839609bdef3b..a8de7be0a38c 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= curl
-PORTVERSION= 7.9
+PORTVERSION= 7.9.1
CATEGORIES= ftp ipv6 www
MASTER_SITES= http://curl.haxx.se/download/ \
http://download.sourceforge.net/curl/ \
@@ -47,19 +47,12 @@ CONFIGURE_ARGS += --with-krb4=/usr
.endif
GNU_CONFIGURE= yes
-# Disable this for the present - curl breaks with automake 1.4 :(
-# (and besides, the pregenerated configure script will DTRT anyway)
-# USE_AUTOMAKE= yes
USE_BZIP2= yes
USE_GMAKE= yes
-MAKEFILES= Makefile src/Makefile
-post-configure:
-
-.for x in ${MAKEFILES}
- @ ${MV} ${WRKSRC}/${x} ${WRKSRC}/${x}.pre_sed
- @ ${SED} -e 's#@SHELL@#${SH}#' \
- ${WRKSRC}/${x}.pre_sed > ${WRKSRC}/${x}
-.endfor
+# Note: some of these tests seem to intermitently fail on my system.
+# I don't know why they would do that, yet.
+test: build
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} test)
.include <bsd.port.mk>