aboutsummaryrefslogtreecommitdiff
path: root/ftp/gollem
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/gollem')
-rw-r--r--ftp/gollem/files/pkg-deinstall.in9
-rw-r--r--ftp/gollem/files/pkg-install.in23
2 files changed, 26 insertions, 6 deletions
diff --git a/ftp/gollem/files/pkg-deinstall.in b/ftp/gollem/files/pkg-deinstall.in
index 5c399f4c3632..74ba43ea36c6 100644
--- a/ftp/gollem/files/pkg-deinstall.in
+++ b/ftp/gollem/files/pkg-deinstall.in
@@ -12,13 +12,10 @@ if [ -z "${PACKAGE_BUILDING}" ]; then
for cf in `ls %%GOLLEMDIR%%/config/*php`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
- 0) # original config file, will be deleted by pkg-plist
+ 0) # original config file, delete it
+ rm -f $cf
;;
- 1) # config file has been updated, must be backuped
- cp -p $cf $cf.previous
- echo "===> Backing-up..."
- echo "---> $cf has been saved ***"
- echo "---> as $cf.previous ***"
+ 1) # config file has been updated, leave it alone
;;
*) # not found?
;;
diff --git a/ftp/gollem/files/pkg-install.in b/ftp/gollem/files/pkg-install.in
new file mode 100644
index 000000000000..49c99fa99dee
--- /dev/null
+++ b/ftp/gollem/files/pkg-install.in
@@ -0,0 +1,23 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+PATH=/usr/sbin:/usr/bin:/bin ; export PATH
+
+case $2 in
+ PRE-INSTALL)
+ ;;
+
+ POST-INSTALL)
+ if [ -z "${PACKAGE_BUILDING}" ]; then
+ # Copy over sample config files unless they already exist
+
+ for cf in `ls %%GOLLEMDIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
+ if [ ! -f $cf ]; then
+ cp -p $cf.dist $cf
+ fi
+ done
+ fi
+ ;;
+esac