aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
Diffstat (limited to 'ftp')
-rw-r--r--ftp/hsftp/Makefile20
1 files changed, 6 insertions, 14 deletions
diff --git a/ftp/hsftp/Makefile b/ftp/hsftp/Makefile
index ff64c74ad2cb..58d13b597650 100644
--- a/ftp/hsftp/Makefile
+++ b/ftp/hsftp/Makefile
@@ -19,25 +19,17 @@ MAKEFILE= makefile
MAN1= hsftp.1
PLIST_FILES= bin/hsftp
+OPTIONS= OPENSSH "Build with OpenSSH support" off
+
+.include <bsd.port.pre.mk>
+
.if defined(WITH_OPENSSH)
-RUN_DEPENDS= ssh:${PORTSDIR}/security/openssh
+RUN_DEPENDS+= ssh:${PORTSDIR}/security/openssh
CONFIGURE_ARGS+= --with-openssh
.endif
-pre-everything::
-.if !defined(WITH_OPENSSH)
- @${ECHO_MSG}
- @${ECHO_MSG} "If you would like build hsftp with OpenSSH support"
- @${ECHO_MSG} "you must set the variable WITH_OPENSSH"
- @${ECHO_MSG}
-.else
- @${ECHO_MSG}
- @${ECHO_MSG} "Building hsftp with OpenSSH support"
- @${ECHO_MSG}
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/hsftp ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/hsftp.1 ${MANPREFIX}/man/man1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>