aboutsummaryrefslogtreecommitdiff
path: root/games/0ad
diff options
context:
space:
mode:
Diffstat (limited to 'games/0ad')
-rw-r--r--games/0ad/Makefile2
-rw-r--r--games/0ad/files/patch-icu6817
2 files changed, 18 insertions, 1 deletions
diff --git a/games/0ad/Makefile b/games/0ad/Makefile
index 58cb16cf9446..fd1ae3e6da87 100644
--- a/games/0ad/Makefile
+++ b/games/0ad/Makefile
@@ -2,7 +2,7 @@
PORTNAME= 0ad
PORTVERSION= 0.0.23b
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= games
MASTER_SITES= http://releases.wildfiregames.com/ \
SF/zero-ad/releases
diff --git a/games/0ad/files/patch-icu68 b/games/0ad/files/patch-icu68
new file mode 100644
index 000000000000..5e9199d89535
--- /dev/null
+++ b/games/0ad/files/patch-icu68
@@ -0,0 +1,17 @@
+Regressed by https://github.com/unicode-org/icu/commit/c3fe7e09d844
+
+../../../source/i18n/L10n.cpp:208:82: error: use of undeclared identifier 'TRUE'
+ currentLocaleIsOriginalGameLocale = (currentLocale == icu::Locale::getUS()) == TRUE;
+ ^
+
+--- source/i18n/L10n.cpp.orig 2018-04-10 18:13:32 UTC
++++ source/i18n/L10n.cpp
+@@ -205,7 +205,7 @@ void L10n::ReevaluateCurrentLocaleAndReload()
+ else
+ {
+ GetDictionaryLocale(locale, currentLocale);
+- currentLocaleIsOriginalGameLocale = (currentLocale == icu::Locale::getUS()) == TRUE;
++ currentLocaleIsOriginalGameLocale = (currentLocale == icu::Locale::getUS()) == true;
+ useLongStrings = false;
+ }
+ LoadDictionaryForCurrentLocale();