aboutsummaryrefslogtreecommitdiff
path: root/games/bloodfrontier/files
diff options
context:
space:
mode:
Diffstat (limited to 'games/bloodfrontier/files')
-rw-r--r--games/bloodfrontier/files/bfclient.in18
-rw-r--r--games/bloodfrontier/files/bfserver.in18
-rw-r--r--games/bloodfrontier/files/patch-src-shared-tools.h15
-rw-r--r--games/bloodfrontier/files/patch-src_Makefile37
-rw-r--r--games/bloodfrontier/files/pkg-message.in6
-rw-r--r--games/bloodfrontier/files/sauer_client.in18
-rw-r--r--games/bloodfrontier/files/sauer_server.in18
7 files changed, 50 insertions, 80 deletions
diff --git a/games/bloodfrontier/files/bfclient.in b/games/bloodfrontier/files/bfclient.in
new file mode 100644
index 000000000000..01d3b7ef4949
--- /dev/null
+++ b/games/bloodfrontier/files/bfclient.in
@@ -0,0 +1,18 @@
+#!/bin/sh
+
+# The executable needs to be run from its data directory, and needs to store
+# configuration in it. We therefore mirror the data directory hierarchy in
+# ~/.bloodfrontier, and create symlinks to the data files.
+
+if [ -d ~/.bloodfrontier ]
+then
+ echo "Using existing ~/.bloodfrontier directory."
+else
+ echo "Creating ~/.bloodfrontier directory."
+ cd %%DATADIR%% || exit 1
+ find * -type d -exec mkdir -p ~/.bloodfrontier/{} \;
+ find * -type f -exec ln -s %%DATADIR%%/{} ~/.bloodfrontier/{} \; 2>/dev/null
+fi
+
+cd ~/.bloodfrontier || exit 1
+exec %%PREFIX%%/libexec/bfclient "$@"
diff --git a/games/bloodfrontier/files/bfserver.in b/games/bloodfrontier/files/bfserver.in
new file mode 100644
index 000000000000..6f15e12a2bd0
--- /dev/null
+++ b/games/bloodfrontier/files/bfserver.in
@@ -0,0 +1,18 @@
+#!/bin/sh
+
+# The executable needs to be run from its data directory, and needs to store
+# configuration in it. We therefore mirror the data directory hierarchy in
+# ~/.bloodfrontier, and create symlinks to the data files.
+
+if [ -d ~/.bloodfrontier ]
+then
+ echo "Using existing ~/.bloodfrontier directory."
+else
+ echo "Creating ~/.bloodfrontier directory."
+ cd %%DATADIR%% || exit 1
+ find * -type d -exec mkdir -p ~/.bloodfrontier/{} \;
+ find * -type f -exec ln -s %%DATADIR%%/{} ~/.bloodfrontier/{} \; 2>/dev/null
+fi
+
+cd ~/.bloodfrontier || exit 1
+exec %%PREFIX%%/libexec/bfserver "$@"
diff --git a/games/bloodfrontier/files/patch-src-shared-tools.h b/games/bloodfrontier/files/patch-src-shared-tools.h
deleted file mode 100644
index 5b028a7f1876..000000000000
--- a/games/bloodfrontier/files/patch-src-shared-tools.h
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/shared/tools.h.orig 2009-04-26 00:14:34.000000000 +0400
-+++ src/shared/tools.h 2009-05-07 19:45:42.000000000 +0400
-@@ -764,6 +764,12 @@
- template<class T> inline void bigswap(T *buf, int len) { if(*(const uchar *)&islittleendian) endianswap(buf, len); }
- #endif
-
-+#ifdef getchar
-+#undef getchar
-+#endif
-+#ifdef putchar
-+#undef putchar
-+#endif
- struct stream
- {
- virtual ~stream() {}
diff --git a/games/bloodfrontier/files/patch-src_Makefile b/games/bloodfrontier/files/patch-src_Makefile
index a534a1847435..c7f5e89d57ac 100644
--- a/games/bloodfrontier/files/patch-src_Makefile
+++ b/games/bloodfrontier/files/patch-src_Makefile
@@ -1,34 +1,19 @@
---- src/Makefile.orig 2009-04-22 21:47:44.000000000 +0400
-+++ src/Makefile 2009-05-07 19:07:39.000000000 +0400
-@@ -1,8 +1,7 @@
+--- src/Makefile.orig 2009-11-25 14:52:58.000000000 +0300
++++ src/Makefile 2009-12-17 00:09:47.000000000 +0300
+@@ -1,5 +1,4 @@
+ #CXXFLAGS= -ggdb3
-CXXFLAGS= -O3 -fomit-frame-pointer
override CXXFLAGS+= -Wall -fsigned-char
PLATFORM= $(shell uname -s)
--PLATFORM_PREFIX= native
-+PLATFORM_PREFIX= FreeBSD
-
- INCLUDES= -Ishared -Iengine -Ifpsgame -Ienet/include
-
-@@ -18,8 +17,8 @@
- CLIENT_INCLUDES= $(INCLUDES) -Iinclude
- CLIENT_LIBS= -mwindows -Llib -lSDL -lSDL_image -lSDL_mixer -lzdll -lopengl32 -lenet -lws2_32 -lwinmm
- else
--CLIENT_INCLUDES= $(INCLUDES) -I/usr/X11R6/include `sdl-config --cflags`
+@@ -21,8 +20,8 @@
+ CLIENT_INCLUDES= -DINTERFACE -DIRC $(INCLUDES) -Iinclude
+ CLIENT_LIBS= -mwindows -lmingw32 -Llib -lSDLmain -lSDL -lSDL_image -lSDL_mixer -lzdll -lopengl32 -lenet -lws2_32 -lwinmm
+ else
+-CLIENT_INCLUDES= -DINTERFACE -DIRC $(INCLUDES) -I/usr/X11R6/include `sdl-config --cflags`
-CLIENT_LIBS= -Lenet -lenet -L/usr/X11R6/lib `sdl-config --libs` -lSDL_image -lSDL_mixer -lz -lGL
-+CLIENT_INCLUDES= $(INCLUDES) `${SDL_CONFIG} --cflags` -I${LOCALBASE}/include
-+CLIENT_LIBS= -Lenet -lenet `${SDL_CONFIG} --libs` -L${LOCALBASE}/lib -lSDL_image -lSDL_mixer -lz -lGL
++CLIENT_INCLUDES= -DINTERFACE -DIRC $(INCLUDES) -I${LOCALBASE}/include `${SDL_CONFIG} --cflags`
++CLIENT_LIBS= -Lenet -lenet -L${LOCALBASE}/lib `${SDL_CONFIG} --libs` -lSDL_image -lSDL_mixer -lz -lGL
endif
ifeq ($(PLATFORM),Linux)
CLIENT_LIBS+= -lrt
-@@ -88,8 +87,8 @@
- SERVER_INCLUDES= -DSTANDALONE $(INCLUDES) -Iinclude
- SERVER_LIBS= -Llib -lzdll -lenet -lws2_32 -lwinmm
- else
--SERVER_INCLUDES= -DSTANDALONE $(INCLUDES)
--SERVER_LIBS= -Lenet -lenet -lz
-+SERVER_INCLUDES= -DSTANDALONE $(INCLUDES) -I${LOCALBASE}/include
-+SERVER_LIBS= -Lenet -lenet -lz -L${LOCALBASE}/lib
- endif
- SERVER_OBJS= \
- shared/crypto-standalone.o \
diff --git a/games/bloodfrontier/files/pkg-message.in b/games/bloodfrontier/files/pkg-message.in
index 2020523db93a..3bc3f84a8629 100644
--- a/games/bloodfrontier/files/pkg-message.in
+++ b/games/bloodfrontier/files/pkg-message.in
@@ -1,8 +1,8 @@
###############################################################################
-1) First time, sauerbraten creates a ~/.sauerbraten directory with symlinks.
-2) Config files are in the ~/.sauerbraten directory.
-3) If you want add new bindings into ~/.sauerbraten/config.cfg, see
+1) First time, bloodfrontier creates a ~/.bloodfrontier directory with symlinks.
+2) Config files are in the ~/.bloodfrontier directory.
+3) If you want add new bindings into ~/.bloodfrontier/config.cfg, see
%%DATADIR%%/data/keymap.cfg.
diff --git a/games/bloodfrontier/files/sauer_client.in b/games/bloodfrontier/files/sauer_client.in
deleted file mode 100644
index 0d0ad1503401..000000000000
--- a/games/bloodfrontier/files/sauer_client.in
+++ /dev/null
@@ -1,18 +0,0 @@
-#!/bin/sh
-
-# The executable needs to be run from its data directory, and needs to store
-# configuration in it. We therefore mirror the data directory hierarchy in
-# ~/.sauerbraten, and create symlinks to the data files.
-
-if [ -d ~/.sauerbraten ]
-then
- echo "Using existing ~/.sauerbraten directory."
-else
- echo "Creating ~/.sauerbraten directory."
- cd %%DATADIR%% || exit 1
- find * -type d -exec mkdir -p ~/.sauerbraten/{} \;
- find * -type f -exec ln -s %%DATADIR%%/{} ~/.sauerbraten/{} \; 2>/dev/null
-fi
-
-cd ~/.sauerbraten || exit 1
-exec %%PREFIX%%/libexec/sauer_client "$@"
diff --git a/games/bloodfrontier/files/sauer_server.in b/games/bloodfrontier/files/sauer_server.in
deleted file mode 100644
index 672564b86865..000000000000
--- a/games/bloodfrontier/files/sauer_server.in
+++ /dev/null
@@ -1,18 +0,0 @@
-#!/bin/sh
-
-# The executable needs to be run from its data directory, and needs to store
-# configuration in it. We therefore mirror the data directory hierarchy in
-# ~/.sauerbraten, and create symlinks to the data files.
-
-if [ -d ~/.sauerbraten ]
-then
- echo "Using existing ~/.sauerbraten directory."
-else
- echo "Creating ~/.sauerbraten directory."
- cd %%DATADIR%% || exit 1
- find * -type d -exec mkdir -p ~/.sauerbraten/{} \;
- find * -type f -exec ln -s %%DATADIR%%/{} ~/.sauerbraten/{} \; 2>/dev/null
-fi
-
-cd ~/.sauerbraten || exit 1
-exec %%PREFIX%%/libexec/sauer_server "$@"