aboutsummaryrefslogtreecommitdiff
path: root/games/bsdgames
diff options
context:
space:
mode:
Diffstat (limited to 'games/bsdgames')
-rw-r--r--games/bsdgames/Makefile74
-rw-r--r--games/bsdgames/distinfo3
-rw-r--r--games/bsdgames/files/patch-adventure::crc.c11
-rw-r--r--games/bsdgames/files/patch-adventure::hdr.h11
-rw-r--r--games/bsdgames/files/patch-battlestar::init.c11
-rw-r--r--games/bsdgames/files/patch-hack::Makefile13
-rw-r--r--games/bsdgames/files/patch-hack::hack.termcap.c13
-rw-r--r--games/bsdgames/files/patch-hack::hack.unix.c13
-rw-r--r--games/bsdgames/files/patch-larn::diag.c31
-rw-r--r--games/bsdgames/files/patch-larn::header.h13
-rw-r--r--games/bsdgames/files/patch-larn::io.c31
-rw-r--r--games/bsdgames/files/patch-quiz175
-rw-r--r--games/bsdgames/pkg-descr6
-rw-r--r--games/bsdgames/pkg-plist108
14 files changed, 0 insertions, 513 deletions
diff --git a/games/bsdgames/Makefile b/games/bsdgames/Makefile
deleted file mode 100644
index a8446dba81b6..000000000000
--- a/games/bsdgames/Makefile
+++ /dev/null
@@ -1,74 +0,0 @@
-# Ports collection makefile for: games
-# Date created: 20 Nov 2002
-# Whom: Mark Murray <markm@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= freebsd-games
-PORTVERSION= 5.1.1
-PORTREVISION= 6
-CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR=markm
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= FreeBSD-modified "Standard" BSD games
-
-USE_REINPLACE= yes
-USE_BZIP2= yes
-
-MAN6= \
- adventure.6 \
- arithmetic.6 \
- atc.6 \
- backgammon.6 \
- battlestar.6 \
- bs.6 \
- canfield.6 \
- cfscores.6 \
- cribbage.6 \
- fish.6 \
- hack.6 \
- hangman.6 \
- larn.6 \
- mille.6 \
- phantasia.6 \
- piano.6 \
- pig.6 \
- quiz.6 \
- robots.6 \
- rogue.6 \
- sail.6 \
- snake.6 \
- snscore.6 \
- trek.6 \
- worm.6 \
- wump.6
-
-MANCOMPRESSED= maybe
-
-PATHNAME_FILES= atc/pathnames.h \
- cribbage/pathnames.h \
- fish/pathnames.h \
- larn/pathnames.h \
- quiz/datfiles/index \
- quiz/pathnames.h \
- wump/pathnames.h
-
-post-extract:
- @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} \
- ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} extract)
-
-post-patch:
- @${FIND} ${WRKSRC} -name '*.c' -or -name '*.h' -or -name '*.6' -or \
- -name 'index' | ${XARGS} ${REINPLACE_CMD} -e \
- 's|share/games|local/share/games|g'
- @for f in ${PATHNAME_FILES}; do \
- ${REINPLACE_CMD} -e 's|/usr/local/local/local|${PREFIX}|g' \
- ${WRKSRC}/$${f}; \
- done
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' \
- "${WRKSRC}/hack/hack.unix.c"
-
-.include <bsd.port.mk>
diff --git a/games/bsdgames/distinfo b/games/bsdgames/distinfo
deleted file mode 100644
index 0e72990e3eb4..000000000000
--- a/games/bsdgames/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (freebsd-games-5.1.1.tar.bz2) = 31c098a1ef0d198a6456e26b6d65be72
-SHA256 (freebsd-games-5.1.1.tar.bz2) = 2ef700e090c975c7d6807a556ca29acc11215ba43f3ad26ad555a63cb3f72f71
-SIZE (freebsd-games-5.1.1.tar.bz2) = 2434501
diff --git a/games/bsdgames/files/patch-adventure::crc.c b/games/bsdgames/files/patch-adventure::crc.c
deleted file mode 100644
index dfca63e6ab53..000000000000
--- a/games/bsdgames/files/patch-adventure::crc.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- adventure/crc.c.bak Sat Feb 23 01:59:45 2002
-+++ adventure/crc.c Wed Sep 29 03:29:37 2004
-@@ -120,7 +120,7 @@
-
- /* Process nr bytes at a time; ptr points to them */
- u_long
--crc(const char *ptr, size_t nr)
-+crc(const char *ptr, ssize_t nr)
- {
- int i;
- const char *p;
diff --git a/games/bsdgames/files/patch-adventure::hdr.h b/games/bsdgames/files/patch-adventure::hdr.h
deleted file mode 100644
index 02344c9191b4..000000000000
--- a/games/bsdgames/files/patch-adventure::hdr.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- adventure/hdr.h.bak Mon Nov 10 15:46:52 2003
-+++ adventure/hdr.h Wed Sep 29 03:30:55 2004
-@@ -167,7 +167,7 @@
- void checkhints (void);
- void ciao (void);
- extern gid_t egid;
--u_long crc (const char *ptr, size_t nr);
-+u_long crc (const char *ptr, ssize_t nr);
- void crc_start (void);
- int dark (void);
- void datime (int *d, int *t);
diff --git a/games/bsdgames/files/patch-battlestar::init.c b/games/bsdgames/files/patch-battlestar::init.c
deleted file mode 100644
index 077107c3e5aa..000000000000
--- a/games/bsdgames/files/patch-battlestar::init.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- battlestar/init.c.old Mon Dec 15 17:48:41 2003
-+++ battlestar/init.c Mon Dec 15 17:48:54 2003
-@@ -62,7 +62,7 @@
- puts("Admiral D.W. Riggle\n");
- srandomdev();
- getutmp(uname);
-- if (startup)
-+ if (startup == NULL)
- location = dayfile;
- wiz = wizard(uname);
- wordinit();
diff --git a/games/bsdgames/files/patch-hack::Makefile b/games/bsdgames/files/patch-hack::Makefile
deleted file mode 100644
index eaa8d43922d1..000000000000
--- a/games/bsdgames/files/patch-hack::Makefile
+++ /dev/null
@@ -1,13 +0,0 @@
-$FreeBSD$
-
---- hack/Makefile.orig Thu Nov 20 11:06:45 2003
-+++ hack/Makefile Thu Nov 20 11:13:27 2003
-@@ -18,6 +18,8 @@
- DPADD= ${LIBTERMCAP} ${LIBCOMPAT}
- LDADD= -ltermcap -lcompat
- CFLAGS+= -fwritable-strings -I${.CURDIR} -I.
-+BINGRP= games
-+BINMODE=2555
- FILES= rumors help hh data
- FILESMODE_rumors= 440
- FILESGRP= ${BINGRP}
diff --git a/games/bsdgames/files/patch-hack::hack.termcap.c b/games/bsdgames/files/patch-hack::hack.termcap.c
deleted file mode 100644
index de8fd532021c..000000000000
--- a/games/bsdgames/files/patch-hack::hack.termcap.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- hack/hack.termcap.c.orig Sat Mar 6 22:18:53 2004
-+++ hack/hack.termcap.c Thu Mar 11 18:42:47 2004
-@@ -35,7 +35,8 @@
- flags.nonull = 1;
- if(pc = tgetstr("pc", &tbufptr))
- PC = *pc;
-- if(!(BC = tgetstr("bc", &tbufptr))) {
-+ if(!(BC = tgetstr("bc", &tbufptr))
-+ &&!(BC = tgetstr("le", &tbufptr))) {
- if(!tgetflag("bs"))
- error("Terminal must backspace.");
- BC = tbufptr;
-
diff --git a/games/bsdgames/files/patch-hack::hack.unix.c b/games/bsdgames/files/patch-hack::hack.unix.c
deleted file mode 100644
index 8143edad035c..000000000000
--- a/games/bsdgames/files/patch-hack::hack.unix.c
+++ /dev/null
@@ -1,13 +0,0 @@
-$FreeBSD$
-
---- hack/hack.unix.c.orig Thu Nov 20 10:17:36 2003
-+++ hack/hack.unix.c Thu Nov 20 10:18:09 2003
-@@ -86,7 +86,7 @@
- /* old version - for people short of space */
- char *np;
-
-- name = "/usr/games/hide/hack";
-+ name = "%%PREFIX%%/bin/hack";
- if(stat(name, &hbuf))
- error("Cannot get status of %s.",
- (np = rindex(name, '/')) ? np+1 : name);
diff --git a/games/bsdgames/files/patch-larn::diag.c b/games/bsdgames/files/patch-larn::diag.c
deleted file mode 100644
index f3cf3d0a5c8b..000000000000
--- a/games/bsdgames/files/patch-larn::diag.c
+++ /dev/null
@@ -1,31 +0,0 @@
-$FreeBSD$
-
---- larn/diag.c 17 Jun 2003 04:25:24 -0000 1.2
-+++ larn/diag.c 21 Jun 2004 02:28:34 -0000 1.3
-@@ -210,7 +210,7 @@
- if (beenhere[k])
- lrfill((char*)&cell[k*MAXX*MAXY],sizeof(struct cel)*MAXY*MAXX);
-
-- lrfill((char*)&c[0],100*sizeof(long)); gtime = lrint();
-+ lrfill((char*)&c[0],100*sizeof(long)); gtime = lrint_x();
- level = c[CAVELEVEL] = lgetc();
- playerx = lgetc(); playery = lgetc();
- lrfill((char*)iven,26); lrfill((char*)ivenarg,26*sizeof(short));
-@@ -241,7 +241,7 @@
- }
-
- time(&zzz);
-- initialtime = zzz-lrint();
-+ initialtime = zzz-lrint_x();
- fstat(fd,&filetimes); /* get the creation and modification time of file */
- lrfill((char*)&zzz,sizeof(long)); zzz += 6;
- if (filetimes.st_ctime > zzz) fsorry(); /* file create time */
-@@ -249,7 +249,7 @@
- if (c[HP]<0) { died(284); return; } /* died a post mortem death */
-
- oldx = oldy = 0;
-- i = lrint(); /* inode # */
-+ i = lrint_x(); /* inode # */
- if (i && (filetimes.st_ino!=i)) fsorry();
- lrclose();
- if (strcmp(fname,ckpfile) == 0)
diff --git a/games/bsdgames/files/patch-larn::header.h b/games/bsdgames/files/patch-larn::header.h
deleted file mode 100644
index ea58c01c7952..000000000000
--- a/games/bsdgames/files/patch-larn::header.h
+++ /dev/null
@@ -1,13 +0,0 @@
-$FreeBSD$
-
---- larn/header.h 17 Jun 2003 02:49:28 -0000 1.1
-+++ larn/header.h 21 Jun 2004 02:28:34 -0000 1.2
-@@ -359,7 +359,7 @@
-
- char *fortune(),*lgetw(),*lgetl();
- char *tmcapcnv();
--long paytaxes(),lgetc(),lrint();
-+long paytaxes(),lgetc(),lrint_x();
- unsigned long readnum();
-
- /* macro to create scroll #'s with probability of occurrence */
diff --git a/games/bsdgames/files/patch-larn::io.c b/games/bsdgames/files/patch-larn::io.c
deleted file mode 100644
index ec579ab00de7..000000000000
--- a/games/bsdgames/files/patch-larn::io.c
+++ /dev/null
@@ -1,31 +0,0 @@
-$FreeBSD$
-
---- larn/io.c 24 Jan 2004 21:00:14 -0000 1.3
-+++ larn/io.c 21 Jun 2004 02:28:34 -0000 1.4
-@@ -25,7 +25,7 @@
- * FILE INPUT ROUTINES
- *
- * long lgetc() read one character from input buffer
-- * long lrint() read one integer from input buffer
-+ * long lrint_x() read one integer from input buffer
- * lrfill(address,number) put input bytes into a buffer
- * char *lgetw() get a whitespace ended word from input
- * char *lgetl() get a \n or EOF ended line from input
-@@ -343,7 +343,7 @@
- }
-
- /*
-- * long lrint() Read one integer from input buffer
-+ * long lrint_x() Read one integer from input buffer
- *
- * +---------+---------+---------+---------+
- * | high | | | low |
-@@ -355,7 +355,7 @@
- * The save order is low order first, to high order (4 bytes total)
- * Returns the int read
- */
--long lrint()
-+long lrint_x()
- {
- unsigned long i;
- i = 255 & lgetc(); i |= (255 & lgetc()) << 8;
diff --git a/games/bsdgames/files/patch-quiz b/games/bsdgames/files/patch-quiz
deleted file mode 100644
index 9f4832ba2ae0..000000000000
--- a/games/bsdgames/files/patch-quiz
+++ /dev/null
@@ -1,175 +0,0 @@
-Index: index
-===================================================================
-RCS file: /ncvs/src/games/quiz/datfiles/index,v
-retrieving revision 1.1.1.1
-diff -u -r1.1.1.1 index
---- quiz/datfiles/index 4 Sep 1994 04:03:09 -0000 1.1.1.1
-+++ quiz/datfiles/index 20 Sep 2002 23:49:50 -0000
-@@ -21,7 +21,7 @@
- /usr/local/local/share/games/quiz.db/murders:victim:killer
- /usr/local/local/share/games/quiz.db/poetry:poem{-}line:next:poem:author
- /usr/local/local/share/games/quiz.db/posneg:pos{itive}:neg{ative}
--/usr/local/local/share/games/quiz.db/pres:pres{ident}:term:succ{essor}
-+/usr/local/local/share/games/quiz.db/pres:pres{ident}:term:vice:succ{essor}
- /usr/local/local/share/games/quiz.db/province:province:cap{ital}
- /usr/local/local/share/games/quiz.db/seq-easy:easy{-}{seq{uence}}:next:name
- /usr/local/local/share/games/quiz.db/seq-hard:hard{-}{seq{uence}}:next:name
-Index: pres
-===================================================================
-RCS file: /ncvs/src/games/quiz/datfiles/pres,v
-retrieving revision 1.1.1.1
-diff -u -r1.1.1.1 pres
---- quiz/datfiles/pres 4 Sep 1994 04:03:10 -0000 1.1.1.1
-+++ quiz/datfiles/pres 20 Sep 2002 23:38:18 -0000
-@@ -1,38 +1,83 @@
--{G{eorge} }Washington:1789-{17}97:{J{ohn} }Adams
--{J{ohn} }Adams:1797-1801:{T{homas} }Jefferson
--{T{homas} }Jefferson:1801-{{18}0}9:{J{ames} }Madison
--{J{ames} }Madison:1809-{18}17:{J{ames} }Monroe
--{J{ames} }Monroe:1817-1825:{J{ohn} }{Q{uincy} }Adams
--{J{ohn} }{Q{uincy} }Adams:1825-{{18}2}9:{A{ndrew} }Jackson
--{A{ndrew} }Jackson:1829-{18}37:{M{artin} }Van Buren
--{M{artin} }Van Buren:1837-{18}41:{W{illiam|m} }{H{enry} }Harrison
--{W{illiam|m} }{H{enry} }Harrison:1841:{J{ohn} }Tyler
--{J{ohn} }Tyler:1841-{{18}4}5:{J{ames} }{K{nox} }Polk
--{J{ames} }{K{nox} }Polk:1845-{{18}4}9:{Z{achary} }Taylor
--{Z{achary} }Taylor:1849-{18}50:{M{illard} }Fillmore
--{M{illard} }Fillmore:1850-{{18}5}3:{F{ranklin} }Pierce
--{F{ranklin} }Pierce:1853-{{18}5}7:{J{ames} }Buchanan
--{J{ames} }Buchanan:1857-{18}61:{A{braham|be} }Lincoln
--{A{braham|be} }Lincoln:1861-{{18}6}5:{A{ndrew} }Johnson
--{A{ndrew} }Johnson:1865-{{18}6}9:{U{lysses} }{S{impson} }Grant
--{U{lysses} }{S{impson} }Grant:1869-{18}77:{R{utherford} }{B{irchard} }Hayes
--{R{utherford} }{B{irchard} }Hayes:1877-{18}81:{J{ames} }{A{bram} }Garfield
--{J{ames} }{A{bram} }Garfield:1881:{C{hester} }{A{lan} }Arthur
--{C{hester} }{A{lan} }Arthur:1881-{{18}8}5:{G{rover} }Cleveland{ (1st term)}
--{G{rover} }Cleveland{ (1st term)}:1885-{{18}8}9:{B{enjamin} }Harrison
--{B{enjamin} }Harrison:1889-{18}93:{G{rover} }Cleveland{ (2nd term)}
--{G{rover} }Cleveland{ (2nd term)}:1893-{18}97:{W{illiam|m} }McKinley
--{W{illiam|m} }McKinley:1897-1901:{T{heodore|eddy} }Roosevelt|TR
--{T{heodore|eddy} }Roosevelt|TR:1901-{{19}0}9:{W{illiam|m} }{H{oward} }Taft
--{W{illiam|m} }{H{oward} }Taft:1909-{19}13:{W{oodrow} }Wilson
--{W{oodrow} }Wilson:1913-{19}21:{W{arren} }{G{amaliel} }Harding
--{W{arren} }{G{amaliel} }Harding:1921-{{19}2}3:{C{alvin} }Coolidge
--{C{alvin} }Coolidge:1923-{{19}2}9:{H{erbert} }Hoover
--{H{erbert} }Hoover:1929-{19}33:{F{ranklin} }{D{elano} }Roosevelt|FDR
--{F{ranklin} }{D{elano} }Roosevelt|FDR:1933-{19}45:{H{arry} }{S }Truman
--{H{arry} }{S }Truman:1945-{19}53:{D{wight} }{D{avid} }Eisenhower
--{D{wight} }{D{avid} }Eisenhower:1953-{19}61:{J{ohn} }{F{itzgerald} }Kennedy|JFK
--{J{ohn} }{F{itzgerald} }Kennedy|JFK:1961-{{19}6}3:{L{yndon} }{B{aines} }Johnson|LBJ
--{L{yndon} }{B{aines} }Johnson|LBJ:1963-{{19}6}9:{R{ichard} }{M{ilhouse} }Nixon
--{R{ichard} }{M{ilhouse} }Nixon:1969-{19}74:{G{erald} }{R{obert} }Ford
--{G{erald} }{R{obert} }Ford:1974-:
-+{G{eorge} }Washington:1789-{17}97:{J{ohn} }Adams:{J{ohn} }Adams
-+{J{ohn} }Adams:1797-1801:{T{homas} }Jefferson:{T{homas} }Jefferson
-+{T{homas} }Jefferson:1801-{{18}0}9:{A{aron} }Burr|{G{eorge} }Clinton:\
-+{J{ames} }Madison
-+{J{ames} }Madison:1809-{18}17:{G{eorge} }Clinton|{E{lbridge} }Gerry:\
-+{J{ames} }Monroe
-+{J{ames} }Monroe:1817-1825:\
-+{D{aniel} }{D{.} }Tompkins:{J{ohn} }{Q{uincy} }Adams
-+{J{ohn} }{Q{uincy} }Adams:1825-{{18}2}9:{J{ohn} }{C{aldwell} }Calhoun:\
-+{A{ndrew} }Jackson
-+{A{ndrew} }Jackson:1829-{18}37:\
-+{J{ohn} }{C{aldwell} }Calhoun|{M{artin} }Van Buren:{M{artin} }Van Buren
-+{M{artin} }Van Buren:1837-{18}41:\
-+{R{ichard} }{M{entor} }Johnson:{W{illiam|m} }{H{enry} }Harrison
-+{W{illiam|m} }{H{enry} }Harrison:1841:{J{ohn} }Tyler:{J{ohn} }Tyler
-+{J{ohn} }Tyler:1841-{{18}4}5:[N|n]one{ (1841-5)}:{J{ames} }{K{nox} }Polk
-+{J{ames} }{K{nox} }Polk:1845-{{18}4}9:\
-+{G{eorge} }{M{ifflin} }Dallas:{Z{achary} }Taylor
-+{Z{achary} }Taylor:1849-{18}50:{M{illard} }Fillmore:{M{illard} }Fillmore
-+{M{illard} }Fillmore:1850-{{18}5}3:[N|n]one{ (1850-3)}:{F{ranklin} }Pierce
-+{F{ranklin} }Pierce:1853-{{18}5}7:\
-+{W{illiam|m} }{R{ufus} }{de Vane }King:{J{ames} }Buchanan
-+{J{ames} }Buchanan:1857-{18}61:\
-+{J{ohn} }{C{abell} }Breckinridge:{A{braham|be} }Lincoln
-+{A{braham|be} }Lincoln:1861-{{18}6}5:\
-+{H{annibal} }Hamlin|{A{ndrew} }Johnson:{A{ndrew} }Johnson
-+{A{ndrew} }Johnson:1865-{{18}6}9:[N|n]one{ (1865-9)}:\
-+{U{lysses} }{S{impson} }Grant
-+{U{lysses} }{S{impson} }Grant:1869-{18}77:\
-+{S{chuyler} }Colfax|{H{enry} }Wilson:{R{utherford} }{B{irchard} }Hayes
-+{R{utherford} }{B{irchard} }Hayes:1877-{18}81:\
-+{W{illiam|m} }{A{lmon} }Wheeler:{J{ames} }{A{bram} }Garfield
-+{J{ames} }{A{bram} }Garfield:1881:\
-+{C{hester} }{A{lan} }Arthur:{C{hester} }{A{lan} }Arthur
-+{C{hester} }{A{lan} }Arthur:1881-{{18}8}5:[N|n]one{ (1881-5)}:\
-+{G{rover} }Cleveland{ (1st term)}
-+{G{rover} }Cleveland{ (1st term)}:1885-{{18}8}9:\
-+{T{homas} }{A{ndrews} }Hendricks:{B{enjamin} }Harrison
-+{B{enjamin} }Harrison:1889-{18}93:\
-+{L{evi} }{P{arsons} }Morton:{G{rover} }Cleveland{ (2nd term)}
-+{G{rover} }Cleveland{ (2nd term)}:1893-{18}97:\
-+{A{dlai} }{E{wing} }Stevenson:{W{illiam|m} }McKinley
-+{W{illiam|m} }McKinley:1897-1901:\
-+{G{arret} }{A{ugustus} }Hobart|{T{heodore|eddy} }Roosevelt|TR:\
-+{T{heodore|eddy} }Roosevelt|TR
-+{T{heodore|eddy} }Roosevelt|TR:1901-{{19}0}9:\
-+{C{harles} }{W{arren} }Fairbanks:{W{illiam|m} }{H{oward} }Taft
-+{W{illiam|m} }{H{oward} }Taft:1909-{19}13:\
-+{J{ames} }{S{choolcraft} }Sherman:{W{oodrow} }Wilson
-+{W{oodrow} }Wilson:1913-{19}21:\
-+{T{homas} }{R{iley} }Marshall:{W{arren} }{G{amaliel} }Harding
-+{W{arren} }{G{amaliel} }Harding:1921-{{19}2}3:{C{alvin} }Coolidge:\
-+{C{alvin} }Coolidge
-+{C{alvin} }Coolidge:1923-{{19}2}9:\
-+{C{harles} }{G{ates} }Dawes:{H{erbert} }{C{lark} }Hoover
-+{H{erbert} }{C{lark} }Hoover:1929-{19}33:\
-+{C{harles} }Curtis:{F{ranklin} }{D{elano} }Roosevelt|FDR
-+{F{ranklin} }{D{elano} }Roosevelt|FDR:1933-{19}45:\
-+{J{ohn} }{N{ance} }Garner|{H{enry} }{A{gard} }Wallace|{H{arry} }{S }Truman:\
-+{H{arry} }{S }Truman
-+{H{arry} }{S }Truman:1945-{19}53:\
-+{A{lben} }{W{illiam} }Barkley:{D{wight} }{D{avid} }Eisenhower
-+{D{wight} }{D{avid} }Eisenhower:1953-{19}61:\
-+{R{ichard} }{M{ilhous} }Nixon:{J{ohn} }{F{itzgerald} }Kennedy|JFK
-+{J{ohn} }{F{itzgerald} }Kennedy|JFK:1961-{{19}6}3:\
-+{L{yndon} }{B{aines} }Johnson|LBJ:{L{yndon} }{B{aines} }Johnson|LBJ
-+{L{yndon} }{B{aines} }Johnson|LBJ:1963-{{19}6}9:\
-+{H{ubert} }{H{oratio} }Humphrey:{R{ichard} }{M{ilhous} }Nixon
-+{R{ichard} }{M{ilhous} }Nixon:1969-{19}74:\
-+{S{piro} }{T{heodore} }Agnew|{G{erald} }{R{udolph} }Ford:\
-+{G{erald} }{R{udolph} }Ford
-+{G{erald} }{R{udolph} }Ford:1974-{{19}7}7:\
-+{N{elson} }{A{ldrich} }Rockefeller:{J{ames} }{E{arl} }Carter{{,} J{unio}r}
-+{J{ames} }{E{arl} }Carter{{,} J{unio}r}:1977-{19}81:\
-+{W{alter} }{F{rederick} }Mondale:{R{onald} }{W{ilson} }Reagan
-+{R{onald} }{W{ilson} }Reagan:1981-{{19}8}9:\
-+{G{eorge} }{H{erbert} }{W{alker} }Bush:{G{eorge} }{H{erbert} }{W{alker} }Bush
-+{G{eorge} }{H{erbert} }{W{alker} }Bush:1989-{19}93:\
-+{J{ames} }{D{anforth|an} }Quayle:{W{illiam|m} }{J{efferson} }Clinton
-+{W{illiam|m} }{J{efferson} }Clinton:1993-2001:\
-+{A{lbert} }{A{rnold} }Gore{{,} J{unio}r}:{G{eorge} }{W{alker} }Bush{{,} J{unio}r}
-+{G{eorge} }{W{alker} }Bush{{,} J{unio}r}:2001-:\
-+{R{ichard} }{B{ruce} }Cheney:
-
-
-
-
---- quiz/datfiles/pres Sat Sep 21 01:38:18 2002
-+++ quiz/datfiles/pres.new Sat Sep 21 20:55:47 2002
-@@ -70,14 +70,17 @@
- {S{piro} }{T{heodore} }Agnew|{G{erald} }{R{udolph} }Ford:\
- {G{erald} }{R{udolph} }Ford
- {G{erald} }{R{udolph} }Ford:1974-{{19}7}7:\
--{N{elson} }{A{ldrich} }Rockefeller:{J{ames} }{E{arl} }Carter{{,} J{unio}r}
--{J{ames} }{E{arl} }Carter{{,} J{unio}r}:1977-{19}81:\
-+{N{elson} }{A{ldrich} }Rockefeller:\
-+{J{ames} }{E{arl} }{(Jimmy) }Carter{{,} J{unio}r}|Jimmy Carter
-+{J{ames} }{E{arl} }{(Jimmy) }Carter{{,} J{unio}r}|Jimmy Carter:1977-{19}81:\
- {W{alter} }{F{rederick} }Mondale:{R{onald} }{W{ilson} }Reagan
- {R{onald} }{W{ilson} }Reagan:1981-{{19}8}9:\
- {G{eorge} }{H{erbert} }{W{alker} }Bush:{G{eorge} }{H{erbert} }{W{alker} }Bush
- {G{eorge} }{H{erbert} }{W{alker} }Bush:1989-{19}93:\
--{J{ames} }{D{anforth|an} }Quayle:{W{illiam|m} }{J{efferson} }Clinton
--{W{illiam|m} }{J{efferson} }Clinton:1993-2001:\
--{A{lbert} }{A{rnold} }Gore{{,} J{unio}r}:{G{eorge} }{W{alker} }Bush{{,} J{unio}r}
-+{J{ames} }{D{anforth|an} }Quayle:\
-+{W{illiam|m} }{J{efferson} }{(Bill) }Clinton|Bill Clinton
-+{W{illiam|m} }{J{efferson} }{(Bill) }Clinton|Bill Clinton:1993-2001:\
-+{A{l{bert}} }{A{rnold} }Gore{{,} J{unio}r}:\
-+{G{eorge} }{W{alker} }Bush{{,} J{unio}r}
- {G{eorge} }{W{alker} }Bush{{,} J{unio}r}:2001-:\
--{R{ichard} }{B{ruce} }Cheney:
-+{R{ichard} }{B{ruce} }{(Dick) }Cheney|Dick Cheney:
diff --git a/games/bsdgames/pkg-descr b/games/bsdgames/pkg-descr
deleted file mode 100644
index 4f0e98eb0b0c..000000000000
--- a/games/bsdgames/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-This is a port of the FreeBSD "standard" games as they were just
-before they were removed from the base system.
-
-This source was formerly a part of the FreeBSD base system, and this
-package is based on the final version of that source code, so it
-includes all previous FreeBSD customizations.
diff --git a/games/bsdgames/pkg-plist b/games/bsdgames/pkg-plist
deleted file mode 100644
index 4c0ebf9239e3..000000000000
--- a/games/bsdgames/pkg-plist
+++ /dev/null
@@ -1,108 +0,0 @@
-@comment $FreeBSD$
-bin/adventure
-bin/arithmetic
-bin/atc
-bin/backgammon
-bin/teachgammon
-bin/battlestar
-bin/bs
-bin/canfield
-bin/cfscores
-bin/cribbage
-bin/fish
-bin/hack
-bin/hangman
-bin/larn
-bin/mille
-bin/phantasia
-bin/piano
-bin/pig
-bin/quiz
-bin/robots
-bin/rogue
-bin/sail
-bin/snake
-bin/snscore
-bin/trek
-bin/worm
-bin/wump
-share/games/atc/Game_List
-share/games/atc/Killer
-share/games/atc/crossover
-share/games/atc/default
-share/games/atc/easy
-share/games/atc/game_2
-@dirrm share/games/atc
-share/games/larn/larnmaze
-share/games/larn/larnopts
-share/games/larn/larn.help
-@dirrm share/games/larn
-share/games/quiz.db/africa
-share/games/quiz.db/america
-share/games/quiz.db/areas
-share/games/quiz.db/arith
-share/games/quiz.db/asia
-share/games/quiz.db/babies
-share/games/quiz.db/bard
-share/games/quiz.db/chinese
-share/games/quiz.db/collectives
-share/games/quiz.db/ed
-share/games/quiz.db/elements
-share/games/quiz.db/europe
-share/games/quiz.db/flowers
-share/games/quiz.db/greek
-share/games/quiz.db/inca
-share/games/quiz.db/index
-share/games/quiz.db/latin
-share/games/quiz.db/locomotive
-share/games/quiz.db/midearth
-share/games/quiz.db/morse
-share/games/quiz.db/murders
-share/games/quiz.db/poetry
-share/games/quiz.db/posneg
-share/games/quiz.db/pres
-share/games/quiz.db/province
-share/games/quiz.db/seq-easy
-share/games/quiz.db/seq-hard
-share/games/quiz.db/sexes
-share/games/quiz.db/sov
-share/games/quiz.db/spell
-share/games/quiz.db/state
-share/games/quiz.db/trek
-share/games/quiz.db/ucc
-@dirrm share/games/quiz.db
-share/games/cribbage.instr
-share/games/fish.instr
-share/games/wump.info
-@dirrm share/games
-@cwd /var/games
-@dirrm atc
-@dirrm battlestar
-hackdir/perm
-hackdir/record
-hackdir/rumors
-hackdir/help
-hackdir/hh
-hackdir/data
-@dirrm hackdir/save
-@dirrm hackdir
-larn/lscore12.0
-larn/llog12.0
-@dirrm larn
-phantasia/characs
-phantasia/gold
-phantasia/lastdead
-phantasia/mess
-phantasia/monsters
-phantasia/motd
-phantasia/scoreboard
-phantasia/void
-@dirrm phantasia
-battlestar.log
-cfscores
-criblog
-robots_roll
-rogue.scores
-saillog
-snakerawscores
-snake.log