aboutsummaryrefslogtreecommitdiff
path: root/games/ctris/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/ctris/Makefile')
-rw-r--r--games/ctris/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/games/ctris/Makefile b/games/ctris/Makefile
new file mode 100644
index 000000000000..b807e0a5cd9e
--- /dev/null
+++ b/games/ctris/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: ctetris
+# Date created: 14 Aug 2004
+# Whom: Travis Poppe <tlp@liquidx.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ctetris
+PORTVERSION= 0.26
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= tlp@liquidx.org
+COMMENT= Beautiful tetris clone written in C using the ncurses library
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+
+MAN1= ctetris.1
+PLIST_FILES= bin/ctetris
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|gcc|${CC}|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|termio.h|termios.h|' ${WRKSRC}/ctetris.h
+
+do-install:
+ ${INSTALL_MAN} ${WRKSRC}/ctetris.1 ${PREFIX}/man/man1/ctetris.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/ctetris ${PREFIX}/bin/ctetris
+
+.include <bsd.port.mk>