aboutsummaryrefslogtreecommitdiff
path: root/games/fteqw/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/fteqw/Makefile')
-rw-r--r--games/fteqw/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/games/fteqw/Makefile b/games/fteqw/Makefile
index 222e9f726fcb..79b5a60ae791 100644
--- a/games/fteqw/Makefile
+++ b/games/fteqw/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fteqw
PORTVERSION= 3343
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/Source/${PORTVERSION}
DISTNAME= ftesrc${PORTVERSION}-all
@@ -42,8 +42,9 @@ FTE_TARGETS+= fteqw.sv
.if !defined(WITHOUT_GL) || !defined(WITHOUT_SDL)
LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png \
+ png15:${PORTSDIR}/graphics/png \
vorbis.4:${PORTSDIR}/audio/libvorbis
+CFLAGS+= -I${LOCALBASE}/include/libpng15
.endif
.if !defined(WITHOUT_GL)
@@ -71,11 +72,6 @@ post-patch:
${WRKSRC}/gl/gl_alias.c ${WRKSRC}/common/com_mesh.c
@${REINPLACE_CMD} -e 's/__linux__/__unix__/' \
${WRKSRC}/common/plugin.c ${WRKSRC}/server/svq3_game.c
-# Resolve name collision with jpeg-8 and API png14
- ${REINPLACE_CMD} -e 's|jpeg_mem_src|local_jpeg_mem_src|' \
- -e 's|jpeg_mem_dest|local_jpeg_mem_dest|' \
- -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \
- ${WRKSRC}/client/image.c
do-install:
.for f in ${FTE_TARGETS}