aboutsummaryrefslogtreecommitdiff
path: root/games/ggz-sdl-games/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/ggz-sdl-games/Makefile')
-rw-r--r--games/ggz-sdl-games/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/games/ggz-sdl-games/Makefile b/games/ggz-sdl-games/Makefile
index b1eaa044f2cb..f5acad194285 100644
--- a/games/ggz-sdl-games/Makefile
+++ b/games/ggz-sdl-games/Makefile
@@ -7,26 +7,22 @@
#
PORTNAME= ggz-sdl-games
-PORTVERSION= 0.0.13
-PORTREVISION= 1
+PORTVERSION= ${GGZ_VERSION}
CATEGORIES= games
-MASTER_SITES= http://mirrors.dotsrc.org/ggzgamingzone/ggz/%SUBDIR%/ \
- http://ftp.ggzgamingzone.org/pub/ggz/%SUBDIR%/
-MASTER_SITE_SUBDIR= ${PORTVERSION}
-DIST_SUBDIR= ggz
MAINTAINER= yinjieh@csie.nctu.edu.tw
COMMENT= The GGZ Gaming Zone - SDL-based games
-LIB_DEPENDS= ggzcore.8:${PORTSDIR}/games/ggz-client-libs
-
USE_GETOPT_LONG= yes
USE_SDL= image mixer sdl ttf
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-debug
+USE_GGZ= client
CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/games/libggz/bsd.ggz.mk"
+.include <bsd.port.post.mk>