aboutsummaryrefslogtreecommitdiff
path: root/games/gnomebreakout/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/gnomebreakout/Makefile')
-rw-r--r--games/gnomebreakout/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/games/gnomebreakout/Makefile b/games/gnomebreakout/Makefile
index b1a88e1bf6e8..a39e431b2e7b 100644
--- a/games/gnomebreakout/Makefile
+++ b/games/gnomebreakout/Makefile
@@ -13,15 +13,11 @@ DISTNAME= gnome-breakout-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs
-RUN_DEPENDS= panel:${PORTSDIR}/x11/gnomecore
-
-USE_X_PREFIX= YES
-GNU_CONFIGURE= YES
+USE_X_PREFIX= yes
+USE_GNOME= yes
+GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome/ \
- --datadir=${PREFIX}/share/gnome
pre-patch:
@${PERL} -pi -e 's|-lpthread|-pthread|g ; \