aboutsummaryrefslogtreecommitdiff
path: root/games/linux-enemyterritory-omni-bot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/linux-enemyterritory-omni-bot/Makefile')
-rw-r--r--games/linux-enemyterritory-omni-bot/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/games/linux-enemyterritory-omni-bot/Makefile b/games/linux-enemyterritory-omni-bot/Makefile
index d0e3b147a04c..2299b2f33cd5 100644
--- a/games/linux-enemyterritory-omni-bot/Makefile
+++ b/games/linux-enemyterritory-omni-bot/Makefile
@@ -21,13 +21,13 @@ USE_ZIP= yes
USE_LINUX= yes
NO_WRKSUBDIR= yes
-DATADIR= ${PREFIX}/lib/enemyterritory
+DATADIR= ${PREFIX}/lib/enemyterritory/${PORTNAME}
DOCSDIR= ${PREFIX}/share/doc/enemyterritory-${PORTNAME}
do-build:
.for f in et etded
- @(${ECHO} "#!/bin/sh"; \
- ${ECHO} 'exec ${PREFIX}/bin/${f} +set fs_game ${PORTNAME} +set omnibot_path "${DATADIR}/omni-bot" "$$@"') > \
+ @(${ECHO_CMD} "#!/bin/sh"; \
+ ${ECHO_CMD} 'exec ${PREFIX}/bin/${f} +set fs_game ${PORTNAME} +set omnibot_path "${DATADIR}/omni-bot" "$$@"') > \
${WRKSRC}/${f}-${PORTNAME}
.endfor
@@ -35,14 +35,11 @@ do-install:
.for f in et etded
${INSTALL_SCRIPT} ${WRKSRC}/${f}-${PORTNAME} ${PREFIX}/bin
.endfor
- ${MKDIR} ${DATADIR}/${PORTNAME}
- ${INSTALL_PROGRAM} ${WRKSRC}/omni-bot/omnibot_et.so \
- ${DATADIR}/${PORTNAME}
- cd ${WRKSRC}/omni-bot && ${CP} -R et global_scripts \
- ${DATADIR}/${PORTNAME}
- ${INSTALL_PROGRAM} ${WRKSRC}/omnibot/qagame.mp.i386.so \
- ${DATADIR}/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/omnibot/omnibot_et.pk3 ${DATADIR}/${PORTNAME}
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/omni-bot/omnibot_et.so ${DATADIR}
+ cd ${WRKSRC}/omni-bot && ${CP} -R et global_scripts ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/omnibot/qagame.mp.i386.so ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/omnibot/omnibot_et.pk3 ${DATADIR}
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
. for f in *.txt omni-bot/*.txt