aboutsummaryrefslogtreecommitdiff
path: root/games/neo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/neo/Makefile')
-rw-r--r--games/neo/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/games/neo/Makefile b/games/neo/Makefile
new file mode 100644
index 000000000000..b788ae239334
--- /dev/null
+++ b/games/neo/Makefile
@@ -0,0 +1,37 @@
+PORTNAME= neo
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.6
+CATEGORIES= games
+
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${PORTNAME}/commit/
+PATCHFILES= 4dd64a0.patch:-p1 # https://github.com/st3w/neo/issues/8
+
+MAINTAINER= driesm@FreeBSD.org
+COMMENT= cmatrix clone with 32-bit color and Unicode support
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= autoconf-archive>=0:devel/autoconf-archive
+
+USES= autoreconf compiler:c++11-lang ncurses
+USE_GITHUB= yes
+GH_ACCOUNT= st3w
+
+GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/neo \
+ share/man/man6/neo.6.gz
+PORTDOCS= README
+
+OPTIONS_DEFINE= DOCS
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/neo ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/doc/neo.6 ${STAGEDIR}${MANPREFIX}/share/man/man6
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>