aboutsummaryrefslogtreecommitdiff
path: root/games/nethack33
diff options
context:
space:
mode:
Diffstat (limited to 'games/nethack33')
-rw-r--r--games/nethack33/Makefile8
-rw-r--r--games/nethack33/files/patch-ad2
2 files changed, 5 insertions, 5 deletions
diff --git a/games/nethack33/Makefile b/games/nethack33/Makefile
index 2a4b2e21cf2d..83b6faa656cb 100644
--- a/games/nethack33/Makefile
+++ b/games/nethack33/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nethack
PORTVERSION= 3.3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= nethack
@@ -23,14 +23,14 @@ NO_LATEST_LINK= yes
USE_GMAKE= yes
USE_REINPLACE= yes
-MAKE_ENV= CXX="${CXX}" GRAPHICS="${GRAPHICS}"
+MAKE_ENV= CXX="${CXX}" GRAPHICS="${GRAPHICS}" LDFLAGS="${LDFLAGS}"
MAN6= dgn_comp.6 dlb.6 lev_comp.6 nethack.6 recover.6
.if defined(WITH_GNOME_GRAPHICS)
CATEGORIES= games gnome
PKGNAMESUFFIX= -gnome
-LIB_DEPENDS+= gnugetopt:${PORTSDIR}/devel/libgnugetopt
+USE_GETOPT_LONG=yes
USE_GNOME= yes
GRAPHICS= GNOME_GRAPHICS
.elif defined(WITH_QT_GRAPHICS)
@@ -49,7 +49,7 @@ GRAPHICS= X11_GRAPHICS
.include <bsd.port.pre.mk>
.if defined(WITH_QT_GRAPHICS) && ${OSVERSION} >= 500113
-BROKEN= "Does not build"
+BROKEN= "Does not build"
.endif
pre-everything::
diff --git a/games/nethack33/files/patch-ad b/games/nethack33/files/patch-ad
index 51e4a09f5a54..2053453e3489 100644
--- a/games/nethack33/files/patch-ad
+++ b/games/nethack33/files/patch-ad
@@ -79,7 +79,7 @@
#
# libraries for Gnome
-WINGNOMELIB = -lgnomeui -lgnome -lart_lgpl -lgtk -lgdk -lpopt
-+WINGNOMELIB = $(shell ${GNOME_CONFIG} --libs gnomeui) -lgnugetopt
++WINGNOMELIB = $(shell ${GNOME_CONFIG} --libs gnomeui) ${LDFLAGS}
#
# libraries for Gem port
WINGEMLIB = -le_gem -lgem