aboutsummaryrefslogtreecommitdiff
path: root/games/noegnud-nethack/files/patch-variants::Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/noegnud-nethack/files/patch-variants::Makefile')
-rw-r--r--games/noegnud-nethack/files/patch-variants::Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/games/noegnud-nethack/files/patch-variants::Makefile b/games/noegnud-nethack/files/patch-variants::Makefile
new file mode 100644
index 000000000000..64a0919d8c0d
--- /dev/null
+++ b/games/noegnud-nethack/files/patch-variants::Makefile
@@ -0,0 +1,51 @@
+--- variants/Makefile.orig Mon Nov 15 03:02:30 2004
++++ variants/Makefile Mon Nov 15 03:03:25 2004
+@@ -1,7 +1,6 @@
+ NOEGNUDVERSION=noegnud-0.8.0
+ # you __MUST__ change this if you change the prefix for any variants' install !!!!!!!!!!!!!
+ # although ..... " make -e foo " also works :O ;)
+-PREFIX = /usr/local
+ GAMEUID = games
+ GAMEGRP = bin
+ CHOWN = chown
+@@ -62,31 +61,31 @@
+ install: install_all
+
+ install_nh342: nh342
+- make -e -C $(NOEGNUDVERSION)-nethack-3.4.2 install
++ make -EPREFIX -C $(NOEGNUDVERSION)-nethack-3.4.2 install
+
+ install_nh343: nh343
+- make -e -C $(NOEGNUDVERSION)-nethack-3.4.3 install
++ make -EPREFIX -C $(NOEGNUDVERSION)-nethack-3.4.3 install
+
+ install_se006e4f8: se006e4f8
+- make -e -C $(NOEGNUDVERSION)-slashem-0.0.6E4F8 install
++ make -EPREFIX -C $(NOEGNUDVERSION)-slashem-0.0.6E4F8 install
+
+ install_se007e2: se007e2
+- make -e -C $(NOEGNUDVERSION)-slashem-0.0.7E2 install
++ make -EPREFIX -C $(NOEGNUDVERSION)-slashem-0.0.7E2 install
+
+ install_se007e5: se007e5
+- make -e -C $(NOEGNUDVERSION)-slashem-0.0.7E5 install
++ make -EPREFIX -C $(NOEGNUDVERSION)-slashem-0.0.7E5 install
+
+ install_se007e6: se007e6
+- make -e -C $(NOEGNUDVERSION)-slashem-0.0.7E6 install
++ make -EPREFIX -C $(NOEGNUDVERSION)-slashem-0.0.7E6 install
+
+ install_se007e6f2: se007e6f2
+- make -e -C $(NOEGNUDVERSION)-slashem-0.0.7E6F2 install
++ make -EPREFIX -C $(NOEGNUDVERSION)-slashem-0.0.7E6F2 install
+
+ install_lh001: lh001
+- make -e -C $(NOEGNUDVERSION)-littlehack-0.0.1 install
++ make -EPREFIX -C $(NOEGNUDVERSION)-littlehack-0.0.1 install
+
+ install_nh342-dt: nh342-dt
+- make -e -C $(NOEGNUDVERSION)-nethack-3.4.2-deet install
++ make -EPREFIX -C $(NOEGNUDVERSION)-nethack-3.4.2-deet install
+
+ # data
+