aboutsummaryrefslogtreecommitdiff
path: root/games/noegnud-nethack
diff options
context:
space:
mode:
Diffstat (limited to 'games/noegnud-nethack')
-rw-r--r--games/noegnud-nethack/Makefile4
-rw-r--r--games/noegnud-nethack/files/patch-noegnud_noegnud_gui.c11
2 files changed, 11 insertions, 4 deletions
diff --git a/games/noegnud-nethack/Makefile b/games/noegnud-nethack/Makefile
index dd0b88d4ca33..3b769b6e48d4 100644
--- a/games/noegnud-nethack/Makefile
+++ b/games/noegnud-nethack/Makefile
@@ -35,10 +35,6 @@ INSTALL_TARGET= install_nh343
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
pre-everything::
.if ${HAVE_SDL}
@${ECHO_MSG} "This port depends on SDL with OpenGL support."
diff --git a/games/noegnud-nethack/files/patch-noegnud_noegnud_gui.c b/games/noegnud-nethack/files/patch-noegnud_noegnud_gui.c
new file mode 100644
index 000000000000..420fb13f3009
--- /dev/null
+++ b/games/noegnud-nethack/files/patch-noegnud_noegnud_gui.c
@@ -0,0 +1,11 @@
+--- noegnud/noegnud_gui.c.orig 2007-10-02 14:32:19.000000000 +0200
++++ noegnud/noegnud_gui.c 2007-10-02 14:32:30.000000000 +0200
+@@ -627,7 +627,7 @@
+ //button=(noegnud_gui_tbutton *)noegnud_gui_create_window(parent,x,y,width,height,(sizeof(noegnud_gui_twindow)-sizeof(noegnud_gui_twidget))+datasize);
+
+ text=noegnud_gui_create_text(
+- (noegnud_gui_twidget *)button=(noegnud_gui_tbutton *)noegnud_gui_create_window(
++ button=(noegnud_gui_tbutton *)noegnud_gui_create_window(
+ parent,
+ x,y,
+ width,height,