aboutsummaryrefslogtreecommitdiff
path: root/games/pmars/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/pmars/Makefile')
-rw-r--r--games/pmars/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/games/pmars/Makefile b/games/pmars/Makefile
index 3d2c064aa915..1ab72d959556 100644
--- a/games/pmars/Makefile
+++ b/games/pmars/Makefile
@@ -7,10 +7,9 @@
PORTNAME= pmars
PORTVERSION= 0.9.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= corewar
+MASTER_SITES= SF/corewar
MAINTAINER= alepulver@FreeBSD.org
COMMENT= A portable corewar system with ICWS'94 extensions
@@ -70,11 +69,11 @@ MAKE_ARGS+= CFLAGS+="-DSMALLMEM"
.endif
.if !defined(WITHOUT_X11)
-USE_XLIB= yes
+USE_XORG= x11
TARGETS+= x11
X11_ARGS+= CFLAGS+="-DXWINGRAPHX" \
- CFLAGS+="-I${X11BASE}/include" \
- LIB+="-L${X11BASE}/lib -lX11"
+ CFLAGS+="-I${LOCALBASE}/include" \
+ LIB+="-L${LOCALBASE}/lib -lX11"
PLIST_SUB+= X11=""
.else
PLIST_SUB+= X11="@comment "